Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [Invalid]: Убрать водяные знаки с промежуточных из&  (Read 5722 times)

0 Members and 1 Guest are viewing this topic.

Cubatao

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 90

Собственно проблема в названии. В "Конфигурации" убирал обе галочки "Накладывать водяной знак на изображения" и "Накладывать водяной знак на миниатюры (видео, аудио, документы)". Потом удалял "Промежуточные изображения", по новой обновлял "Промежуточные и полноразмерные (если доступна оригинальная копия)" и в итоге получал промежуточные с водяным знаком.
Началось всё из-за того, что в логах увидел ошибку по одному файлу и решил "Перезагрузить информацию о размере и объеме файлов". В итоге размеры не совпадали и был наложен водяной знак. До этого его НЕ было. Подскажите, как быть. Не нужен он мне пока. Блин, если бы я не перезагрузил информацию, так и был бы без водяного знака.
CPG 1.5.3 RC
« Last Edit: May 15, 2010, 12:30:24 am by Makc666 »
Logged

Cubatao

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 90

В общем, пока просто переименовал файл водяного знака и обновил промежуточные изображения. Но вопрос открыт.
Logged

TV-child

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 110
  • Не падай духом, ушибёшься телом!
    • фотожабы, фотомонтаж

А не подскажете где и в како и функций эти водяные знаки вообще включаются/выкоючаются?
Logged

Cubatao

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 90

"Конфигурация"--->"Настройки водяных знаков"
Logged

Makc666

  • Moderator
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 1614
  • Русский (ISO-8859-1) - Russian - Русский (Windows)
    • Makc's home page

В общем, пока просто переименовал файл водяного знака и обновил промежуточные изображения. Но вопрос открыт.

Вы можете описать проблему по шагам?
Воспроизводится ли она всегда?
Какой инструмент обработки изображений используете?
С каким типом файлов данная проблема возникает?
Logged

Cubatao

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 90

В общем получается так. В данный момент файл водянного знака переименован, соответственно все изображения без него. Если я его переименую обратно (в оригинал) и потом сделаю "Обновить миниатюры и/или измененные изображения", то водянной знак будет наложен на промежуточные изображения, хотя в "Конфигурации" он выключен, где только можно.
Самое интересное, что после переименования файла в другой, на некоторых изображениях он остаётся, но это похоже на что-то типа кукисов, что ли. Потому как потом, через некоторое время, водяной знак пропадает.
Инструмент обработки GD version 2.x
Типы файлов jpeg.
Logged

Cubatao

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 90

Мда-а-а. Извиняюсь за созданную мною тему... Весь баг оказался в Опере, блин. В общем получается так. Ставлю галку "Ставить водяной знак на изображения", в "Инструментах администратора" обновляю изображения, получаю водяной знак на них. Далее, убираю галку, обновляю изображения и вуаля... Водяной знак присутствует на картинках!!!!! Блин. Всю голову сломал. Решил посмотреть как это всё выглядит в IE. Посмотрел и удивился (только не знаю, приятно или нет). Водяных знаков нет. Проделываю всё по новой (все операции делал в Опере, в IE только просматривал) и всё работает как и должно!!! Блин, ну нафига так делать? Я "производителей" софта имею ввиду. Хотя на данный момент поимели меня... >:( >:(
Logged

TV-child

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 110
  • Не падай духом, ушибёшься телом!
    • фотожабы, фотомонтаж

Мда-а-а. Извиняюсь за созданную мною тему... Весь баг оказался в Опере, блин. В общем получается так. Ставлю галку "Ставить водяной знак на изображения", в "Инструментах администратора" обновляю изображения, получаю водяной знак на них. Далее, убираю галку, обновляю изображения и вуаля... Водяной знак присутствует на картинках!!!!! Блин. Всю голову сломал. Решил посмотреть как это всё выглядит в IE. Посмотрел и удивился (только не знаю, приятно или нет). Водяных знаков нет. Проделываю всё по новой (все операции делал в Опере, в IE только просматривал) и всё работает как и должно!!! Блин, ну нафига так делать? Я "производителей" софта имею ввиду. Хотя на данный момент поимели меня... >:( >:(
Да может это для экономии траффика делается. Лежат у тебя в темпорари картинки - ну и пусть лежат, зачем их опять грузить поновой. А "Ctr+F5" в 0pera тоже на помогал?
Logged

Cubatao

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 90

В том-то и дело, что хоть за открывайся картинки, заобновляйся страницу. Блин, кэш это хорошо, но... Засада в обчем.
Logged

TV-child

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 110
  • Не падай духом, ушибёшься телом!
    • фотожабы, фотомонтаж

В том-то и дело, что хоть за открывайся картинки, заобновляйся страницу. Блин, кэш это хорошо, но... Засада в обчем.
Ну, это еще может быть настройка в опере, "для экономии траффика" или что-нибудь такое. Просто странно чтобы Опера и так глючила.
Logged
Pages: [1]   Go Up
 

Page created in 0.029 seconds with 22 queries.