Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Batch Upload not seeing folders  (Read 4600 times)

0 Members and 2 Guests are viewing this topic.

bcossel

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Batch Upload not seeing folders
« on: February 06, 2007, 02:05:44 pm »

Hi everyone,

Having a problem with the batch upload.  I've created several sub-folders under the albums directory for admin upload.  When I go to the batch upload it tells me no folders exists under the albums directory.

http://www.cosselphotography.com/cpg1410/index.php
user/pw: test

any help would be appreciated.  I read through the docs, made sure my permissions were set correctly, so I'm at a loss right now why the application sin't seeing the newly created directories.

Thanks,
Benjamin
« Last Edit: February 06, 2007, 03:54:52 pm by Nibbler »
Logged

Hein Traag

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: nl
  • Offline Offline
  • Gender: Male
  • Posts: 2166
  • A, B, Cpg
    • Personal website - Spintires.nl
Re: Batch Upload not seeing folders
« Reply #1 on: February 06, 2007, 02:48:49 pm »

Did you read this ? http://coppermine-gallery.net/demo/cpg14x/docs/index.htm#batch_add_pics
Also read the sticky post at top of the Upload categorie, it has a lot of info on how to troubleshoot upload problems. http://forum.coppermine-gallery.net/index.php?topic=24088.0

Try setting the folders to 777 using FTP. Then try to batch add again. Batch add needs to be able to write into the folders where the pictures have been uploaded to. If those are not set 777 then batch add can not do anything.

Since this is your first post i would also suggest to use the search function a bit before posting a questions which might have already been answered before.

Regards,
Hein
Logged

bcossel

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Batch Upload not seeing folders
« Reply #2 on: February 06, 2007, 02:52:46 pm »

I reckon I should have been a little bit more specific.  Yes, I did search the forums and didn't see anything though I'll completely admit I might have just missed it.  I also read the docs.  I created the folders, as the docs state, via my ftp client (ws-ftp) since this is a windows based server, I think went into the domain manager and set the permissions on the albums folder and all sub-folders to full control and still nothing.
Logged

bcossel

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Batch Upload not seeing folders
« Reply #3 on: February 06, 2007, 02:54:19 pm »

Did you read this ? http://coppermine-gallery.net/demo/cpg14x/docs/index.htm#batch_add_pics
Also read the sticky post at top of the Upload categorie, it has a lot of info on how to troubleshoot upload problems. http://forum.coppermine-gallery.net/index.php?topic=24088.0

Try setting the folders to 777 using FTP. Then try to batch add again. Batch add needs to be able to write into the folders where the pictures have been uploaded to. If those are not set 777 then batch add can not do anything.

Since this is your first post i would also suggest to use the search function a bit before posting a questions which might have already been answered before.

Regards,
Hein

Hein,

Another thought, if it was a permissions issue, wouldn't the program at least be able to see the folders? The batch upload is telling me no folders exist.
Logged

bcossel

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Batch Upload not seeing folders
« Reply #4 on: February 06, 2007, 02:58:22 pm »

I turned on debug and this is what I'm getting. Again, I'll totlaly submit that somehow I'm being a taterhead on this, but I'm just not seeing it.  Thanks in advance.

Code: [Select]
USER:
------------------
Array
(
    [ID] => 14072d2830e913c4b7f3f52696c07590
    [am] => 1
    [lang] => english
    [liv] => Array
        (
        )

)

==========================
USER DATA:
------------------
Array
(
    [user_id] => 3
    [user_name] => Benjamin
    [groups] => Array
        (
            [0] => 1
        )

    [disk_max] => 0
    [disk_min] => 0
    [can_rate_pictures] => 1
    [can_send_ecards] => 1
    [ufc_max] => 3
    [ufc_min] => 3
    [custom_user_upload] => 0
    [num_file_upload] => 5
    [num_URI_upload] => 3
    [can_post_comments] => 1
    [can_upload_pictures] => 1
    [can_create_albums] => 1
    [has_admin_access] => 1
    [pub_upl_need_approval] => 0
    [priv_upl_need_approval] => 0
    [group_name] => Administrators
    [upload_form_config] => 3
    [group_quota] => 0
    [can_see_all_albums] => 1
    [group_id] => 1
)

==========================
Queries:
------------------
Array
(
    [0] => SELECT extension, mime, content, player FROM cpg1410_filetypes; (0.001s)
    [1] => select * from cpg1410_plugins order by priority asc; (0.001s)
    [2] => delete from `cosselphotography`.cpg1410_sessions where time<1170766527 and remember=0; (0.001s)
    [3] => delete from `cosselphotography`.cpg1410_sessions where time<1169560527; (0s)
    [4] => select user_id from `cosselphotography`.cpg1410_sessions where session_id=md5("8280ed04dcdc0e0db8570eb8d75dde3b47a72899f8277694a26ed1484954017a"); (0.001s)
    [5] => select user_id as id, user_password as password from `cosselphotography`.cpg1410_users where user_id=3 (0s)
    [6] => SELECT u.user_id AS id, u.user_name AS username, u.user_password AS password, u.user_group+100 AS group_id FROM `cosselphotography`.cpg1410_users AS u INNER JOIN `cosselphotography`.cpg1410_usergroups AS g ON u.user_group=g.group_id WHERE u.user_id='3' (0s)
    [7] => SELECT user_group_list FROM `cosselphotography`.cpg1410_users AS u WHERE user_id='3' and user_group_list <> ''; (0s)
    [8] => SELECT MAX(group_quota) as disk_max, MIN(group_quota) as disk_min, MAX(can_rate_pictures) as can_rate_pictures, MAX(can_send_ecards) as can_send_ecards, MAX(upload_form_config) as ufc_max, MIN(upload_form_config) as ufc_min, MAX(custom_user_upload) as custom_user_upload, MAX(num_file_upload) as num_file_upload, MAX(num_URI_upload) as num_URI_upload, MAX(can_post_comments) as can_post_comments, MAX(can_upload_pictures) as can_upload_pictures, MAX(can_create_albums) as can_create_albums, MAX(has_admin_access) as has_admin_access, MIN(pub_upl_need_approval) as pub_upl_need_approval, MIN( priv_upl_need_approval) as  priv_upl_need_approval FROM cpg1410_usergroups WHERE group_id in (1) (0.002s)
    [9] => SELECT group_name FROM  cpg1410_usergroups WHERE group_id= 1 (0s)
    [10] => update `cosselphotography`.cpg1410_sessions set time='1170770127' where session_id=md5('8280ed04dcdc0e0db8570eb8d75dde3b47a72899f8277694a26ed1484954017a'); (0.001s)
    [11] => SELECT user_favpics FROM cpg1410_favpics WHERE user_id = 3 (0.008s)
    [12] => DELETE FROM cpg1410_banned WHERE expiry < '2007-02-06 18:55:27' (0.001s)
    [13] => SELECT * FROM cpg1410_banned WHERE (ip_addr='65.24.110.62' OR ip_addr='65.24.110.62' OR user_id=3) AND brute_force=0 (0s)
    [14] => SELECT aid, title FROM cpg1410_albums WHERE 1 (0s)
    [15] => SELECT COUNT(*) FROM cpg1410_pictures WHERE approved = 'NO' (0s)
)

==========================
GET :
------------------
Array
(
)

==========================
POST :
------------------
Array
(
)

==========================
VERSION INFO :
------------------
PHP version: 5.2.0 - OK
------------------
mySQL version: 4.1.20-community-max-nt
------------------
Coppermine version: 1.4.10(stable)
==========================
Module: GD
------------------
GD Version: bundled (2.0.28 compatible)
FreeType Support: 1
FreeType Linkage: with freetype
T1Lib Support: 1
GIF Read Support: 1
GIF Create Support: 1
JPG Support: 1
PNG Support: 1
WBMP Support: 1
XPM Support:
XBM Support: 1
JIS-mapped Japanese Font Support:

==========================
Module: mysql
------------------
MySQL Supportenabled
Active Persistent Links 0
Active Links 1
Client API version 4.1.7
==========================
Module: zlib
------------------
ZLib Support enabled
Stream Wrapper support compress.zlib://
Stream Filter support zlib.inflate, zlib.deflate
Compiled Version 1.2.3
Linked Version 1.2.3
==========================
Server restrictions (safe mode)?
------------------
Directive | Local Value | Master Value
safe_mode | Off | Off
safe_mode_exec_dir | no value | no value
safe_mode_gid | Off | Off
safe_mode_include_dir | no value | no value
safe_mode_exec_dir | no value | no value
sql.safe_mode | Off | Off
disable_functions | no value | no value
file_uploads | On | On
include_path | .;C:\php\pear;C:\php\pear\pear | .;C:\php\pear;C:\php\pear\pear
open_basedir | no value | no value
==========================
email
------------------
Directive | Local Value | Master Value
sendmail_from | raptor8php@nextmill.net | raptor8php@nextmill.net
sendmail_path | no value | no value
SMTP | mail1.nextmill.net | mail1.nextmill.net
smtp_port | 25 | 25
==========================
Size and Time
------------------
Directive | Local Value | Master Value
max_execution_time | 180 | 180
max_input_time | 180 | 180
upload_max_filesize | 10M | 10M
post_max_size | 8M | 8M
==========================
Page generated in 0.134 seconds - 16 queries in 0.016 seconds - Album set : ; Meta set: ;
« Last Edit: February 06, 2007, 03:00:16 pm by Hein »
Logged

Hein Traag

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: nl
  • Offline Offline
  • Gender: Male
  • Posts: 2166
  • A, B, Cpg
    • Personal website - Spintires.nl
Re: Batch Upload not seeing folders
« Reply #5 on: February 06, 2007, 03:03:05 pm »

Is the path to where the albums can be found set to /albums in the configuration page of CPG ?

(hint: when posting something as large a debug list use the little # to post it as code. This puts the large text block into its own screen)
Logged

bcossel

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Batch Upload not seeing folders
« Reply #6 on: February 06, 2007, 03:06:53 pm »

Is the path to where the albums can be found set to /albums in the configuration page of CPG ?

(hint: when posting something as large a debug list use the little # to post it as code. This puts the large text block into its own screen)

Sorry about that, I will make sure to do that in the future.
Logged

bcossel

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Batch Upload not seeing folders
« Reply #7 on: February 06, 2007, 03:12:36 pm »

Is the path to where the albums can be found set to /albums in the configuration page of CPG ?

(hint: when posting something as large a debug list use the little # to post it as code. This puts the large text block into its own screen)

Yes, it is set to albums/ in the configuration.
Logged

Hein Traag

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: nl
  • Offline Offline
  • Gender: Male
  • Posts: 2166
  • A, B, Cpg
    • Personal website - Spintires.nl
Re: Batch Upload not seeing folders
« Reply #8 on: February 06, 2007, 03:25:34 pm »

I think this thread might hold the solution to your problem

http://forum.coppermine-gallery.net/index.php?topic=39453.0
or http://forum.coppermine-gallery.net/index.php?topic=39397.0

Try using the classic interface with batch adding pictures.

Hein
Logged

bcossel

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Batch Upload not seeing folders
« Reply #9 on: February 06, 2007, 03:28:15 pm »

I think this thread might hold the solution to your problem

http://forum.coppermine-gallery.net/index.php?topic=39453.0

Like I said man, entirely possible I'm being a taterhead.  THanks for the link that seems to have done the trick and I can certianly empathize with the original poster......on all counts.

Thanks.
Benjamin
Logged
Pages: [1]   Go Up
 

Page created in 0.023 seconds with 20 queries.