Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Fehler bei der Albendarstellung nach Update auf 1.5.26  (Read 5747 times)

0 Members and 1 Guest are viewing this topic.

berni

  • Coppermine frequent poster
  • ***
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 100
    • Bei Berni
Fehler bei der Albendarstellung nach Update auf 1.5.26
« on: February 08, 2014, 11:12:14 pm »

Hallo André,
ich habe das Theme chaoticsoul und nach dem Update werden die Alben nicht mehr richtig dargestellt. Seltsamer Weise nicht alle aber bei einigen tritt der Fehler auf.
Ich kann nur schlecht erklären, was ich meine deshalb siehst Du es Dir am Besten selbst an.
Im Gebrauch habe ich zur Zeit noch die Version 1.5.24 und da ist alles okay, siehe hier http://bgollin.homepage.t-online.de/Galerie/index.php?cat=0
Die neue Version ist hier http://bgollin.homepage.t-online.de/neuGalerie/index.php?cat=0
Den Fehler siehst Du, wenn Du das Album "Bernd Gollin" oder "Kinder" öffnest. Merkwürdig ist für mich halt, dass der Fehler nicht bei allen Alben auftritt. Vielleicht kannst
Du mir einen Tipp geben, wo ich suchen und ändern muß. Bei den originalen Themes scheint alles in Ordnung zu sein. Leider ist mein Englisch nicht gut genug um mich
direkt an Jeff Bailey zu wenden, der das Theme wohl umgesetzt hat. Solltest Du noch irgend etwas an Informationen oder einen Admin-Zugang brauchen, laß es mich bitte wissen.
Vielen Dank im Voraus, Bernd
Logged

Αndré

  • Administrator
  • Coppermine addict
  • ****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: Fehler bei der Albendarstellung nach Update auf 1.5.26
« Reply #1 on: February 10, 2014, 12:38:26 pm »

Seit cpg1.5.24 wurden eigentlich keine Änderungen vorgenommen, die so etwas bewirken könnten. Weiterhin ist es natürlich auch merkwürdig, dass es nur bei manchen Alben auftritt. Firebug hat in diesem Fall auch nicht weitergeholfen. Ich konnte zwar feststellen, dass manche Tabellenzellen viel zu breit sind, den Grund dafür konnte ich aber nicht finden.

Kannst du mir einen FTP-Zugang zu "neuGalerie" einrichten? Ich würde dir dann meine Kontaktdaten per PN schicken.
Logged

berni

  • Coppermine frequent poster
  • ***
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 100
    • Bei Berni
Re: Fehler bei der Albendarstellung nach Update auf 1.5.26
« Reply #2 on: February 10, 2014, 12:54:10 pm »

Hallo René,
danke für Deine Hilfe. Ich würde Dir meine Zugangsdaten schicken, zu Dir habe ich Vertrauen und das Kennwort kann ich ja danach wechseln.
Mit Firebug habe ich auch gesehen, dass die Tabellenzeile vom 3. Thumbnail viel zu breit ist aber ich weiß nicht mal ansatzweise weshalb.
Das Update habe ich eigentlich wie immer gemacht und auch wiederholt aber es brachte nichts.
MfG. Bernd
Logged

Αndré

  • Administrator
  • Coppermine addict
  • ****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: Fehler bei der Albendarstellung nach Update auf 1.5.26
« Reply #3 on: February 10, 2014, 02:06:05 pm »

Hallo René,
André ;)


Habe dir gerade eine PN geschickt.
Logged

berni

  • Coppermine frequent poster
  • ***
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 100
    • Bei Berni
Re: Fehler bei der Albendarstellung nach Update auf 1.5.26
« Reply #4 on: February 10, 2014, 02:13:48 pm »

Danke André,
die Mail ist raus...
Logged

Αndré

  • Administrator
  • Coppermine addict
  • ****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: Fehler bei der Albendarstellung nach Update auf 1.5.26
« Reply #5 on: February 10, 2014, 03:03:02 pm »

Ich habe bisher leider keine E-Mail erhalten.
Logged

berni

  • Coppermine frequent poster
  • ***
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 100
    • Bei Berni
Re: Fehler bei der Albendarstellung nach Update auf 1.5.26
« Reply #6 on: February 10, 2014, 03:17:35 pm »

hallo rené,
die Mail hängt bei meinem Server...Die Telekom hat wohl gerade nen Fehler, ich bin leider nicht der Einzige...
Ich hoffe es geht gleich wieder...Son Mist...
Logged

Αndré

  • Administrator
  • Coppermine addict
  • ****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: Fehler bei der Albendarstellung nach Update auf 1.5.26
« Reply #7 on: February 10, 2014, 03:21:52 pm »

Alles klar, mein Name ist aber immer noch André ;)
Logged

berni

  • Coppermine frequent poster
  • ***
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 100
    • Bei Berni
Re: Fehler bei der Albendarstellung nach Update auf 1.5.26
« Reply #8 on: February 10, 2014, 03:26:19 pm »

Ich weiß André,
ein Arbeitskollege hieß René, dadurch wohl die Verwechlung. Ist leider nicht zum ersten Mal. Sorry
Meldung der Telekom:
Durch eine technische Störung steth der E-Mail abruf für einige Kunden derzeit nicht zur Verfügung.

Der Fehler ist uns bekannt und unsere Techniker setzen derzeit alles daran, diesen so schnell wie möglich zu beheben. Wir bitten um Ihr Verständnis, dass wir Ihnen augenblicklich noch keinen genauen Zeitpunkt nennen können.
Logged

berni

  • Coppermine frequent poster
  • ***
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 100
    • Bei Berni
Re: Fehler bei der Albendarstellung nach Update auf 1.5.26
« Reply #9 on: February 10, 2014, 03:42:51 pm »

Habe jetzt über Google-Mail geschickt, wer weiß wann die Telekom in die Reihe kommt.
Gib bitte bescheidt, wenn es angekommen ist.
Danke, Bernd
Logged

Αndré

  • Administrator
  • Coppermine addict
  • ****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: Fehler bei der Albendarstellung nach Update auf 1.5.26
« Reply #10 on: February 10, 2014, 03:44:09 pm »

Ist angekommen.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • ****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: Fehler bei der Albendarstellung nach Update auf 1.5.26
« Reply #11 on: February 10, 2014, 04:41:24 pm »

Ich habe jetzt mal die benutzerdefinierte Funktion theme_display_thumbnails in der Datei theme.php deaktiviert, damit scheint es zu funktionieren. Auffälligste Änderung: die Beschreibungen wurden vorher (vom Theme-Autor gewollt) abgeschnitten, werden sie jetzt nicht mehr. Falls dir dieses Feature wichtig ist, müssten wir uns die Funktion noch mal genauer ansehen.
Logged

berni

  • Coppermine frequent poster
  • ***
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 100
    • Bei Berni
Re: Fehler bei der Albendarstellung nach Update auf 1.5.26
« Reply #12 on: February 10, 2014, 04:58:57 pm »

Danke André,
vorher sah es zwar besser aus, weil gleichmäßiger aber damit kann ich leben. Ich muß mur die Reihen verringern, denn durch die Kommentare wird es doch recht lang.
Sollte Dir noch etwas einfallen um die alte Darstellung wieder hinzubekommen, wäre schön aber nur wenn Du Zeit dafür hast. Jeden Falls scheint der Fehler nicht bei
mir gelegen zu haben, dass beruhigt mich schon mal ;)
Vielen Dank, Bernd
Logged

Αndré

  • Administrator
  • Coppermine addict
  • ****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: Fehler bei der Albendarstellung nach Update auf 1.5.26
« Reply #13 on: February 10, 2014, 05:08:12 pm »

Text nach einer bestimmten Anzahl an Zeichen abzuschneiden ist sehr einfach. Im Theme selbst wurde dafür sogar eine Funktion erstellt:
Code: [Select]
function myTruncate($string, $limit, $break=".", $pad="...</span>")
{
// return with no change if string is shorter than $limit
if(strlen($string) <= $limit) return $string;

// is $break present between $limit and the end of the string?
if(false !== ($breakpoint = strpos($string, $break, $limit))) {
if($breakpoint < strlen($string) - 1) {
$string = substr($string, 0, $breakpoint) . $pad;
}
}

return $string;
}

Ich werde morgen testen, ob noch weiter Änderungen an der Funktion theme_display_thumbnails vorgenommen wurden, jedoch fällt mir in der selbsterstellten Funktion oben auf, dass das Anfügen der Variable $pad ein span-Tag geschlossen wird, der nirgendwo geöffnet wird. Evtl. ist das schon die Ursache, falls nicht, wäre es zumindest recht unsauber.
Logged

berni

  • Coppermine frequent poster
  • ***
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 100
    • Bei Berni
Re: Fehler bei der Albendarstellung nach Update auf 1.5.26
« Reply #14 on: February 10, 2014, 05:18:23 pm »

Danke, jetzt wo Du mir die Stelle gezeigt hast, sehe ich das auch...schmunzel... nun weiß ich auch, dass "Truncate" "kürzen" heißt ...
Ich hätte das nie hinbekommen obwohl ich inzwischen schon einige Anpassungen gemacht habe. Die meisten allerdings auch mit Deiner
Hilfe. Ich habe aus Sicherheitsgründen die Galerie wieder umgenannt. Das http://bgollin.homepage.t-online.de/Galerie/index.php?cat=0
ist nun die von Dir bearbeitete Galerie, die Zugänge lasse ich noch so.
Danke noch mal, Bernd
Logged

Αndré

  • Administrator
  • Coppermine addict
  • ****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: Fehler bei der Albendarstellung nach Update auf 1.5.26
« Reply #15 on: February 11, 2014, 09:44:40 am »

Ich habe die Funktion theme_display_thumbnails wieder aktiviert und den Aufruf von myTruncate an beiden Stellen um den dritten Parameter erleichtert. Dadurch sehen die Alben wieder normal aus und die Beschreibungen werden gekürzt. Jedoch scheint die Funktion nicht korrekt zu arbeiten, da sie die Beschreibungen eigentlich erst ab 120 Zeichen kürzen soll, dies aber eindeutig früher macht:
Quote from: 66 Zeichen
Ich, mein Bruder Gerhard, mein Vater Werner und mein Schwager Bela...
Quote from: 82 Zeichen
Als Westberliner war er zwingend notwendig für den Transit durch die ehemalige DDR...

Je nachdem wie wichtig dir das ist, könnten wir das noch beheben.
Logged

berni

  • Coppermine frequent poster
  • ***
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 100
    • Bei Berni
Re: Fehler bei der Albendarstellung nach Update auf 1.5.26
« Reply #16 on: February 11, 2014, 10:53:40 am »

Hallo André,
hab vielen Dank.
Quote
Jedoch scheint die Funktion nicht korrekt zu arbeiten
Das läßt ja darauf schließen, dass man erst den Fehler finden müßte und das übersteigt meine Fähigkeiten bei Weitem.
Du hast die Darstellung wieder hinbekommen und so wie es jetzt aussieht, reicht mir das völlig. Es ist ja nur eine
private Seite, da ist der "Look" nicht so wichtig.
Vielen Dank für Deine Mühe,
MfG. Bernd
Logged
Pages: [1]   Go Up
 

Page created in 0.023 seconds with 19 queries.