Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [CPG 1.4x] XP_publish broken in latest CVS?  (Read 4782 times)

0 Members and 1 Guest are viewing this topic.

cryogenic

  • Tester
  • Coppermine regular visitor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 79
    • the cynic says...
[CPG 1.4x] XP_publish broken in latest CVS?
« on: September 14, 2004, 02:17:49 pm »

OK, so just for fun I decided to try the xp_publish method of posting pics to my gallery. I'd just updated to the latest CVS version 1.15 posted about 24 hrs ago. However it did not work as expected.  :(  I did as instructed on the xp_publish.php page, merged the registry entry, selected the pics I wanted to upload, entered my username/pass, picked the gallery I wished for the pics to be placed in... pressed finish, pics are nowhere to be found. So I check other galleries, still no luck. I checked the log files... again no sign. I even FTP'd into my host to find the pics, nowhere to be found. At this point, I deleted the registry entries, re-downloaded the .reg file, re-merged, tried again. Same result. I downgraded to the previous CVS version of xp_publish.php, 1.13, and it worked perfectly. It appears that the substitution of the superglobals broke something somewhere. Everything else on my gallery has been upgraded to the versions with the superglobal variables, so I don't think file version mismatches would be the problem. Everything else appears to function as expected (including uploading directly from CPG and also using the batch upload feature). I also found it odd that downgrading to 1.13 fixed the problem immediately without even re-merging the registry entries.
« Last Edit: March 05, 2005, 08:37:14 pm by TranzNDance »
Logged

Casper

  • VIP
  • Coppermine addict
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 5231
Re: [CPG 1.4x] XP_publish broken in latest CVS?
« Reply #1 on: September 14, 2004, 03:22:24 pm »

Tested and confirmed.  The xp_publish thinks it has done it, bt the pics are not on the server.
Suggest a rollback to the previous version for this file.

Thanks for the report cryogenic, copying your report to the 1.4 board.
Logged
It has been a long time now since I did my little bit here, and have done no coding or any other such stuff since. I'm back to being a noob here

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: [CPG 1.4x] XP_publish broken in latest CVS?
« Reply #2 on: March 05, 2005, 08:37:02 pm »

Since xp publish works now, I'll mark this as fixed.
Logged

prof_hastig

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: [CPG 1.4x] XP_publish broken in latest CVS?
« Reply #3 on: April 21, 2005, 01:48:22 pm »

Where di I find the 1.13 version. Have the same problem.
Thanks
« Last Edit: April 22, 2005, 12:08:44 am by GauGau »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: [CPG 1.4x] XP_publish broken in latest CVS?
« Reply #4 on: April 22, 2005, 12:08:30 am »

cpg1.3.x issues don't belong in the board that is dedicated to cpg1.4.x bugs. Your posting is invalid. Locking this thread.
Logged

Casper

  • VIP
  • Coppermine addict
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 5231
Re: [CPG 1.4x] XP_publish broken in latest CVS?
« Reply #5 on: April 22, 2005, 12:26:35 pm »

@ Joachim,  prof_hastig was asking where to get xp_publish.php version 1.13, not the coppermine 1.3.2 version.

@ prof_hastig, there have been several changes to this file since then, and we are now at version 1.27, which you can get at http://cvs.sourceforge.net/viewcvs.py/*checkout*/coppermine/devel/xp_publish.php?rev=1.27

However, if you are using coppermine version 1.3.2, this file will not work for you at all.
Logged
It has been a long time now since I did my little bit here, and have done no coding or any other such stuff since. I'm back to being a noob here
Pages: [1]   Go Up
 

Page created in 0.016 seconds with 18 queries.