Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1] 2   Go Down

Author Topic: Video Clips in CM Query  (Read 22911 times)

0 Members and 1 Guest are viewing this topic.

esugrue

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Video Clips in CM Query
« on: July 02, 2004, 03:03:18 am »

Hi!

1) With video galleries, is it possible on the displayimage.php page not to attempt to play the video but to have a `Click here to download this video' link. Some of my video clips are large and I want members to download the clip for offline playback!

Thanks
Ernie
Logged

omniscientdeveloper

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 901
Re: Video Clips in CM Query
« Reply #1 on: July 02, 2004, 03:22:30 am »

You can modify it yourself by editting displayimage.php and changing:

Code: [Select]
            $pic_html = "<object {$image_size['whole']}><param name=\"autostart\" value=\"true\"><param name=\"src\" value=\"". $picture_url . "\"><embed {$image_size['whole']} src=\"". $picture_url . "\" autostart=\"true\"></embed></object><br />\n";
to

Code: [Select]
            $pic_html = "<object {$image_size['whole']}><param name=\"autostart\" value=\"false\"><param name=\"src\" value=\"". $picture_url . "\"><embed {$image_size['whole']} src=\"". $picture_url . "\" autostart=\"false\"></embed></object><br />\n".
                        "<p><a href=\"download.php?pid={$CURRENT_PIC_DATA['pid']}\">Click here to download</a></p>";


Copy the code at the bottom of this thread as a new file "download.php" in your coppermine folder:
http://forum.coppermine-gallery.net/index.php?topic=6464.0


-omni
Logged

esugrue

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Video Clips in CM Query
« Reply #2 on: July 02, 2004, 08:47:08 am »

Hi Omni:

Thanks for the quick response. I did as you said and it works great!

Thanks
Logged

liddo

  • Coppermine newbie
  • Offline Offline
  • Posts: 18
Download Enabled Albums
« Reply #3 on: August 26, 2004, 08:06:19 pm »

http://forum.coppermine-gallery.net/index.php?topic=7535.0
[download code]

is there a way to have an option if the files in the album will have a download link

for example I have 2 albums .. pictures and videos.

I want the videos to have the download link but not the pictures album

thanks
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Video Clips in CM Query
« Reply #4 on: August 26, 2004, 09:57:59 pm »

merged your question with the thread you're refering to. Next time, please reply if you actually have a follow-up question on a thread, instead of starting a new thread.
Why don't you just try the code Omni posted? You will find out that it only shows the download link beneath multimedia files, but not beneath regular pics?

GauGau
Logged

liddo

  • Coppermine newbie
  • Offline Offline
  • Posts: 18
Re: Video Clips in CM Query
« Reply #5 on: September 12, 2004, 03:48:45 am »

my pictures are converted to swf
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Video Clips in CM Query
« Reply #6 on: September 12, 2004, 08:46:39 am »

means what?

Joachim
Logged

Zakraket

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: Video Clips in CM Query
« Reply #7 on: October 09, 2004, 07:31:18 pm »

Another thing for video-files: It would be nice when the displayimage.php would not show the videowindow (WMP) but a preview screenshot of the video - and clicking on the screenshot would start the "save to..." - , so that for video you would need:

- video.avi
- video.jpg
- thumb_video.jpg

I've noticed that thumb preview images are shown correctly :)
« Last Edit: October 10, 2004, 10:19:47 pm by Zakraket »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Video Clips in CM Query
« Reply #8 on: October 11, 2004, 05:54:24 am »

The image libraries "GD" and "ImageMagic" (and the PHP functions that are used with them) that are being used by coppermine to create intermediate sized and thumbnails for pics don't support the movie formats, so you can't build movie thumbnails automatically with them. However, you can upload custom thumbnails that represent the movie by creating them on your client and uploading them separately. This is being covered in the docs.

Joachim
Logged

Zakraket

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: Video Clips in CM Query
« Reply #9 on: October 11, 2004, 06:38:48 pm »

I have done that already for thumbnails (created thumb on my client and uploaded it). However, I would like to see the displayimage.php to show a "video.jpg" for a "video.avi" (or .mpg) instead of the WMP screen.

In other words: same as with pictures, only with a downloadlink for the actual videofile. Or something like that, and NOT the Windows Media Player trying to play the video.

:)
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Video Clips in CM Query
« Reply #10 on: October 11, 2004, 09:40:09 pm »

then I propose you just upload a jpeg representation of the video in the first place (adding the jpeg the usual way to the coppermine database), upload the video to some folder outside of coppermine and add the video download link in the file description, using bbcode.

Joachim
Logged

Zakraket

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: Video Clips in CM Query
« Reply #11 on: October 12, 2004, 01:19:14 pm »

That's a good solution :), however, my gallery doens't seem to accept urls in file description. Is that perhaps some option I've missed?

http://www.stefijn.com/gallery/displayimage.php?album=1&pos=0
« Last Edit: October 12, 2004, 01:24:53 pm by Zakraket »
Logged

kegobeer

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 4637
  • Beer - it does a body good!
    • The Kazebeer Family Website
Re: Video Clips in CM Query
« Reply #12 on: October 12, 2004, 01:24:45 pm »

It doesn't work with

Code: [Select]
[url=http://Jouwsite.nl/]Url Text[/url]
in the description field?
Logged
Do not send me a private message unless I ask for one.  Make your post public so everyone can benefit.

There are no stupid questions
But there are a LOT of inquisitive idiots

Zakraket

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: Video Clips in CM Query
« Reply #13 on: October 12, 2004, 01:27:32 pm »

It doesn't work with

Code: [Select]
[url=http://Jouwsite.nl/]Url Text[/url]
in the description field?
No, see the link I gave

Btw, its also not possible to enter URL's in comments..they turn up as:  (...)
Logged

Zakraket

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: Video Clips in CM Query
« Reply #14 on: October 17, 2004, 09:46:21 am »

It doesn't work with

Code: [Select]
[url=http://Jouwsite.nl/]Url Text[/url]
in the description field?
So? Is this a "glitch" in CM? Can I enable it somehow?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Video Clips in CM Query
« Reply #15 on: October 17, 2004, 12:44:31 pm »

I don't get the point, this works fine for me - see the demo (take a look at the link in the description of the "vegetables" album) for album descriptions. A link in the pic description can be found here: http://coppermine.sourceforge.net/demo/displayimage.php?pos=-16

Joachim
Logged

Zakraket

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: Video Clips in CM Query
« Reply #16 on: October 17, 2004, 02:31:34 pm »

The point is...is doens't work on my gallery (latest version) :-\\

see http://www.stefijn.com/gallery/displayimage.php?album=10&pos=2

This URL
google (which obviously works here)

Comes out only as google[/url ]

It works fine in the albumdescription btw.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Video Clips in CM Query
« Reply #17 on: October 18, 2004, 09:13:35 am »

I get
Quote
Coppermine critical error:
Unable to connect to database !

MySQL said: Can't connect to local MySQL server through socket '/var/tmp/mysql.sock' (11)
on your page...

Joachim
Logged

Zakraket

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: Video Clips in CM Query
« Reply #18 on: October 18, 2004, 11:51:17 am »

Indeed...that wasn't the case yesterday  ??? I'll get back to this when it's solved  :-[
Logged

Zakraket

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: Video Clips in CM Query
« Reply #19 on: October 22, 2004, 11:31:03 am »

Indeed...that wasn't the case yesterday  ??? I'll get back to this when it's solved  :-[

It's up again

http://www.stefijn.com/gallery/displayimage.php?album=1&pos=0

Seems it DOES work in picture description. I tried to put it in the picture TITLE
Logged
Pages: [1] 2   Go Up
 

Page created in 0.025 seconds with 21 queries.