Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Thumbnails not showing up in Random  (Read 3795 times)

0 Members and 1 Guest are viewing this topic.

Sunlizzard

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Thumbnails not showing up in Random
« on: September 07, 2004, 07:47:17 am »

Hi, this is my first post. Great gallery, but I'm having a problem I haven't seen addressed on any of the boards...and I have been digging for it.
For my index board I have random, 2 set up. Invariably there is always 1 thumbnail with a red x. I am using version 1.3.2, I've used versions 1.3.0 and 1.3.1 and the only version I haven't had this problem is 1.3.0. With 1.3.1 and 1.3.2 there's always 1 red x.
I have about 2500 pics, could it be too many pics for the random function? Dunno.
Appreciate any help.

http://www.kinglizzard.com/photos/index.php
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Thumbnails not showing up in Random
« Reply #1 on: September 07, 2004, 07:52:26 am »

works fine for me - maybe your browser is timing out. Reduce the number of items on your start page - there are may too many queries and thumbnails on it anyway imo.

Joachim
« Last Edit: September 09, 2004, 11:31:35 pm by GauGau »
Logged

Nibbler

  • Guest
Re: Thumbnails not showing up in Random
« Reply #2 on: September 09, 2004, 11:14:40 pm »

Some of the links are broken, like http://www.kinglizzard.com/photos/albums/events/D/tn_P3280056b.JPG

Did you delete files with your FTP client directly ?
Logged

Sunlizzard

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Thumbnails not showing up in Random
« Reply #3 on: September 10, 2004, 07:20:43 am »

Quote
Some of the links are broken, like http://www.kinglizzard.com/photos/albums/events/D/tn_P3280056b.JPG

Wow...that's a new one on me.
I don't even have an events subfolder in my albums folder...it just goes http://www.kinglizzard.com/photos/albums/D/tn_P3280056b.JPG , that album is "the Concert at The Beach" album located in the Concerts category (fourth page).

Nibbler, where did you find that broken link url?  ???
Logged

kegobeer

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 4637
  • Beer - it does a body good!
    • The Kazebeer Family Website
Re: Thumbnails not showing up in Random
« Reply #4 on: September 10, 2004, 07:24:56 am »

When clicking on the broken image, this error is displayed:

A category has a non-existing parent, run the category manager to correct the problem!

As for the url, a right click on the broken image shows this:

http://www.kinglizzard.com/photos/albums/events/D/tn_P3280030b.JPG

Seems like your categories might be messed up - check your albums and categories to see if there's anything amiss.
Logged
Do not send me a private message unless I ask for one.  Make your post public so everyone can benefit.

There are no stupid questions
But there are a LOT of inquisitive idiots

Sunlizzard

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Thumbnails not showing up in Random
« Reply #5 on: September 10, 2004, 07:59:53 am »

Holy crap...okay, got this bad boy solved...
The dead thumbnails were coming from a bunch of old entries left over in mySQL. A category named events when I was initially setting this up still had over 400 pics in the database which didn't physically exist. Those pics showed up in the "last uploads" as all of those broken links and on the random pics bar.
Problem solved ;D
Thanks Kegobeer, Nibbler and GauGau. BTW,
Quote
there are may too many queries and thumbnails on it anyway imo.
Any suggestions? I tried going down to category level, but people were complaining they couldn't find an album they were looking for.
Can these be spread over several pages? No biggy, just a thought based on your recommendation.
Thanks again.
Logged

kegobeer

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 4637
  • Beer - it does a body good!
    • The Kazebeer Family Website
Re: Thumbnails not showing up in Random
« Reply #6 on: September 10, 2004, 08:09:15 am »

As a webmaster, you are partly held hostage by what your members want.  If they want a listing like the one you have, keep it.
Logged
Do not send me a private message unless I ask for one.  Make your post public so everyone can benefit.

There are no stupid questions
But there are a LOT of inquisitive idiots
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 21 queries.