Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Error message  (Read 3617 times)

0 Members and 1 Guest are viewing this topic.

Andy_Swe

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Error message
« on: October 24, 2003, 03:38:27 am »

Hello guys I get this error messages while clicking on a thumnail on the index.php page

Warning: in_array(): Wrong datatype for second argument in D:\Apache2\htdocs\foto\displayimage.php on line 278

Fatal error: Call to undefined function: display_film_strip() in D:\Apache2\htdocs\foto\displayimage.php on line 607


What is your quick response to this matter ?  What could be wrong .... it works for me to upload pictures etc.....


Thanks in advance any help is higly appriciated // Andy
Logged

Zarsky

  • VIP
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 268
    • Zerr Family Website
Error message
« Reply #1 on: October 24, 2003, 03:53:14 am »

have you tried editing the theme.php file?  If so try restoring the original theme files.
Logged
Read the Online DOCs, FAQ, and SEARCH the board BEFORE posting questions for help.

Andy_Swe

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Error message
« Reply #2 on: October 24, 2003, 05:09:41 am »

it is the default   Im using ... just newly installed this version .... had the older one before and that version is running smoth hmmmm ... do u guys think it can have anything to do with chmod ??
Logged

kegobeer

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 4637
  • Beer - it does a body good!
    • The Kazebeer Family Website
Error message
« Reply #3 on: October 24, 2003, 01:42:30 pm »

Quote
Fatal error: Call to undefined function: display_film_strip() in D:\Apache2\htdocs\foto\displayimage.php on line 607


Take a look in function.inc.php and search for function display_film_strip.  Is it there?
Logged
Do not send me a private message unless I ask for one.  Make your post public so everyone can benefit.

There are no stupid questions
But there are a LOT of inquisitive idiots

deckhead

  • Coppermine newbie
  • Offline Offline
  • Posts: 1
Error message
« Reply #4 on: October 24, 2003, 04:34:27 pm »

Hi,

i fixed the problem by changing the source of the php file "displayimage.php".

It's at the end of the file..
I just commented the source out... it works fine for me...

Code: [Select]

     // Display Filmstrip if the album is not search
    //    if ($album != 'search') {
   //$film_strip = display_film_strip($album, (isset($cat) ? $cat : 0), $pos, true);
    //}
    theme_display_image($nav_menu, $picture, $votes, $pic_info,   $comments, $film_strip);
    pagefooter();
    ob_end_flush();
 }

Logged
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 19 queries.