Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Sorry there is no album where you are allowed to upload pict  (Read 26137 times)

0 Members and 1 Guest are viewing this topic.

Cyberbill

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
    • http://www.hardwickfamily.com/html
Sorry there is no album where you are allowed to upload pict
« on: October 23, 2003, 03:54:59 pm »

I don't understand.  I have:

1.the correct ChMod
2.followed the post to:
     make a user
     delete cookies
     close browser
     open broswer
     log in as admin
3.  Even rebooted :)

CPG 1.1d
PHP-Nuke 6.9 (it Works) :P
mySql (I can't find the version) :roll:
PHP 3


http://capstonemi.com/html/modules.php?name=coppermine
Logged

Cyberbill

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
    • http://www.hardwickfamily.com/html
Fixed, but broke even more
« Reply #1 on: October 23, 2003, 05:29:51 pm »

OK, I got past the first error, and it looked like I could upload pics but it said something about permissions for the includes directory.
I chmod's the included folder to read/write and this happened

Fatal error: Failed opening required 'modules/coppermine/include/init.inc.php' (include_path='./:/usr/local/lib/php') in /home/capstone/capstonemi-www/html/modules/coppermine/db_input.php on line 34
Logged

DJMaze

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Posts: 831
    • Dragonfly CMS
Sorry there is no album where you are allowed to upload pict
« Reply #2 on: October 23, 2003, 06:43:59 pm »

When i try to access the "include" directory i get a "Forbidden" page.

Is that directory CHMODded 755 ?
Logged
There are 2 kinds of users in this world: satisfied and complainers.
Why do we never hear something from the satisfied users?
http://coppermine-gallery.net/forum/index.php?topic=24315.0

Cyberbill

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
    • http://www.hardwickfamily.com/html
db_imput.php
« Reply #3 on: October 23, 2003, 08:12:01 pm »

I CHMOD'd the include folder under coppermine to 777 and got the album to view again, but when I try to upload a pic i get


Failed to create directory modules/coppermine/albums/userpics/10002 !

Warning: mkdir() failed (Permission denied) in /home/capstone/capstonemi-www/html/modules/coppermine/db_input.php on line 222


I CHMOD'd the entire coppermin folder to 777 with the same results.

Is there a list somewhere as to what permissions(CHMOD) should be on each folder?
Logged

DJMaze

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Posts: 831
    • Dragonfly CMS
Logged
There are 2 kinds of users in this world: satisfied and complainers.
Why do we never hear something from the satisfied users?
http://coppermine-gallery.net/forum/index.php?topic=24315.0

Cyberbill

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
    • http://www.hardwickfamily.com/html
safe mode?
« Reply #5 on: October 23, 2003, 09:46:51 pm »

I don't bellieve the PHP is being run in safe mode.  I have contacted the ISP and they are "getting back" to me.

I used to have a file that would give me all of the stats of my server (PHP ver, mySQLver....) which included safe mode.  I think it was called phpinfo.php but I can't find the file.  Any idea where I can get the file?
Logged

gtroll

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Posts: 618
    • CPG-Nuke
phpinfo
« Reply #6 on: October 23, 2003, 10:45:36 pm »

Code: [Select]
<?php phpinfo();?>
That's it save and upload,delete from server when done with it....

Cyberbill

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
    • http://www.hardwickfamily.com/html
Can't create Albums
« Reply #7 on: December 05, 2003, 12:39:47 am »

phpNuke 6.9, RC4

I can live with the bug until RC5, but I can not create Albums.  It will lwt me create categories, but not albums.  I have read http://coppermine.sourceforge.net/manual.php but that doesn;t seem to help.
Logged

Cyberbill

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
    • http://www.hardwickfamily.com/html
directory not writable
« Reply #8 on: December 05, 2003, 03:09:01 am »

ok, I have telephoned and takled to my ISP personally and I am not in safe mode.

Here is what happens.  I log in, go to batch upload pics and I see all of the directories and they all say not writable.

I do not believe my latest post has anything to do with this 1 1/2 month old post.  I was instructed by DJMAZE to delete and reinstall on another post.  How do I close or get rid of this post group? I still need my questions answered though.
Logged

Cyberbill

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
    • http://www.hardwickfamily.com/html
directory not writable
« Reply #9 on: December 05, 2003, 03:20:23 am »

my include/.config.inc file is

Code: [Select]
<?php
"define&#40;'SILLY_SAFE_MODE', 1&#41;;"
// Coppermine configuration file
// coppermine directory name
$cpg_dir "coppermine";
 
/* old not used anymore
// MySQL TABLE NAMES PREFIX
$cpg_prefix = "cpg_";
*/
?>


and I chMOD'd the include dir to 777

Same Problem.
Logged

Cyberbill

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
    • http://www.hardwickfamily.com/html
Safe mode test
« Reply #10 on: December 05, 2003, 03:35:45 am »

Safe mode test results

safe_mode
 Off Off
safe_mode_exec_dir
 no value no value
safe_mode_gid
 Off Off
safe_mode_include_dir
 no value no value

safe_mode_allowed_env_vars
 PHP_ PHP_
safe_mode_protected_env_vars
 LD_LIBRARY_PATH LD_LIBRARY_PATH


Looks off to me.
Logged

Cyberbill

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
    • http://www.hardwickfamily.com/html
Batch upload error
« Reply #11 on: December 05, 2003, 03:49:42 am »

Latest errors, after trying to batch upload pics.  PLEASE give me some guidance on this.  I can give access if you want, I just want it fixed.  

This keeps getting moved into this "hiding"place instead of being addressed.  I need help!

Warning: imagejpeg: unable to open 'modules/coppermine/albums/hardwick/thumb_DSC04618.jpg' for writing in /home/hardwick/hardwickfamily-www/html/modules/coppermine/include/picmgmtbatch.inc.php on line 192

Warning: chmod failed: No such file or directory in /home/hardwick/hardwickfamily-www/html/modules/coppermine/include/picmgmtbatch.inc.php on line 198

Warning: getimagesize: Unable to open 'modules/coppermine/albums/hardwick/thumb_DSC04618.jpg' for reading. in /home/hardwick/hardwickfamily-www/html/modules/coppermine/include/picmgmtbatch.inc.php on line 200
Unable to create thumbnail or reduced size image.
Logged

Cyberbill

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
    • http://www.hardwickfamily.com/html
I love Coppermine
« Reply #12 on: December 06, 2003, 05:45:17 pm »

I love Coppermine  :) , but feel like no one want to even guide me to a resolution to my problem.  My case is decrecated to something that isn't even related to the issue at hand.

Obviously I have offended someone (read my messages, I can't figure out what I said to offend someone).   All I want is some help getting Coppermine working on my site.  After I get it working, I'll go away, I promise.

Can anyone address this issue (before it gets lost in the deprecated areas and never

This is from dictionary.com
dep·re·cate    
( P )  Pronunciation Key  (dpr-kt)
tr.v. de·pre·cat·ed, de·pre·cat·ing, de·pre·cates
1. To express disapproval of; deplore.
2. To belittle; depreciate.

This is exactly how I feel treated at this moment.  Please help me change my opinion of the forum here.

 :(
Logged

DJMaze

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Posts: 831
    • Dragonfly CMS
Sorry there is no album where you are allowed to upload pict
« Reply #13 on: December 06, 2003, 06:31:29 pm »

Cyberbill since we also still don't have a clue with your server we are also finding a way thru it.

Create and upload files thru FTP is possible IF your server allows FTP connections, but then we maybe still have a problem editing the pictures.

So here are a few things that could solve problems:

CHMOD 777: modules/coppermine/albums/
CHMOD 777: modules/coppermine/albums/userpics/

modules.php?name=coppermine&file=config
set "Default mode for directories": 0777

Ask host if open_basedir is active.

Dutch server? Try a otherone (UK/US although they are slower)
Logged
There are 2 kinds of users in this world: satisfied and complainers.
Why do we never hear something from the satisfied users?
http://coppermine-gallery.net/forum/index.php?topic=24315.0
Pages: [1]   Go Up
 

Page created in 0.022 seconds with 20 queries.