Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: "uploader with the picture info" hack not working  (Read 4264 times)

0 Members and 1 Guest are viewing this topic.

cerberus

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 46
    • Pocket PC Russia
"uploader with the picture info" hack not working
« on: July 19, 2004, 03:26:39 pm »

I've got coppermine integrated with YaBB SE and I've applied the "How can I display the name of the uploader with the picture info?" hack as described in the FAQ. But it isn't working. I'm encountering the following error:
Code: [Select]
Template error
Failed to find block 'config'(#(<!-- BEGIN config -->)(.*?)(<!-- END config -->)#s) in :


                <div align="left">
                <table cellpadding="0" cellspacing="1">
                        <tr>
                                <td class="admin_menu"><a href="editpics.php?mode=upload_approval" title="">{UPL_APP_LNK}</a></td>
                                <td class="admin_menu"><a href="config.php" title="">{CONFIG_LNK}</a></td>
                                <td class="admin_menu"><a href="albmgr.php{CATL}" title="">{ALBUMS_LNK}</a></td>
                                <td class="admin_menu"><a href="catmgr.php" title="">{CATEGORIES_LNK}</a></td>
                                <td class="admin_menu"><a href="usermgr.php" title="">{USERS_LNK}</a></td>
                                <td class="admin_menu"><a href="groupmgr.php" title="">{GROUPS_LNK}</a></td>
                                <td class="admin_menu"><a href="banning.php" title="">{BAN_LNK}</a></td>
                                <td class="admin_menu"><a href="reviewcom.php" title="">{COMMENTS_LNK}</a></td>
                                <td class="admin_menu"><a href="searchnew.php" title="">{SEARCHNEW_LNK}</a></td>
                                <td class="admin_menu"><a href="util.php" title="">{UTIL_LNK}</a></td>
                                <td class="admin_menu"><a href="profile.php?op=edit_profile" title="">{MY_PROF_LNK}</a></td>
                        </tr>
                </table>
                </div>
Any idea?
Logged
With Best Regards, Cerberus
Edamus, bibamus, gaudeamus.
http://www.pocketpcrussia.com - My Main Site

cerberus

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 46
    • Pocket PC Russia
Re: "uploader with the picture info" hack not working
« Reply #1 on: July 19, 2004, 03:34:32 pm »

I was editing the wrong file lol ;D.

But now I've edited the right files and I get:
Quote
There was an error while processing a database query
Logged
With Best Regards, Cerberus
Edamus, bibamus, gaudeamus.
http://www.pocketpcrussia.com - My Main Site

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: "uploader with the picture info" hack not working
« Reply #2 on: July 19, 2004, 04:37:08 pm »

When experiencing this error, you should always enable debug_mode in coppermine config to see what query actually fails.

GauGau
Logged

cerberus

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 46
    • Pocket PC Russia
Re: "uploader with the picture info" hack not working
« Reply #3 on: July 19, 2004, 05:28:38 pm »

Quote
While executing query "SELECT pid, filepath, filename, url_prefix, filesize, pwidth, pheight, ctime, title, caption, hits, user_name from foto_pictures AS p LEFT JOIN **ERROR** AS u ON u.user_id = p.owner_id WHERE p.aid='8'   ORDER BY pid ASC  LIMIT 0 ,12" on 0

mySQL error: You have an error in your SQL syntax.  Check the manual that corresponds to your MySQL server version for the right syntax to use near '**ERROR** AS u ON u.user_id = p.owner_id WHERE p.aid='8'   ORDE

I guess it's referring to
Code: [Select]
$result = db_query("SELECT $select_columns from {$CONFIG['TABLE_PICTURES']} AS p LEFT JOIN {$CONFIG['TABLE_USERS']} AS u ON u.user_id = p.owner_id WHERE p.aid='$album' $approved $ALBUM_SET ORDER BY $sort_order $limit");
Logged
With Best Regards, Cerberus
Edamus, bibamus, gaudeamus.
http://www.pocketpcrussia.com - My Main Site

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: "uploader with the picture info" hack not working
« Reply #4 on: July 19, 2004, 09:29:44 pm »

hm, not sure. Does the error go away if you undo the mod?

GauGau
Logged

cerberus

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 46
    • Pocket PC Russia
Re: "uploader with the picture info" hack not working
« Reply #5 on: July 19, 2004, 10:11:42 pm »

Yes. When I've replaced functions.inc.php with an "unmodded" functions.inc.php the problem vanished. I exclude any sort of conflict with other mods, because that was and is the first mod I've installed on that gallery :).

I've did all the procedure again but I still have the same problem :(
Logged
With Best Regards, Cerberus
Edamus, bibamus, gaudeamus.
http://www.pocketpcrussia.com - My Main Site

Nibbler

  • Guest
Re: "uploader with the picture info" hack not working
« Reply #6 on: July 20, 2004, 02:44:05 am »

That hack won't work with a bridged install, you would need to modify the query to access the YaBB user table, and use the appropriate field names. I'm not familiar with YaBB, so I can't help you with that I'm afraid.
Logged

cerberus

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 46
    • Pocket PC Russia
Re: "uploader with the picture info" hack not working
« Reply #7 on: July 20, 2004, 12:36:26 pm »

That hack won't work with a bridged install, you would need to modify the query to access the YaBB user table, and use the appropriate field names. I'm not familiar with YaBB, so I can't help you with that I'm afraid.
:o :'(
I've thought that coppermine saves the uploader's name in its own DB.
I'm familiar with YaBB, but not with MySQL :(.
Logged
With Best Regards, Cerberus
Edamus, bibamus, gaudeamus.
http://www.pocketpcrussia.com - My Main Site

Nibbler

  • Guest
Re: "uploader with the picture info" hack not working
« Reply #8 on: July 20, 2004, 12:57:53 pm »

What the hack tries to do is lookup the user name in the coppermine user table using the owner_id associated with the picture, it doesnt use the owner_name atall. You can try it with the owner_name if you like.
Logged

cerberus

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 46
    • Pocket PC Russia
Re: "uploader with the picture info" hack not working
« Reply #9 on: July 20, 2004, 06:44:04 pm »

What the hack tries to do is lookup the user name in the coppermine user table using the owner_id associated with the picture, it doesnt use the owner_name atall. You can try it with the owner_name if you like.
it isn't working :(
I'll have to dig in the bridge and see how it handles owners ::)
Logged
With Best Regards, Cerberus
Edamus, bibamus, gaudeamus.
http://www.pocketpcrussia.com - My Main Site
Pages: [1]   Go Up
 

Page created in 0.029 seconds with 19 queries.