Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Redirects from old CPG galleries to new pages  (Read 239 times)

0 Members and 1 Guest are viewing this topic.

Walkinman

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 378
    • Skolai Images - Nature, Travel and Adventure stock photos
Redirects from old CPG galleries to new pages
« on: January 21, 2023, 04:07:02 am »

Apologies . I posted this in the older 1.5 support .. it might be better here.

I'm switching to a new server, and no longer using cpg, and having trouble getting redirects from the old cpg galleries and images to work.

For albums and categories that I will not redirect, just are gone and no longer exist, I wrote the 410 rule as

Code: [Select]
RewriteRule ^stock/thumbnails\.php\?album=62$ - [R=410, L]

That breaks the new site and creates a 500 error

For old cpg albums that I want to redirect to a new url, I wrote

Code: [Select]
RewriteRule ^stock/thumbnails\.php\?album=36$ https://www.domain.com/gallery/appalachian-trail-photos/ [R=301,L]

But it does nothing. THe urls from cpg show as 404 pages. I also tried it as

Code: [Select]
Redirect 301 /stock/index.php?cat=2 https://www.domain.com/gallery/outdoor-recreation-photos/

which also does nothing.

I also want to redirect any image display pages to the root gallery of their relative album. So an image from a particular cpg album would go to the gallery page for that on the new site. I wrote

Code: [Select]
RewriteRule ^stock/displayimage\.php\?album=30&.*$ https://www.domain.com/gallery/canadian-wildlife-photos/ [R=301,L]
RewriteRule ^stock/displayimage\.php\?album=32&.*$ - [R=410,L]

to send any image from album 30 to the CA wildlife photos album and any image from album 32 is gone.

None of these last work but I can't see what's wrong with them?

Any help would be superduper appreciated, thanks.
Logged
Pages: [1]   Go Up
 

Page created in 0.015 seconds with 19 queries.