Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Could not enter a new Admin User , Error  (Read 270 times)

0 Members and 1 Guest are viewing this topic.

Dancefloor

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Could not enter a new Admin User , Error
« on: July 19, 2022, 02:09:06 pm »

I made a fresh install of the newest Coppermine.
Everythings during install went fine.
The i logged in and want to create a new Admin User
I filled out the Name, Password, set as Administrator in the drop down window
Klicked Administrator and Registered with X
Filled out the Emailaddress and klicked OK
Then directly this Error comes :

Fatal error: Uncaught TypeError: fwrite(): Argument #1 ($stream) must be of type resource, bool given in /home/docjack/public_html/copper/include/logger.inc.php:59 Stack trace: #0 /home/docjack/public_html/copper/include/logger.inc.php(59): fwrite() #1 /home/docjack/public_html/copper/usermgr.php(1005): log_write() #2 /home/docjack/public_html/copper/usermgr.php(1112): update_user() #3 {main} thrown in /home/docjack/public_html/copper/include/logger.inc.php on line 59

Debian 10
PHP 8.0.20
Apache 2.0

I tried both : mysqli and mysqld at installation..
Same Error ith new user

What can i do
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1869
Re: Could not enter a new Admin User , Error
« Reply #1 on: July 19, 2022, 04:22:34 pm »

Make sure that there is a logs folder and that it is writeable by Apache (www-data).
Logged
Pages: [1]   Go Up
 

Page created in 0.016 seconds with 19 queries.