Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Newbie problem with update.php  (Read 5418 times)

0 Members and 1 Guest are viewing this topic.

steverosenblum

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Newbie problem with update.php
« on: April 30, 2022, 02:55:40 am »

I had used cpg1.2? in the past and was no longer able to log in because of script errors. I finally decided to try to upgrade to cpg1.6 and I think I have gotten as far in the process described in the manual as trying to run update.php whihc I think is the last step. For my website I tried to run the following from the browser on my computer at home: htttp://www.rosenblums.us/home4/rosenblu/public_html/coppermine/update.php and Firefox continually defaults to Search mode rather than going to the website and executing the file. What should I be doing instead?
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4886
    • Windsurf.me
Re: Newbie problem with update.php
« Reply #1 on: April 30, 2022, 06:31:06 pm »

It is going to be very challenging to upgrade from that far back. What I would suggest is you do it from a backup on your local machine using WAMP or similar. This is because you can run older, compatible versions of PHP and MySQL while you go through the various stages. You cannot upgrade directly from 1.2.x to 1.6.x so will need to use intermediate stages.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 2027
Re: Newbie problem with update.php
« Reply #2 on: April 30, 2022, 07:40:45 pm »

You were last running version 1.4.10 of CPG. Upgrading to CPG 1.6 will need to be a two step process. First, the 1.4.10 version will need to be upgraded to 1.5.48, and then that version can be upgraded to CPG 1.6.  I suggest that you take some time to consider how important what gallery you had is to you now.  If not that greatly important, it may not be worth the effort needed to get it running again.  You can just abandon having a gallery or start a new one from scratch.  If, on the other hand, you truly believe that your gallery needs to be resurrected, I will help get that done (or just do it for you).
Logged

steverosenblum

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Newbie problem with update.php
« Reply #3 on: May 01, 2022, 01:38:51 am »

ron4mac, thank you for your kind offer. I did put a lot of work into the gallery, saved as Albums in the Coppermine folder. I organized all the pictures up to that time by year and event so they could be easily found by my family and friends. About 7 years ago I could no longer access Coppermine, getting a script error message when I tried to log in so I stopped using it. Since family and friends are scattered around the globe, Coppermine offers a way for them to access our photos which I would like to continue to do, adding newer photos to the existing ones. I reject the idea of giving Google or Apple access to my pictures, which is why I have my own website.
It took me several hours to go through the steps described in the manual to try to carry out the upgrade to cpg1.6x, which obviously was doomed to fail. I am happy to try to do the 2 step process that you and phill104 describe, although I would appreciate some overview of what needs to be done. If the manual is clear enough, I could try what is there. I would need some guidance to the specific parts to carry out.
If you are willing to do it for me, please let me now what information you require. Thanks again to both of you for your quick and informed response.
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 2027
Re: Newbie problem with update.php
« Reply #4 on: May 01, 2022, 01:56:22 pm »

Don't you think that maybe you should have sought help 7 years ago?  There will need to be PHP version adjustments and enough complexity that you should just let me do it for you. You just need to PM me (private message - bubble icon by me on the left of this message) the login credentials for your (HostMonster?) hosting account.
« Last Edit: May 01, 2022, 02:18:44 pm by ron4mac »
Logged

steverosenblum

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Newbie problem with update.php
« Reply #5 on: May 01, 2022, 09:44:32 pm »

ron4mac, point taken. I spent a little time trying to figure it out with Hostmonster support(my webhosting service) since they provided the Coppermine download as a free add-on to customers, but they were unable to help me past the problem. I looked through the documentation and was discouraged by the complexity of figuring out the cause and lack of time on my part to dig into it. I was also not aware that there was a support forum with such responsive people in it. My experience with other public domain software, and often even commercial software is that solutions through consultation are difficult to achieve. Thanks again for your kind offer. I will DM the info to you.
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 2027
Re: Newbie problem with update.php
« Reply #6 on: May 02, 2022, 01:54:30 am »

Okay, Steve ... your Coppermine Gallery is up to date. (CPG version 1.6.18 running on PHP 7.4)
Logged

steverosenblum

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Newbie problem with update.php
« Reply #7 on: May 02, 2022, 08:48:10 pm »

ron4mac, thank you. I really appreciate your help.
Logged

steverosenblum

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Newbie problem with update.php
« Reply #8 on: May 03, 2022, 01:01:55 am »

Hopefully this is my last problem. Coppermine works fine using the Microsoft Edge browser and Windows 11, but looks only black and white and does not generate thumbnails using Firefox 99.0.1(64-bit). Must be a setting that I can't figure out. I prefer Firefox because of privacy protections.
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 2027
Re: Newbie problem with update.php
« Reply #9 on: May 03, 2022, 02:34:25 am »

Hopefully this is my last problem. Coppermine works fine using the Microsoft Edge browser and Windows 11, but looks only black and white and does not generate thumbnails using Firefox 99.0.1(64-bit). Must be a setting that I can't figure out. I prefer Firefox because of privacy protections.

Try clearing the cache in your Firefox browser.
Logged

steverosenblum

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Newbie problem with update.php
« Reply #10 on: May 03, 2022, 06:11:23 am »

ron4mac, you are 2 for 2. Thank you again. I am now fully back on board with Coppermine.
Logged
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 20 queries.