Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Confused By Watermark Option  (Read 321 times)

0 Members and 1 Guest are viewing this topic.

nootkan

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 24
Confused By Watermark Option
« on: January 01, 2022, 01:41:32 am »

I am confused by how to use the watermark. 

I've read through the docs on it and created my own custom_watermark.png file, uploaded it to the images folder and set the path in config.

I set the transparency for entire image to 22% which is the same as the opacity for my custom watermark image which is the same width and height as the sample image.

I set the files option to both (original/resized).

I tested my custom watermark on light and dark images already in my gallery using photoshop and they look perfect.

Every time I click an image in the gallery to view it, it shows the original example watermark and not my custom one. 

I have also tried deleting the watermark.png file from the images folder but it still shows. 

As a last resort I even went to admin/tools and deleted original image backup for watermarked images.

Still I am seeing the original sample watermark which doesn't exist in the images folder anymore.

I would like some clarification on how to make this work if it is possible.  Or should I go into the database now and see if I can make it work there?
Logged

nootkan

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 24
Re: Confused By Watermark Option
« Reply #1 on: January 01, 2022, 02:20:58 am »

Well the newly uploaded images show my custom watermark but the previously uploaded images show the ugly sample watermark.  I need a way to remove this watermark and I thought by deleting the watermark.php image that would ensure the watermark layer wouldn't show but it still does.
Logged

nootkan

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 24
Re: Confused By Watermark Option
« Reply #2 on: January 01, 2022, 02:41:29 am »

Alright I finally figured this out. 

It seems that cpg doesn't apply a layer over the original image but actually embeds it into the image. 

I had to go into my backup and upload all the images again to the albums/userpics folders which removed the sample watermark. 

I cannot however get the new custom watermark to show on the images that were previously uploaded only the newly uploaded ones. 

Glad I don't have hundreds of images to edit in photoshop with a watermark as that would be very time consuming. 

Not sure if it is a possible feature request but it would be nice to have a different way to watermark images that allows for updating previously uploaded images with the new custom watermark no matter what date they were loaded.

One might some day decide to change the watermark to a better looking one or different named one in which case it can't be done the way it is now it seems.
Logged
Pages: [1]   Go Up
 

Page created in 0.014 seconds with 21 queries.