Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Admin Cannot Create New Users  (Read 358 times)

0 Members and 1 Guest are viewing this topic.

nootkan

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 24
Admin Cannot Create New Users
« on: December 31, 2021, 07:42:04 am »

I am running version 1.6.16 and everything seems to be fine except I cannot create a new user without doing so inside my database with phpmyadmin.  When I try to create the new user inside cpg admin and hit save I get a 404 page cannot be found error.  I viewed my cpg security logs and here is what I see:
Quote
Dec 30, 2021 at 10:03 PM - Denied privileged access to usermgr.php by user Guest at IP xxxxxx
Dec 30, 2021 at 10:12 PM - Denied privileged access to catmgr.php by user Guest at IP xxxxxx
Dec 30, 2021 at 10:18 PM - Denied privileged access to profile.php by user Guest at IP xxxxxx

The ip address is mine so not sure why it is saying I'm a guest when I am logged in as admin.

Anyone else have this problem before? I tried searching the forums but nothing came up.
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1813
Re: Admin Cannot Create New Users
« Reply #1 on: December 31, 2021, 04:05:52 pm »

You need to be consistent with whether the site is being accessed as http: or https:
Make sure the site url in the config starts with https:
Also consistent use of www. or not.

[I see you found Monica's themes ... good job]
« Last Edit: December 31, 2021, 04:25:56 pm by ron4mac »
Logged

nootkan

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 24
Re: Admin Cannot Create New Users
« Reply #2 on: December 31, 2021, 06:53:24 pm »

Hi thanks for the reply.  I'm not sure I understand you correctly.  When I view my general settings I see this:

Quote
URL of your Coppermine gallery folder (with a trailing slash, no 'index.php' or similar at the end) https://www.grstreamkeepers.com/photogallery/        
URL of your home page    https://www.grstreamkeepers.com/photogallery/index.php

I tried changing the home page url to just index.php but that didn't work either.  I also tried changing back to the Curve theme to see if it was a theme issue but got the same result.
Logged

nootkan

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 24
Re: Admin Cannot Create New Users
« Reply #3 on: December 31, 2021, 08:28:44 pm »

I tried logging in with one of the users credentials and everything works fine for him when editing his profile.  Just cannot add a new user or edit a users profile in admin. ???
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1813
Re: Admin Cannot Create New Users
« Reply #4 on: December 31, 2021, 08:57:59 pm »

If you PM me with an admin login, I'll see if I can resolve the issue.

Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1813
Re: Admin Cannot Create New Users
« Reply #5 on: December 31, 2021, 11:33:09 pm »

I feel that what I am seeing is being caused by some site or WP .htaccess rule
Logged

nootkan

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 24
Re: Admin Cannot Create New Users
« Reply #6 on: December 31, 2021, 11:58:24 pm »

Hmmm...Okay I figured it out.  It was a rule in modsecurity that was blocking what it thought was a blind sql injections.  I whitelisted the rule for the domain and it works.  I also seen your attemp which was blocked also before I made the change.  Thanks for your help.
Logged
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 21 queries.