Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Upgrade from 1.5.46 to 1.5.48  (Read 207 times)

0 Members and 1 Guest are viewing this topic.

nootkan

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 24
Upgrade from 1.5.46 to 1.5.48
« on: December 29, 2021, 08:36:06 pm »

Hi guys, it's been a while since I upgraded and wanted to do it in stages to the most current version. 

I wanted to start with version 1.5.48 and downloaded, unzipped, overwrited all files except the albums folder and the anycontent.php file. 

When I tried to run the upgrade.php script I got this error:
Quote
Uncaught Error: Call to undefined function mysql_connect() in /home/mywebsite/public_html/photogallery/include/functions.inc.php:183 Stack trace: #0 /home/mywebsite/public_html/photogallery/include/init.inc.php(171): cpg_db_connect() #1 /home/mywebsite/public_html/photogallery/update.php(27): include_once('/home/mywebsite/...') #2 {main} thrown in /home/mywebsite/public_html/photogallery/include/functions.inc.php on line 183

I checked the include/config.inc.php file and the configuration is correct to the database.

Here is my server specs:
cPanel Version    100.0 (build 5)
Apache Version    2.4.52
PHP Version    7.2.34
MySQL Version    5.7.36
Architecture    x86_64
Operating System    linux
Kernel Version    3.10.0-1160.49.1.el7.x86_64
 
I am running php 7.34 but the site was working fine with the previous version 1.5.46 so not sure why the error now.  Any ideas?
Paul
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1772
Logged

nootkan

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 24
Re: Upgrade from 1.5.46 to 1.5.48
« Reply #2 on: December 29, 2021, 10:07:33 pm »

Thanks for your reply.  It turned out to be a htaccess issue when I switched the main website over to wordpress from modx.  Once I fixed that everything is back to normal.  I am okay with upgrading the manual way to 1.6.16, so I'll do that first than change my php version to 7.4.
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1772
Re: Upgrade from 1.5.46 to 1.5.48
« Reply #3 on: December 29, 2021, 10:46:41 pm »

Your theme is based on curve and will need to have changes (fixes) made for CPG 1.6.x
https://forum.coppermine-gallery.net/index.php/topic,79193.msg384018.html#msg384018
Logged

nootkan

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 24
Re: Upgrade from 1.5.46 to 1.5.48
« Reply #4 on: December 29, 2021, 11:07:20 pm »

Okay I've manually uploaded the files overwriting all of the files except for the albums folder and the anycontent.php file.  I tried to browse to https://www.grstreamkeepers.com/upgrade.php but received this error message:
Quote
Critical error
There was an error while processing a database query

So I switched to php 7.4 and tried to upgrade again with the same result.  Also when I try to login with my admin username and password the same error occurs.  I even tried going into the database and changing the password there but no luck doing that either. Any ideas?
Logged

nootkan

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 24
Re: Upgrade from 1.5.46 to 1.5.48
« Reply #5 on: December 29, 2021, 11:14:29 pm »

Okay I've manually uploaded the files overwriting all of the files except for the albums folder and the anycontent.php file.  I tried to browse to https://www.grstreamkeepers.com/upgrade.php but received this error message:
So I switched to php 7.4 and tried to upgrade again with the same result.  Also when I try to login with my admin username and password the same error occurs.  I even tried going into the database and changing the password there but no luck doing that either. Any ideas?

Sorry that should have read update.php not upgrade.php.  And I am now running 1.6.16 and the 2 updates (mysql_ to cpg_db_) were made to the curve_green theme file theme.php as your link suggested and the https://www.grstreamkeepers.com/photogallery/ site is working well except for the login and database update issue.
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1772
Re: Upgrade from 1.5.46 to 1.5.48
« Reply #6 on: December 29, 2021, 11:26:43 pm »

From what I can see, your database has been properly updated and you should not have a login issue (unless a forgotten password).
Logged

nootkan

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 24
Re: Upgrade from 1.5.46 to 1.5.48
« Reply #7 on: December 29, 2021, 11:45:06 pm »

Yeah after my last post I went back and ran update.php one more time and voila it worked.  I have logged in and changed my password and checked over my configurations for the registration form which I have set to no one can register.  I am currently getting bots trying to register to the newer version which is something I didn't have happening in the previous version.

Thanks for all your support but I am worried that you can determine that my database was upgraded and you knew my theme before I posted the links.  Is there a security risk with my site that I should be aware of that allows you to see this information?
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1772
Re: Upgrade from 1.5.46 to 1.5.48
« Reply #8 on: December 30, 2021, 12:15:43 am »

Thanks for all your support but I am worried that you can determine that my database was upgraded and you knew my theme before I posted the links.  Is there a security risk with my site that I should be aware of that allows you to see this information?

Ha!  ... nothing to worry about.  Being able to see your email, I could determine your gallery url and see that it is using a curve based theme (for which I knew there would be that issue). And there is an innocuous method for me (developer/support) to see the update status of your db.
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1772
Re: Upgrade from 1.5.46 to 1.5.48
« Reply #9 on: December 30, 2021, 12:24:29 am »

I am currently getting bots trying to register to the newer version which is something I didn't have happening in the previous version.

Yes ... the flies tend to swarm around WP sites.
Logged

nootkan

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 24
Re: Upgrade from 1.5.46 to 1.5.48
« Reply #10 on: December 30, 2021, 02:30:35 am »

Yeah I debated a long time whether to use WP or not but in the end it was a lot more convenient for me for the little time I had to offer to the non profit organization the website is built for. 

I'll try some of the captcha plugins available for cpg but based on my experience bots can circumvent almost every method aimed at preventing them that I've been able to find to date. 

The only ones that seem to be working for most of the bots include some kind of minimum time allotment for filling in the forms.  But this is above my skill set.

I have found a plugin for WP that works quite well for blocking bots but alas it won't work for cpg out of the box.  There is a stand alone version of the plugin for non WP websites and I have it working on another non WP site but I had to pay someone to configure it for me as I don't have the skills necessary.

You can mark this thread as resolved if you like.  I couldn't find anywhere to do this myself.
Thanks again for all your help.
Logged
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 19 queries.