Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: large image popups not displaying  (Read 237 times)

0 Members and 1 Guest are viewing this topic.

HarryAdney

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
large image popups not displaying
« on: November 22, 2021, 06:35:49 pm »

Hey guys,

I built a site years ago for a client and all was well, until a few days ago when my client told me that when she clicks on an image, there's no enlarged image displaying.

Details
I upgraded from 1.5.x to 1.6.16. The site is displaying as expected (though I'm building a new, up to date site for the client) but clicking on any image results in the following console error in dev tools:
     
    Uncaught ReferenceError: enlarge is not defined
    at HTMLImageElement.onclick (thumbnails.php?album=3:193)


I have the following plugins installed, which have some image display functions:
  • Fit screen (fit_screen): v1.0
  • EnlargeIt! (enlargeit): v1.15
  • (link_target): v1.2
  • Panorama Viewer (panorama_viewer): v1.4
  • Fancybox Media Display (fancybox): v1.3

Any ideas what's gone wrong (and, of course, how to fix it)?

Many thanks



Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1740
Re: large image popups not displaying
« Reply #1 on: November 22, 2021, 07:53:38 pm »

Start by disabling those plugins. If everything works as expected after that, enable one at a time to find one causing the issue.
Is it possible to provide a link to the site?
Logged

HarryAdney

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: large image popups not displaying
« Reply #2 on: November 26, 2021, 04:29:33 pm »

Hi, thanks for replying. The website is https://wensleydale-archive.info. I haven't tried disabling the plugins yet, so I'll try that now; thanks for the suggestion.
Logged

HarryAdney

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: large image popups not displaying
« Reply #3 on: November 26, 2021, 04:51:35 pm »

Thanks very much mate. It was the EnlargeIt plugin that was causing the problem.
Logged
Pages: [1]   Go Up
 

Page created in 0.015 seconds with 20 queries.