Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: need tech help to fix my Coppermine Photo Gallery  (Read 248 times)

0 Members and 1 Guest are viewing this topic.

lynnpd

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
need tech help to fix my Coppermine Photo Gallery
« on: November 15, 2021, 10:01:24 pm »

Don't ask me what version of the Coppermine gallery I have because I cannot get to it to see which version it is, but it may be 1.4 to 1.5 or more. 

I have links throughout my wordpress website linking to my Coppermine photo gallery and recently, something happened that is preventing Coppermine to no longer work.  Instead, I now get the following error message:

Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /hermes/bosnacweb04/bosnacweb04az/b1694/ipw.classicmoviefavorites/public_html/classicmoviefavWP/classicmoviefavWP/photogallery/include/functions.inc.php:183 Stack trace: #0 /hermes/bosnacweb04/bosnacweb04az/b1694/ipw.classicmoviefavorites/public_html/classicmoviefavWP/classicmoviefavWP/photogallery/include/init.inc.php(171): cpg_db_connect() #1 /hermes/bosnacweb04/bosnacweb04az/b1694/ipw.classicmoviefavorites/public_html/classicmoviefavWP/classicmoviefavWP/photogallery/index.php(26): require('/hermes/bosnacw...') #2 {main} thrown in /hermes/bosnacweb04/bosnacweb04az/b1694/ipw.classicmoviefavorites/public_html/classicmoviefavWP/classicmoviefavWP/photogallery/include/functions.inc.php on line 183

My website is https://classicmoviefavorites.com

I would appreciate some guidance or some help on this. Please let me know if you have any guidance or help to provide.

There was no indication notification to me why the gallery stopped working as i haven't added new photos recently.  I have links to it throughout my website that now no longer work resulting in the message above.

Again, I haven't uploaded photos or done much with the gallery recently, but it is an integral part of my website, so I'd like to get it fixed.

Thanks!
Lynn

Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1740
Re: need tech help to fix my Coppermine Photo Gallery
« Reply #1 on: November 15, 2021, 10:28:48 pm »

Your gallery version is 1.5.46 and your host has changed the default version of PHP to be some version of PHP 7.  Coppermine Photo Gallery versions prior to 1.6 are not compatible with PHP 7.
To solve the problem, your gallery can be upgraded using this method.
Logged
Pages: [1]   Go Up
 

Page created in 0.014 seconds with 21 queries.