Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Upgrade from 1.4.27 to 1.6x  (Read 920 times)

0 Members and 1 Guest are viewing this topic.

newseed

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Upgrade from 1.4.27 to 1.6x
« on: February 08, 2021, 11:39:41 pm »

Hi,

It's been years but I  want to get my 1.4.27 gallery updated to the latest version, 1.6.x.  I have read a good number of posts but it still not qquite clear yet.

1. To upgrade from 1.4.27, I would download the full version of 1.5.46, upload it to my current gallery folder and then run the 'update.php'?
2. And then I would download the 1.6.x (does matter which 1.6 version?) and then run the 'update.php'?

Is there anything I am missing here?  Are there specific versions (and in what order) I should be using to get from 1.4.27 all the way to 1.6.10?

Note: I am aware about php version and I savvy enough to do my upgrade in a development environment.

Thank you.

Logged

newseed

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: Upgrade from 1.4.27 to 1.6x
« Reply #1 on: February 09, 2021, 03:47:39 pm »

Anyone?  I just tried to do it on my own. It completely became a mess having all kinds of file errors. Can someone please tell me what the actually steps to tak to get me upgraded?  Do you remove all the old files first and then install 1.5.x? Do you remove the 1.5.x before upgrading to 1.6.x?

So does anyone know the official steps to get me upgraded from 1.4.27 to 1.5.x to 1.6.x. 

Also, the 1.6.x files are way smaller than the 1.5.46 package.  is there a full package of 1.6? (yes, I did click on the download link from the home page but I still got a small file).

Please, can someone get me going in the right direction? I have two of these sites I need to upgrade.

Thank you.
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1667
Re: Upgrade from 1.4.27 to 1.6x
« Reply #2 on: February 09, 2021, 05:03:08 pm »

Follow the instructions here to upgrade from 1.4.x to 1.5.x.
Then follow the instructions here to upgrade from 1.5.x to 1.6.x.
( for an easier method to upgrade from 1.5.x.to 1.6.x, follow the instructions here )
Logged

newseed

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: Upgrade from 1.4.27 to 1.6x
« Reply #3 on: February 09, 2021, 06:13:13 pm »

Thank you.  Going from 1.5.x to 1.6 isn't quite clear.  In the second link you've provide, I didn't read if I should be uploading the 1.6 package or not?.  The only package I found was called this: cpg1.6.x-1.6.04.zip.  I did not find one that is named as 1.5.x-1.6.04.zip or something similar.  Also, does cpg_installer_stub.php script work for upgrading from 1.5 to 1.6?  I did try using the script but it didn't work. 

There is a lot of 'blah blah' in those instructions that tends to get me lost.  I am sorry that I am not competent enough to understand what I am missing or doing wrong.  I am so spoiled by step by step instructions that gets to point of what you should be performing/completing before moving on to the next step.
Thank you.
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1667
Re: Upgrade from 1.4.27 to 1.6x
« Reply #4 on: February 09, 2021, 08:01:57 pm »

The cpg_installer_stub, when used to upgrade from 1.5.x to 1.6.x, does the job for you of getting the files on the server ... and then running the update.
First, you need to get your sites from 1.4.x to 1.5.x(48).

Can you provide links to the sites you are trying to upgrade?
Logged

newseed

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: Upgrade from 1.4.27 to 1.6x
« Reply #5 on: February 09, 2021, 08:32:33 pm »

I did upgrade to 1.5.46 sucessfully but the issues were the installer script.  Kept saying it could not save the package. So I have started to download the packages and upload them manually and then run the updater. I still find 26 errors when I ran the version checker. 

But if you would like to take a look, here's the url.
http://www.desertsafaris.net/gallery-upgrade/
I will message you the login credentials.

Keep in mind that this is on a development folder and dev database.  If I have to start over, I can.
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1667
Re: Upgrade from 1.4.27 to 1.6x
« Reply #6 on: February 10, 2021, 01:51:10 am »

You seem to have the one gallery at 1.6.06.  Just do the same thing to the other one. Don't pay much attention to the version check.
You should be upgrading to the latest version of 1.6.
Logged

newseed

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: Upgrade from 1.4.27 to 1.6x
« Reply #7 on: February 10, 2021, 05:18:30 am »

i went from 1.5 to 1.6.04. Thereafter, I did each of the remaining 1.6.x versions one at a time.  All seems to be working well and fully updated.

I have another site. My only question is this:  Once it get it to 1.6.04 version, do I have to update each version until I get to 1.6.10 or can I just skip ones in between?

Thank you.
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4799
    • Windsurf.me
Re: Upgrade from 1.4.27 to 1.6x
« Reply #8 on: February 10, 2021, 11:40:21 am »

You can do it in one go. Just use the installer stub mentioned above.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

newseed

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: Upgrade from 1.4.27 to 1.6x
« Reply #9 on: February 10, 2021, 04:51:21 pm »

The installer stub hasn't worked for me and the other site is on the same server so I kind of expect the same issue.
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1667
Re: Upgrade from 1.4.27 to 1.6x
« Reply #10 on: February 10, 2021, 05:40:42 pm »

The installer stub hasn't worked for me and the other site is on the same server so I kind of expect the same issue.
Make sure you are using v3.4 of the installer stub. (guess there should be a prominent version number when it is run  :-[ )
Logged

newseed

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: Upgrade from 1.4.27 to 1.6x
« Reply #11 on: February 10, 2021, 05:58:22 pm »

Yeah. I doubled-check and I did use the latest version (v3.4). 

Another issue. There is a theme/language switcher via the front end. I wanted to test out a different theme (eyeball) which worked just fine but now I want to revert back to 'classic' but the option to do so no longer existing.  I even checked via admin settings and I see where I could change the theme to 'classic' (which is already set to that) and so I saved it but the eyeball theme still showing thus the 'classic' theme is not saved.

Is there somewhere else that I need to change it back to my 'classic' theme? Maybe purging tool in the admin to clear the cookies?  Finally, if those do not work, is there a default user file that I can edit to revert my theme back to 'classic'?

Thank you.
Logged

newseed

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: Upgrade from 1.4.27 to 1.6x
« Reply #12 on: February 10, 2021, 06:25:57 pm »

One last thing, via the front end,  you have the LOGIN link, I don't want that to appear for any users.  This gallery is strictly managed by one user (the client) but I want to keep the LOGOUT link avaialbe so that the client can logout quickly.

I promise, I think that is the last of questions I will ask.
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4799
    • Windsurf.me
Re: Upgrade from 1.4.27 to 1.6x
« Reply #13 on: February 11, 2021, 11:08:28 am »

Can you please in future start separate threads for your additional questions. We have a one problem per thread policy to make it easier for visitors to search for a specific problem. Hope you understand.

How to remove the login link has been asked many times and a quick search brings up many options. It can be done in the theme engine etc but IMO it is easiest to use the final extract plug-in- https://forum.coppermine-gallery.net/index.php/topic,79580.0.html

Theme selection is stored in a cookie so sometimes even after changing theme that cookie is not reset on your local machine. You can force that by adding ?theme=xxx to the end of your URL. This is outlined in the docs as well as on the forums many times as quite a few peop,e experience similar when experimenting.

Hope that helps.
« Last Edit: February 11, 2021, 08:05:59 pm by Phill Luckhurst »
Logged
It is a mistake to think you can solve any major problems just with potatoes.

newseed

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: Upgrade from 1.4.27 to 1.6x
« Reply #14 on: February 11, 2021, 03:55:38 pm »

Thank you so much. It's been about 8-10 years since I last messed with Coppermine.  After I am done with this and the other upgrade, being 63 years old, I don't think I will be messing with it again.

Thank you again.
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4799
    • Windsurf.me
Re: Upgrade from 1.4.27 to 1.6x
« Reply #15 on: February 11, 2021, 08:09:24 pm »

Iím sure you have plenty more years in you to play.

Hopefully, using the installer stub will be all you need to keep abreast of any further updates now you are current.

Apologies if I came over as a little abrupt above. I struggle with content such as yours so while I try to continue to help it does make me quite tense.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

newseed

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: Upgrade from 1.4.27 to 1.6x
« Reply #16 on: February 11, 2021, 08:45:14 pm »

Not at all nor was I offended. You are good. Thanks for helping out.
Logged
Pages: [1]   Go Up
 

Page created in 0.053 seconds with 19 queries.