Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1] 2   Go Down

Author Topic: trying to upgrade from 1.5.8 to 1.6+  (Read 2328 times)

0 Members and 1 Guest are viewing this topic.

heavensportal

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Posts: 259
    • The Fantasy Attic
trying to upgrade from 1.5.8 to 1.6+
« on: December 28, 2020, 03:24:19 am »

I tried using the stub installer file and it claimed it went proper but would not accept my username/password, went into a loop of login over and over. It is PHP version 7.2

Removed the installer file it put in there and then tried the upgrade, update, and upgrader and updater files to no avail cause they all claimed it had not been installed right.

Then I tried again by taking out the config file and replaced a new one...well then tried the stub installer and it installed without issue and then I got the place to add the db username/password and db prefix.

After doing so it said all was good and then went to a white page with nothing showing.

In the error_log I found this:

Code: [Select]
PHP Fatal error:  Call to undefined function mcrypt_create_iv() in /home/thefanta/public_html/attic/cpg/include/passwordhash.inc.php on line 63[/code

Now what do I do...since it is bridged with the forum do I have to change my password?
Logged

heavensportal

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Posts: 259
    • The Fantasy Attic
Re: trying to upgrade from 1.5.8 to 1.6+
« Reply #1 on: December 28, 2020, 03:28:10 am »

Now it is flashing an error that it was not installed correctly and to click the link for the installer but it goes white right away, without allowing the click of link.
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4822
    • Windsurf.me
Re: trying to upgrade from 1.5.8 to 1.6+
« Reply #2 on: December 28, 2020, 03:39:30 am »

You should deactivate the bridge before upgrading. Also disable all plugins.

If you have a backup, best restore that and make sure your site is working before you start.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

heavensportal

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Posts: 259
    • The Fantasy Attic
Re: trying to upgrade from 1.5.8 to 1.6+
« Reply #3 on: December 28, 2020, 07:55:21 am »

The gallery was functional proper to my trying to upgrade it. I will reupload the older db and try again tomorrow. I went through and removed the plugins totally after uninstalling them.
Do I just delete the database and re-upload it or should I also upload the older files, then proceed with the db.
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4822
    • Windsurf.me
Re: trying to upgrade from 1.5.8 to 1.6+
« Reply #4 on: December 28, 2020, 10:22:33 am »

Just upload the files for now and see if that works. If it doesnít then do the DB. Letís get your gallery running before the upgrade.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1733
Re: trying to upgrade from 1.5.8 to 1.6+
« Reply #5 on: December 28, 2020, 02:14:21 pm »

If you are actually trying to upgrade to 1.6.x from 1.5.8, that will not work. As described in a number of places, CPG 1.5.x must be at least 1.5.20 to upgrade directly to 1.6.x. You must first update your gallery to 1.5.48. Then you can upgrade to the latest 1.6.x version.
Logged

heavensportal

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Posts: 259
    • The Fantasy Attic
Re: trying to upgrade from 1.5.8 to 1.6+
« Reply #6 on: December 28, 2020, 06:01:16 pm »

If you are actually trying to upgrade to 1.6.x from 1.5.8, that will not work. As described in a number of places, CPG 1.5.x must be at least 1.5.20 to upgrade directly to 1.6.x. You must first update your gallery to 1.5.48. Then you can upgrade to the latest 1.6.x version.
OMG my fingers lost their mind...I did not notice that I wrote that....nop I had the files up for the  gallery---that was working before the upgrade---at the 1.5.48. I try to get things upgraded with each one. I was wondering, since the gallery was first created eons ago, I had a different password back then, then later on in life it got bridged to the forum for ease of just needing the one log in info.  Could that be the issue?
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1733
Re: trying to upgrade from 1.5.8 to 1.6+
« Reply #7 on: December 28, 2020, 06:42:24 pm »

I was able to use a developer method to force your site to run the update script. Please see if things are better for you now.

P.S. you need to update to 1.6.09

Logged

heavensportal

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Posts: 259
    • The Fantasy Attic
Re: trying to upgrade from 1.5.8 to 1.6+
« Reply #8 on: December 29, 2020, 12:08:42 am »

Well, I just tried it by tying the url and not using a bookmark...no joy, it tells me the login link. I clik it and it sends me to the forum...that's good. But then it just login loopsville. If I use the forum, logout and then relog then go to the gallery it does the same thing.
I may have to just redo the database after changing the password to match the one in the  forum???
The way it claims to upgrade is what it kept telling me....not sure.. I will just load the database then if need be redo the files again . The first time when I got a login screen it was a little login screen with no other questions. I had to go hunting down the pass word for it in some earlier  databases for the gallery installation.
Do you thing it would be better to add the db to the forum database or leave as is?
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4822
    • Windsurf.me
Re: trying to upgrade from 1.5.8 to 1.6+
« Reply #9 on: December 29, 2020, 01:59:07 pm »

Check the guides for manually disabling the bridge. Once disabled you should be able to logon directly to your Coppermine install.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

heavensportal

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Posts: 259
    • The Fantasy Attic
Re: trying to upgrade from 1.5.8 to 1.6+
« Reply #10 on: December 29, 2020, 06:01:30 pm »

I tried everything but finally ended up reuploading the 1.5.48 files and the database to be able to get to the gallery from the forum.

Upon doing so and accessing the gallery I found all plugins still on so I uninstalled them once more(I had turned them off) and I should be able to turn off the bridge, if still needed???

Then trying the upgrade again, at first glance after this hosting move I seem to have only lost 2 images. Not bad cause they were recent and he should be able to reupload them.

Logged

heavensportal

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Posts: 259
    • The Fantasy Attic
Re: trying to upgrade from 1.5.8 to 1.6+
« Reply #11 on: December 30, 2020, 02:54:29 am »

OK, I uploaded a fresh copy of the former 1.5.48 database and forum smf 2.0.17 stuff too....was able to get into the gallery via the bridging. No matter what I did though it would not let me log into the gallery to turn off the bridge. I found instructions on how to do so via another process and did it.
Then I uploaded all my older directories/files from before the update, as well as the database earlier. ran the stub file after uploading all the goodies from the update folder...which did its thing and then allowed me to access the rest of the installer things and yes I turned bridge back on (to early??).
Now after it claiming that it installed the new version it took me to a page that showed me to go to home page or version check and now I get this:
Critical error There was an error while processing a database query
I look at the error_log and t says:
Code: [Select]
[30-Dec-2020 01:04:39 UTC] PHP Fatal error:  Class 'Inspekt_Cage' not found in /home/xxxx/cpg/include/inspekt.php on line 147

that line is: (139-147)
Code: [Select]
public static function makeGetCage($strict=TRUE) {
        /**
         * @staticvar $_instance
         */
        static $_instance;

        if (!isset($_instance)) {
            $_instance = Inspekt_Cage::Factory($_GET, $strict);
        }
What to do now??
Logged

heavensportal

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Posts: 259
    • The Fantasy Attic
Re: trying to upgrade from 1.5.8 to 1.6+
« Reply #12 on: December 30, 2020, 03:06:09 am »

I keep forgetting to ask also...I noticed that when it tries to install it says that I should change from MYSQL to MYSQLI
because the former is deprecated but the phpMyadmin is MYSQL, could my clicking to make it so have messed things up?
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1733
Re: trying to upgrade from 1.5.8 to 1.6+
« Reply #13 on: December 30, 2020, 06:22:43 am »

You're not messing it up. You should be choosing mysqli.
Logged

heavensportal

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Posts: 259
    • The Fantasy Attic
Re: trying to upgrade from 1.5.8 to 1.6+
« Reply #14 on: December 30, 2020, 06:59:04 pm »

You're not messing it up. You should be choosing mysqli.

Even if it is not anywhere in the php, that I can see anyway
Right now everything went south again, can't get to forum at all. I see the message from settings file but that is all, to access site there are no error_logs and all it does is spin.
Logged

heavensportal

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Posts: 259
    • The Fantasy Attic
Re: trying to upgrade from 1.5.8 to 1.6+
« Reply #15 on: January 13, 2021, 09:31:17 pm »

OK, the gallery is not working at all now. I have reinstalled an older DB from when it worked but still nothing. it is bridged and IF I need to reinstall fresh prior to everything is fine, providing the images and such are not lost. I don't know if doing that then applying the db to the new gallery would work (1.5.48 version clean install that is) then think about upgrading.
I can't change the PHP from 7.3 to 5.6 cause being bridged the forum will go away.
Please help.

Code: [Select]
Fatal error:  Uncaught Error: Call to undefined function mysql_connect() in /home/xxxxx/cpg/include/functions.inc.php:183 Stack trace: #0 /home/xxxxx/cpg/include/init.inc.php(171): cpg_db_connect() #1 /home/xxxxx/cpg/index.php(26): require('/home/xxxxx.') #2 {main} thrown in /home/thefanta/public_html/attic/cpg/include/functions.inc.php on line 183
Logged

heavensportal

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Posts: 259
    • The Fantasy Attic
Re: trying to upgrade from 1.5.8 to 1.6+
« Reply #16 on: January 17, 2021, 09:37:56 pm »

Code: [Select]
OK, this is happening right now, click the Users button in the menu and get this error, and no idea what to do to fix it.

[code]Critical error There was an error while processing a database query



This shows in debug when turned on:
Code: [Select]
Critical error There was an error while processing a database query.

 While executing query 'SELECT id_member AS user_id, real_name AS user_name, email_address AS user_email, date_registered AS user_regdate, last_login AS user_lastvisit, is_activated AS user_active, COUNT(pid) AS pic_count, ROUND(SUM(total_filesize)/1024) AS disk_usage, group_name, group_quota FROM `thefanta_smf`.smf8_members AS u INNER JOIN `thefanta_cpg2`.cpg14x_usergroups AS g ON u.id_post_group+100 = g.group_id LEFT JOIN `thefanta_cpg2`.cpg14x_pictures AS p ON p.owner_id = u.id_member GROUP BY user_id ORDER BY user_regdate DESC LIMIT 0, 25;' in bridge/udb_base.inc.php on line 59 database error: 0 : 
 
 File: /home/thefanta/public_html/attic/cpg/include/functions.inc.php - Line: 250

and
Code: [Select]
[table][tr][td][/td][td][img width=16 height=16]http://www.thefantasiesattic.net/attic/cpg/images/icons/bug.png[/img]Debug Info [/td][/tr][tr] [td]
[/td] [/tr][tr] [td][left] [url=http://www.thefantasiesattic.net/attic/cpg/phpinfo.php][img width=16 height=16]http://www.thefantasiesattic.net/attic/cpg/images/icons/phpinfo.png[/img]display phpinfo[/url] Debug Output: show / hide [/left][/td] [/tr][tr] [td] Notices [url=http://www.thefantasiesattic.net/attic/cpg/help.php?f=empty.htm&h=lang_cpg_debug_output[notices]&t=lang_cpg_debug_output[notices_help_admin]][img width=13 height=11]http://www.thefantasiesattic.net/attic/cpg/images/help.gif[/img][/url] [/td] [/tr][tr][td][b]/bridge/smf20.inc.php[/b][list]
[li]Warning line 33: Declaration of cpg_udb::view_profile() should be compatible with core_udb::view_profile($uid)   [/li][/list][/td][/tr][/table]

Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1733
Re: trying to upgrade from 1.5.8 to 1.6+
« Reply #17 on: January 18, 2021, 01:51:22 pm »

Please provide me with an admin login.
Logged

heavensportal

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Posts: 259
    • The Fantasy Attic
Re: trying to upgrade from 1.5.8 to 1.6+
« Reply #18 on: January 18, 2021, 08:15:29 pm »

see pm
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1733
Re: trying to upgrade from 1.5.8 to 1.6+
« Reply #19 on: January 19, 2021, 12:58:35 am »

Your CPG and SMF tables need to be in the same database (with same database user).
Logged
Pages: [1] 2   Go Up
 

Page created in 0.024 seconds with 20 queries.