Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Stumped. Issue with myBB 1.8.24 and cpg1.6.09 login. Redirects ALL to forum  (Read 633 times)

0 Members and 1 Guest are viewing this topic.

cadude7

  • Coppermine newbie
  • Offline Offline
  • Posts: 11

Hello

I am replacing PHPAlbums with Coppermine and I love this ability to integrate the forum side of mysite with the photo side.  My site basically has gone up as a replacement for facebook/instagram after mom passed so the family (which is scattered around the world) can post files, etc that don't want to use facebook. The site is also for content that we cant post maybe because of file size and background noise content that gets blocked. This webiste is basically my family's webpage that I maintain.  Because we had found some nasty issues with variable saturation we was forced to move to another platform and im trying out yours.  My only problem so far is this login problem that i need to be simple.


old site being replaced:  https://elterfamily.ca/Elter/PhotoAlbum/  This had its own login outside the rest.  Has a bad variable sat issue security reported.

I have found that the integration does seem to work but only if your logging in to the planned target.  For instance if you login to the forums then click the albums link (i created here editing templates in myBB) it seems normal.  I did the same in coppermine using the sample theme.  But as soon as they login from a page from the Albums, it always takes them back to the forum; or trys too.  I am noticing that the referer on the logout/login button is just the page name and this seems to be my issue.  How to get this bad boy to change to /Albums/Page.php where page can be index.php, displayimage.php, thumbnails.php, etc.   Now i could maybe tweak myBB and make these pages blank with redirects to the proper area, with check for the coopermine variable in php to redirect back to the albums...i'm making ideas here but i really am not to sure which scripts i should target especially when templates are needed.  I could easily target core and do this but then upgrades are sloshed for me....really don't want another PHpAlbums here.   There i had to fix a lot of stuff; security core stuff because they decided not too. But there database is dead as of 8.0 php.   I love this idea of integrating and adding buttons to either side is working as a workaround for now for the younger generation.

Steps to Reproduce (GE Tech here so i write these for a living)

Windows 2012R2 Standard
IIS 7.5
PHP 7.4.1
GD2 installed

Cookie myBB:  Name: .elterfamily.ca (ive tried everything but and this is what works)  Coppermine wont accept a value like this
                    Path: /
                    px: none defined

Cooke CopperMine: Name(default): cpg16x
                         Path: /

Ive tried combinations including /Elter/ as the path on both to no avail.  Refer always stays =page.php

Steps to show login works with a workaround for now:
1.  Access the website   https://elterfamily.ca/Elter/Albums/
2.  Click login:  it will redirect to /Forums/  Login with the credentials:
                          User:  testuser
                          Pass:  Test2020$
3. Login takes you to the forum/index.php.  Here is where i want to do a coppermine check and redirect to the proper page
4. Click albums to take yo to albums
5.  Click forums to take you to forums
6.  Go back to Albums and logout
7.  Takes you back to Forums index.php

Cause a 404 error due to thumbnails.php not existing in the Forum directory
BE A GUEST TO TEST THIS PART.  LOGOUT.
1.  Goto the Albums Page https://elterfamily.ca./Elter/Albums/
2.  Click Noel Elter
3.  Click his wedding link to goto the thumbnail page
4.  Click login and enter the above credentials
5.  Boom!  404 error.  Change URL back to /Albums/  and we are good.  I have old guests that aren't members that need easy peazy links.  404 errors cause messages and phone calls.

I have read the help docs, followed what i though was good settings but i still cant get this redirect thing to work. (I also want to point out that i found reading your help docs at times funny but also at times seemed like a cranky developer being rude.  Alot of the time it seemed like more babbling then any help.  You should redo them as i found them not helpful.  I write these docs for a living for GE Digital.) 

I had found a posing about modifying the mybb.inc.php file which i did.  This allowed the cookies to actually come over when the links got clicked from either side to come back.  But it never fixed this issue as the article had suggested.  I was on my iphone searching and damn if i can find that page now.  I was looking at the other include file and it too was using links that dont exist on my box.  Should this also be changed?  I don't use myBB to identify any folder on my system and it doesn't read as a variable to me looking at the code....looks like a pure 'http:Localhost' string.  I haven't changed that other file yet and maybe this is why the redirect is still flaking out on thumbnails. 

Any ideas I would greatly appreciate?  All in all i love the app so far. ;D  Just this login SSO thing (bridging) isn't working as i would like it too or expect it too based on the messages....you will be redirected to where you came from.



Thanks,
Bill
Edmonton, Canada
Logged
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 21 queries.