Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Can't Login / Can't Upgrade / New PHP Version (1.5.24)  (Read 304 times)

0 Members and 1 Guest are viewing this topic.

Artin

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Can't Login / Can't Upgrade / New PHP Version (1.5.24)
« on: June 03, 2020, 08:14:10 am »

Hi,

I have an old installation of Coppermine from many years ago that I'm trying to revive however I'm facing two issues that I can't really fix without the other being fixed.

1) Can't Login
When I go to the login page and enter my admin credentials, I just get "logged in" as a guest but even when I go to the homepage after that I'm not logged in at all. There's an error in red on the login page that says "Warning your browser does not accept script's cookies". I've tried the following after searching for help to fix this to no avail:
- Disabled cookie plugin. Well I didn't have a cookie plugin at all, so just renamed the plugin folder to disable everything.
- Checked server time of machine and it's up to date.
- Made sure "cookies_need_consent" was set to 0 value in the "cpg14x_config" table. It already was.
- My cookie_path path is set to just / in my database

Any ideas on how to fix this so I can login as admin?

2) Gallery Errors - Updated PHP
The gallery still works but at the top of each page I get the following error messages:
Code: [Select]
Strict Standards: Non-static method Inspekt::makeSuperCage() should not be called statically in /home/user/public_html/gallery/include/init.inc.php on line 42

Strict Standards: Non-static method Inspekt_Supercage::Factory() should not be called statically in /home/user/public_html/gallery/include/inspekt.php on line 282

Strict Standards: Non-static method Inspekt::makeGetCage() should not be called statically, assuming $this from incompatible context in /home/user/public_html/gallery/include/inspekt/supercage.php on line 124

Strict Standards: Non-static method Inspekt_Cage::Factory() should not be called statically, assuming $this from incompatible context in /home/user/public_html/gallery/include/inspekt.php on line 147

Strict Standards: Non-static method Inspekt::makePostCage() should not be called statically, assuming $this from incompatible context in /home/user/public_html/gallery/include/inspekt/supercage.php on line 125

Strict Standards: Non-static method Inspekt_Cage::Factory() should not be called statically, assuming $this from incompatible context in /home/user/public_html/gallery/include/inspekt.php on line 170

Strict Standards: Non-static method Inspekt::makeCookieCage() should not be called statically, assuming $this from incompatible context in /home/user/public_html/gallery/include/inspekt/supercage.php on line 126

Strict Standards: Non-static method Inspekt_Cage::Factory() should not be called statically, assuming $this from incompatible context in /home/user/public_html/gallery/include/inspekt.php on line 192

Strict Standards: Non-static method Inspekt::makeEnvCage() should not be called statically, assuming $this from incompatible context in /home/user/public_html/gallery/include/inspekt/supercage.php on line 127

Strict Standards: Non-static method Inspekt_Cage::Factory() should not be called statically, assuming $this from incompatible context in /home/user/public_html/gallery/include/inspekt.php on line 215

Strict Standards: Non-static method Inspekt::makeFilesCage() should not be called statically, assuming $this from incompatible context in /home/user/public_html/gallery/include/inspekt/supercage.php on line 128

Strict Standards: Non-static method Inspekt_Cage::Factory() should not be called statically, assuming $this from incompatible context in /home/user/public_html/gallery/include/inspekt.php on line 238

Strict Standards: Non-static method Inspekt::makeServerCage() should not be called statically, assuming $this from incompatible context in /home/user/public_html/gallery/include/inspekt/supercage.php on line 134

Strict Standards: Non-static method Inspekt_Cage::Factory() should not be called statically, assuming $this from incompatible context in /home/user/public_html/gallery/include/inspekt.php on line 124

I've worked out that it's because my server was automatically updated to a newer PHP version. However, I can't fix it because I can't login to upgrade my Coppermine version that works with the newer PHP version.

Extra Details:
Coppermine Gallery Version: 1.5.24
Server PHP Version: 5.5.30

Would really appreciate any help.

Thank you!
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 1535
Re: Can't Login / Can't Upgrade / New PHP Version (1.5.24)
« Reply #1 on: June 03, 2020, 02:59:13 pm »

Perform the upgrade procedure to CPG 1.5.48
https://documentation.coppermine-gallery.net/en/upgrading.htm

Once running again, you should consider upgrading to CPG 1.6.x
Logged

Artin

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Can't Login / Can't Upgrade / New PHP Version (1.5.24)
« Reply #2 on: June 12, 2020, 06:22:43 am »

Apologies for the delay. Thanks for that! That did the trick.

One question regarding upgrading from 1.5.48 to 1.6.08. Can I do it like the following without having to upload and overwrite through FTP:

1. Delete every single file/folder except my albums folder, and the include/config.inc.php and anycontent.php files.
2. Upload all files/folders in the 1.6.08 package, except for the above.
3. Run update.php script.

Is that possible or do the files specifically need to be overwritten? I have no plugins or themes to worry about.

Thanks for your help.
Logged

Artin

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Can't Login / Can't Upgrade / New PHP Version (1.5.24)
« Reply #3 on: June 12, 2020, 07:09:48 am »

Never mind. I just upgraded successfully with the easy installer.
Logged
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 20 queries.