Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Help Topics  (Read 3139 times)

0 Members and 1 Guest are viewing this topic.

Paul-D

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Help Topics
« on: April 12, 2020, 01:13:25 pm »

Hi, I currently have version 1.6.08 (using rainy_day theme) and when I click on any of the help icons in the configuration section I just get a blank pop up window with no text. I know that this was working OK previously but not sure when or why it stopped working. Any suggestions?
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1928
Re: Help Topics
« Reply #1 on: April 12, 2020, 02:48:13 pm »

CPG documentation is no longer part of a local gallery install. Clicking on help icons will cause it to attempt to get the relevant documentation from a separate online source. This means that the CPG install will have to be able to reach the documentation urls. If this proves to be a problem in some particular situation, you can add a local copy of the documentation to your install. Place the documentation files into a folder named docs in your installation.
Logged

Paul-D

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: Help Topics
« Reply #2 on: April 12, 2020, 04:09:59 pm »

Thanks. I can't quite work out why it's not able to access the online docs but all working now with the docs you linked to added to my server. Incidentally there was a set of docs already on the server (presumably left there from a previous version?) but they weren't displaying either, it only worked when I replaced them with the docs you linked to.

Thanks for the help!
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1928
Re: Help Topics
« Reply #3 on: April 12, 2020, 04:44:53 pm »

Incidentally there was a set of docs already on the server (presumably left there from a previous version?) but they weren't displaying either, it only worked when I replaced them with the docs you linked to.

That is some explanation as to why it wasn't working. You can test the online documentation access by renaming the docs folder. It should then get the documentation from our servers.
Logged

Paul-D

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: Help Topics
« Reply #4 on: April 12, 2020, 07:15:08 pm »

Strangely no. I did try that but it still wouldn't access the online help, it only seems to work with the local docs but not a problem  :)
Logged

Johnfromhere

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 77
Re: Help Topics
« Reply #5 on: August 22, 2021, 10:30:30 pm »

I realise that this is an old thread but I am having the same problem as described here but do not quite understand the solution.

I haven't used the help button in the configuration for ages but when I did today - blank boxes.

When I go to the 'documentation files' link (GitHub) I can't see any way to download the files - and I am not sure which files to download to put into a local 'docs' directory as directed.

Any enlightenment would be greatly appreciated.

Many thanks.

John.
Logged

Johnfromhere

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 77
Re: Help Topics
« Reply #6 on: August 23, 2021, 02:54:21 pm »

I should have read the GitHub page more carefully!  ::) :-[ :-[.

Downloaded - then uploaded to new 'docs' directory and bingo!

All fixed now.

Apologies.

Cheers.

John
Logged

lili123

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Help Topics
« Reply #7 on: May 22, 2022, 01:44:59 pm »

Hello, it did not help to have docs folder, the help windows were working two weeks ago, and after the PHP update it is not working.
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4860
    • Windsurf.me
Re: Help Topics
« Reply #8 on: May 22, 2022, 02:20:36 pm »

You may have to look at what modules are included with your new PHP install. Sometimes things like cURL are not enabled. There could also be a change of firewall rules on your hosting that is blocking calls to external resources. Unfortunately that is something we cannot help with and you would need to speak to your host for advice. Alternatively you could use a local copy of the docs as discussed above
Logged
It is a mistake to think you can solve any major problems just with potatoes.

lili123

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Help Topics
« Reply #9 on: May 23, 2022, 10:10:22 am »

Hello,

thank you, I have contacted the hosting, they are not able to fix it, they have tried to downgrade PHP but no luck. Also cURL are enabled and firewall rules was not changed. Please any help of this? I have tried upload docs, but it is not working, can someone help?
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1928
Re: Help Topics
« Reply #10 on: May 23, 2022, 12:52:30 pm »

As a minimum, you will need to provide me with a link to your site and and admin login.
Logged

lili123

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Help Topics
« Reply #11 on: May 23, 2022, 01:11:15 pm »

Hey, I have send you a PM, please read, thanks!
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1928
Re: Help Topics
« Reply #12 on: May 23, 2022, 02:10:33 pm »

I repaired your help.php file, set your PHP version to the host current default (7.4) and enabled allow_url_fopen in the php config. So help works now but your theme CSS is not friendly to its display. You can temporarily use a different theme just for yourself ( <site-url>?theme=curve ) and then undo that ( <site-url>?theme=none ).
Logged

lili123

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Help Topics
« Reply #13 on: May 23, 2022, 05:22:57 pm »

Thanks again for the help, it shows the help windows correctly  :)
Logged
Pages: [1]   Go Up
 

Page created in 0.039 seconds with 19 queries.