Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: upgrade from 1.5.48 to 1.6.07 -->login failed  (Read 2662 times)

0 Members and 1 Guest are viewing this topic.

harritapio

  • Coppermine newbie
  • Country: fi
  • Offline Offline
  • Posts: 4
upgrade from 1.5.48 to 1.6.07 -->login failed
« on: February 03, 2020, 01:49:06 pm »

hello,
I updated my cpg 1.5.48 to 1.6.07 with cpg_installer_stub.php and now I can not login to gallery at all. It does recognize my admin "username" and after pw it says; welcome guest. I have tried the installation several times, but the result has been always the same (no access).

I have copied the database from cpg 1.5.48 to a new name to be used with cpg 1.6.07, and I can see all the content of the gallery without any problem. But I have no possibility to login, I believe the passwords are for some reason been damaged during the installation. I do not know how to proceed, any advice is welcome.

https://lannenlokarit.fi/cpg/index.php - my gallery

regards

harri
Logged

harritapio

  • Coppermine newbie
  • Country: fi
  • Offline Offline
  • Posts: 4
Re: upgrade from 1.5.48 to 1.6.07 -->login failed
« Reply #1 on: February 03, 2020, 03:20:53 pm »

Some more info for "login failed" problem:

I have neither plugins nor additional language files in use, only pure installation file: cpg1.6.x-1.6.07.tar.gz

harri
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 1535
Re: upgrade from 1.5.48 to 1.6.07 -->login failed
« Reply #2 on: February 03, 2020, 04:00:54 pm »

You may have been using the Cookie Consent Plugin before and now you will have to change a value in the database.
https://forum.coppermine-gallery.net/index.php/topic,79419.msg385099.html#msg385099
Logged

harritapio

  • Coppermine newbie
  • Country: fi
  • Offline Offline
  • Posts: 4
Re: upgrade from 1.5.48 to 1.6.07 -->login failed
« Reply #3 on: February 03, 2020, 06:35:25 pm »

Thanks for good advice!
My previous installation of cpg1.5.48  is on/coppermine path and cpg1.6.07 is on /cpg path, and some remaining traces are still in the config table.

These lines i could find in config table:
Code: [Select]
Delete contact_form_subject_content Coppermine gallery contact form
 Delete cookie_name cpg15x
 Delete cookie_path /coppermine/
 Delete ecards_more_pic_target https://lannenlokarit.fi/coppermine/
 Delete cookies_need_consent 0

cookies _need_consent appears to be "zero" but there might be more cpg1.5.48 traces in other db tables.

harri
Logged

harritapio

  • Coppermine newbie
  • Country: fi
  • Offline Offline
  • Posts: 4
Re: upgrade from 1.5.48 to 1.6.07 -->login failed
« Reply #4 on: February 03, 2020, 07:04:59 pm »

Good news, now admin login is ok!

I did not find any relevant traces from old path on other db tables, only on config table.

Thanks!

Harri
Logged
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 21 queries.