Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Database problems?  (Read 1163 times)

0 Members and 1 Guest are viewing this topic.

KchoPrro

  • Coppermine frequent poster
  • ***
  • Country: es
  • Offline Offline
  • Gender: Male
  • Posts: 205
    • Adolfo Ventas - Naturaleza Andaluza
Database problems?
« on: January 04, 2021, 12:06:34 pm »

Hello friends, for a long time my gallery gives me an error:

Quote
Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /var/www/vhosts/adolfoventas.es/httpdocs/galeria/include/functions.inc.php:183 Stack trace: #0 /var/www/vhosts/adolfoventas.es/httpdocs/galeria/include/init.inc.php(171): cpg_db_connect() #1 /var/www/vhosts/adolfoventas.es/httpdocs/galeria/index.php(26): require('/var/www/vhosts...') #2 {main} thrown in /var/www/vhosts/adolfoventas.es/httpdocs/galeria/include/functions.inc.php on line 183

My website: http://www.adolfoventas.es/galeria/

A photo from the gallery:
https://www.adolfoventas.es/galeria/displayimage.php?pid=697

I have checked everything and it seems to be in order, the database is correct, what is the problem?
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1731
Re: Database problems?
« Reply #1 on: January 04, 2021, 02:11:53 pm »

Your hosting account has probably switched to using PHP7.x instead of PHP5.x.  You will either need to have PHP5.x be active again or upgrade your gallery to CPG 1.6.x.

You also need to fix your SSL certificate.
Logged

KchoPrro

  • Coppermine frequent poster
  • ***
  • Country: es
  • Offline Offline
  • Gender: Male
  • Posts: 205
    • Adolfo Ventas - Naturaleza Andaluza
Re: Database problems?
« Reply #2 on: January 08, 2021, 09:20:25 am »

Your hosting account has probably switched to using PHP7.x instead of PHP5.x.  You will either need to have PHP5.x be active again or upgrade your gallery to CPG 1.6.x.

You also need to fix your SSL certificate.

OK thanks!!. I will have to update, manually, to version 1.6x  ;)
Logged

KchoPrro

  • Coppermine frequent poster
  • ***
  • Country: es
  • Offline Offline
  • Gender: Male
  • Posts: 205
    • Adolfo Ventas - Naturaleza Andaluza
Re: Database problems?
« Reply #3 on: January 08, 2021, 10:56:54 am »

OK thanks!!. I will have to update, manually, to version 1.6x  ;)

Finally, I have spoken with my hosting provider and they have lowered the PHP5.x version, now it works as before, without problems.

I'm going to consider upgrading to version 1.6x of coppermine whith update :)
Logged
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 20 queries.