Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: 1.5.48 --> 1.6.07 Parse error message while running update.php  (Read 5830 times)

0 Members and 1 Guest are viewing this topic.

cboudier

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 33
    • Album-Photos
1.5.48 --> 1.6.07 Parse error message while running update.php
« on: October 27, 2019, 11:50:24 pm »

Hello
Don't know what went wrong, but my gallery is down now.
I tried to upgrade manually from 1.5.48 to 1.6.07 (made a backup of my SQL database, anycontent.php, albums folder and conf.inc.php and then upload all the 1.6.07 files and folders),
but when running update.php, I get this :
Parse error: syntax error, unexpected ':' in /mnt/136/sdb/b/a/cboudier/update.php on line 458

If now I try to run cpg_installer_stub.php I get this error message :
Parse error: syntax error, unexpected ':' in /mnt/136/sdb/b/a/cboudier/cpg_installer_stub.php on line 227

Any idea ?
Thanks

My Coppermine gallery is here --> http://cboudier.free.fr
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 1535
Re: 1.5.48 --> 1.6.07 Parse error message while running update.php
« Reply #1 on: October 28, 2019, 12:02:32 am »

You must be using PHP 5.3 or newer.
Logged

cboudier

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 33
    • Album-Photos
Re: 1.5.48 --> 1.6.07 Parse error message while running update.php
« Reply #2 on: October 28, 2019, 12:10:43 am »

Thank you for your fast answer !
Unfortunately, I can't do anything about this (it's from my internet provider), so what should I do ?
revert to 1.5.48 ?
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 1535
Re: 1.5.48 --> 1.6.07 Parse error message while running update.php
« Reply #3 on: October 28, 2019, 12:17:56 am »

Ask your provider to upgrade the PHP version used on your site or revert to 1.5.48
Logged

cboudier

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 33
    • Album-Photos
Re: 1.5.48 --> 1.6.07 Parse error message while running update.php
« Reply #4 on: October 28, 2019, 12:36:09 am »

Thanks again for your help.
I found a way to force the use of PHP 5.6 (via a .htaccess file) and now it's online again :)

Bye
Logged
Pages: [1]   Go Up
 

Page created in 0.021 seconds with 20 queries.