Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: The selected album/file does not exist! And Issues With Admin Rezize Thumbnails  (Read 4231 times)

0 Members and 1 Guest are viewing this topic.

nowordneeded

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 183

Hello:

I've just upgraded my gallery to the current stable version of 1.6.07 and it is located here: http://garylockwood.samskara.org/gallery

The two issues I'm having is with first, when I went to resize the thumbnails and ran the Admin Tools. I get this error:

Code: [Select]
Fatal error: Cannot redeclare theme_cpg_die() (previously declared in.
In this case the error is on line 1765, but it's only a curly bracket.

The second issue I'm having is, after the update of the database and all, everything looks good. The issue is that when I click on the intermediate picture, it gives me an error with this page:

Code: [Select]
The selected album/file does not exist!
Not sure what happened this time around, but this is what I'm getting. If RonMac replies, I've uploaded your tool for checking files to expedite.

Thanks.
Logged
Sometimes my musings are too confusing for someone not inside my head.

nowordneeded

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 183

So I was able to fix the image issue by replacing the theme file in my themes. However, the issue is still persisting with the Admin Tools isue. I get this:

Code: [Select]
A valid form token could not be found. Critical error
Screencap attached.

NWN
Logged
Sometimes my musings are too confusing for someone not inside my head.

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 1423

Please try with the Curve theme to see whether it is a problem with your theme.
http://garylockwood.samskara.org/gallery/?theme=curve
Logged

nowordneeded

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 183

Ron:

Yes, it still happens. I still get the same warning.

NWN
Logged
Sometimes my musings are too confusing for someone not inside my head.

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 1423

If this is happening after it runs for a while, you need to increase the Form Token Lifetime in the config.
Logged

nowordneeded

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 183

Ron:

Is it the config in the files, or from the config screen in the Coppermine itself?

NWN
Logged
Sometimes my musings are too confusing for someone not inside my head.

nowordneeded

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 183

Ron:

I increased it to 1800 and ran the command again and got this:


Code: [Select]
Allowed memory size of 134217728 bytes exhausted (tried to allocate 20480 bytes) Critical error
NWN
Logged
Sometimes my musings are too confusing for someone not inside my head.

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 1423

You need to increase the amount of memory that PHP allows for processes from 128M to 256M. (php.ini or .user.ini)
Logged

nowordneeded

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 183

Ron:

I created a php.ini file and inserted the following code:

Code: [Select]
ini_set('memory_limit','268M');
I ran the admin tools again to resize thumbnails, and received the following:


Code: [Select]
A valid form token could not be found. Critical error
I have never had this happen before. I've done this many times in my other galleries, but this one for some reason is just not cooperating.

NWN
Logged
Sometimes my musings are too confusing for someone not inside my head.

nowordneeded

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 183

Well I managed to get all the thumbnails fixed, however, I had to do it one album at a time. Thankfully the gallery has very little in it and is one of my least updated sites. There was only one album that kept giving me the error. Fortunately it was already fixed before it timed out and created the error. I don't know what more can be done as I did "solve" the issue. I thought of closing the ticket but I'll leave it open in case someone wants to add something. If no replies forthcoming, I'll close it as "solved".

NWN
Logged
Sometimes my musings are too confusing for someone not inside my head.
Pages: [1]   Go Up
 

Page created in 0.022 seconds with 22 queries.