Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Many erros ! Help! >.<  (Read 10371 times)

0 Members and 1 Guest are viewing this topic.

a_penalva

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Many erros ! Help! >.<
« on: August 24, 2019, 06:11:08 pm »

My gallery is : http://morenabaccarinbr.sosugary.org/


Many errors in gallery:
1- the message appears:
cpg1.5.48 has been released. It's a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.

I don't know how to do this, like someone explain to me how I do it?

and appearing these errors:
/include/inspekt/cage.php
Deprecated line 253: Non-static method Inspekt::getMatched() should not be called statically, assuming $this from incompatible context
Deprecated line 529: Non-static method Inspekt::isIp() should not be called statically, assuming $this from incompatible context
Deprecated line 236: Non-static method Inspekt::getEscaped() should not be called statically, assuming $this from incompatible context
Deprecated line 236: Non-static method Inspekt::getEscaped() should not be called statically, assuming $this from incompatible context
Deprecated line 140: Non-static method Inspekt::getAlnum() should not be called statically, assuming $this from incompatible context
/include/functions.inc.php
Deprecated line 183: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead
Runtime Notice line 773: Non-static method CPGPluginAPI::filter() should not be called statically
Runtime Notice line 816: Non-static method CPGPluginAPI::filter() should not be called statically
Runtime Notice line 821: Non-static method CPGPluginAPI::filter() should not be called statically
Runtime Notice line 822: Non-static method CPGPluginAPI::filter() should not be called statically
Runtime Notice line 6157: Non-static method CPGPluginAPI::filter() should not be called statically
Notice line 4308: Undefined variable: result
Runtime Notice line 6157: Non-static method CPGPluginAPI::filter() should not be called statically
/include/init.inc.php
Runtime Notice line 230: Non-static method CPGPluginAPI::load() should not be called statically
Runtime Notice line 435: Non-static method CPGPluginAPI::action() should not be called statically
/include/plugin_api.inc.php
Runtime Notice line 86: Non-static method CPGPluginAPI::action() should not be called statically
/bridge/udb_base.inc.php
Deprecated line 353: mysql_escape_string(): This function is deprecated; use mysql_real_escape_string() instead.
/include/themes.inc.php
Runtime Notice line 153: Non-static method CPGPluginAPI::filter() should not be called statically
Runtime Notice line 190: Non-static method CPGPluginAPI::filter() should not be called statically
Runtime Notice line 2439: Non-static method CPGPluginAPI::filter() should not be called statically
Runtime Notice line 1699: Non-static method CPGPluginAPI::filter() should not be called statically
Runtime Notice line 1554: Non-static method CPGPluginAPI::filter() should not be called statically
/pluginmgr.php
Runtime Notice line 276: Non-static method CPGPluginAPI::installed() should not be called statically
Runtime Notice line 276: Non-static method CPGPluginAPI::installed() should not be called statically

and I can't upload multiple images
Logged

lurkalot

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 905
  • +Tinyportal Support team.
Re: Many erros ! Help! >.<
« Reply #1 on: August 24, 2019, 06:21:52 pm »

So looks like you're running Coppermine v1.5.34 and your host has upped the PHP version.  Can you confirm what version of PHP your server is running? If your server is running PHP 7.x.x then you'll need to upgrade to Coppermine 1.6.06 to make it compatible.
Logged
Running SMF 2.0.15  / Tinyportal 1.6.4, bridged with Coppermine 1.6.06, plus cpmfetch 2.0.0

a_penalva

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Re: Many erros ! Help! >.<
« Reply #2 on: August 24, 2019, 09:08:12 pm »

Every time that I try to see PHP information, error message appears
Logged
Pages: [1]   Go Up
 

Page created in 0.016 seconds with 20 queries.