Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Doesn't work with PHP 7.1  (Read 255 times)

0 Members and 1 Guest are viewing this topic.

The_Miner

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Doesn't work with PHP 7.1
« on: July 13, 2019, 12:51:49 pm »

Hi all,

my provider wrote a mail, that PHP 5.6 is old and will not be supported in die next time.
So I changed the PHP version so 7.1 and get a blank white website. When I'm switching back to 5.6 the Website is working again.

Used version: 1.6.06.

I hope you can help me.


Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 1258
Re: Doesn't work with PHP 7.1
« Reply #1 on: July 13, 2019, 01:14:32 pm »

It is probably being caused by one of your plugins.
Create a disabled_plugins folder. Move all the plugin folders (except the upload_xxx plugins) into the disabed_plugins folder.
If the site now works okay, move them back one at a time until you find the one causing the problem.

Also, follow this advice for your theme:
https://forum.coppermine-gallery.net/index.php/topic,79013.msg385956.html#msg385956
« Last Edit: July 13, 2019, 01:30:04 pm by ron4mac »
Logged

The_Miner

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Doesn't work with PHP 7.1
« Reply #2 on: July 13, 2019, 01:49:06 pm »

Thank you, I worked.  ;D
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 1258
Re: Doesn't work with PHP 7.1
« Reply #3 on: July 13, 2019, 02:29:34 pm »

Could you please tell us the plugin that was causing the problem?
There may be a replacement for it here or here.
Logged

The_Miner

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Doesn't work with PHP 7.1
« Reply #4 on: July 13, 2019, 02:34:18 pm »

Truth be told,- it deleted all of them and installed only the upload plugin.
Logged
Pages: [1]   Go Up
 

Page created in 0.014 seconds with 20 queries.