Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Increase Maximum Upload Size  (Read 591 times)

0 Members and 1 Guest are viewing this topic.

nowordneeded

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 157
Increase Maximum Upload Size
« on: May 03, 2019, 06:56:53 am »

Hello. I'm running the latest stable version in 1.6.06 on this gallery http://lauramennell.org/gallery.

What I'm wanting to know is, I'm trying to upload some HI RES images to the gallery with dimensions of 5790x3870. All of these images in the screengrab below are the same size, yet some uploaded while others didn't. I've also increased the upload size in both my .htaccess and php.ini files. What can I do to get these images added?

Thanks.
Logged
Sometimes my musings are too confusing for someone not inside my head.

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4660
    • Windsurf.me
Re: Increase Maximum Upload Size
« Reply #1 on: May 03, 2019, 10:50:28 am »

We need to determine what is causing the problem. It could be limits on your server or you have limited image sizes in your config. Please follow the troubleshooting guidelines from the docs so we can test some uploads.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

nowordneeded

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 157
Re: Increase Maximum Upload Size
« Reply #2 on: May 03, 2019, 11:43:51 am »

This is a screengrab for what I have in the config file settings:

Logged
Sometimes my musings are too confusing for someone not inside my head.

nowordneeded

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 157
Re: Increase Maximum Upload Size
« Reply #3 on: May 03, 2019, 12:16:44 pm »

I set up the test account and activated debug mode. Here are the deets:

user: test
password: testuser

I received this error when uploading:

Code: [Select]
Error executing ImageMagick - Return value: 9

Cmd line :
/usr/bin/convert -quality 100 -antialias -resize 150 -crop 150x150+0+8 'albums/userpics/10002/07192018_-_2018_Comic_Con_Los_Angeles_Times_012.jpg' 'albums/userpics/10002/thumb_07192018_-_2018_Comic_Con_Los_Angeles_Times_012.jpg'

The convert program said:
#0 /home/obscurad/public_html/lauramennell.org/gallery/uniload.php @498

Logged
Sometimes my musings are too confusing for someone not inside my head.

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 1204
Re: Increase Maximum Upload Size
« Reply #4 on: May 03, 2019, 04:14:20 pm »

You should look at how much memory is allowed for the php process (phpinfo).
Logged

nowordneeded

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 157
Re: Increase Maximum Upload Size
« Reply #5 on: May 04, 2019, 03:51:28 am »

Ron:

Where would I find that? When I look at the phpinfo file all it has in it is coding, no ways to change memory.
Logged
Sometimes my musings are too confusing for someone not inside my head.

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 1204
Re: Increase Maximum Upload Size
« Reply #6 on: May 04, 2019, 04:53:12 am »

Where would I find that? When I look at the phpinfo file all it has in it is coding, no ways to change memory.
One of the admin menu items is phpinfo. It will show you all the PHP settings. Look for memory_limit. I recommend that it be at least 128M ... better is 256M. Depending on your system, it can be set either in a php.ini file or a .user.ini file.
Logged

nowordneeded

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 157
Re: Increase Maximum Upload Size
« Reply #7 on: May 04, 2019, 08:26:08 am »

I just checked and it said "no value".
Logged
Sometimes my musings are too confusing for someone not inside my head.

nowordneeded

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 157
Re: Increase Maximum Upload Size
« Reply #8 on: May 04, 2019, 08:26:57 am »

Sorry, wrong line. I does say 256M.
Logged
Sometimes my musings are too confusing for someone not inside my head.

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 1204
Re: Increase Maximum Upload Size
« Reply #9 on: May 04, 2019, 04:22:00 pm »

I did not get any failure with a somewhat smaller file named like your problem files. Those are quite large files. Try increasing memory_limit to 384M.
You could also try using GD instead of ImageMagick as the image processor.
Logged

nowordneeded

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 157
Re: Increase Maximum Upload Size
« Reply #10 on: May 04, 2019, 11:14:57 pm »

Where would I increase that? In .htaccess or the php.ini file?
Logged
Sometimes my musings are too confusing for someone not inside my head.

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4660
    • Windsurf.me
Re: Increase Maximum Upload Size
« Reply #11 on: May 05, 2019, 01:14:57 am »

That depends on your servers setup. There is also a problem with some hosts in that although you appear to have increased the memory limit, behind the scenes the host limits it elsewhere. Might be worth having a chat with them.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

nowordneeded

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 157
Re: Increase Maximum Upload Size
« Reply #12 on: May 05, 2019, 02:05:47 am »

Phill:

I will do that. As for the issue, I think Ron's solution to change from Imagemagick to GD worked. I'm able to upload all the images I had wanted to. So for now things appear to be working as it should. Thank you again for all your help.

Marked as solved.
Logged
Sometimes my musings are too confusing for someone not inside my head.
Pages: [1]   Go Up
 

Page created in 0.019 seconds with 22 queries.