Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: How to know what themes work in 1.6x ?  (Read 2819 times)

0 Members and 1 Guest are viewing this topic.

rat_tracks

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
How to know what themes work in 1.6x ?
« on: March 24, 2019, 08:09:46 am »

What themes will currently work with cpg 1.6x ?  I have looked for this information but, can not find it. Currently I am working with 'chaotic soul' theme as it matches my website and I am about to upgrade it from 1.4 to 1.5 and ultimately to 1.6, but, would be nice to  know if this theme will work or can be made to work easily ? A list of themes that will work with 1.6 would be nice !! 

Also, when upgrading an existing gallery that uses a theme that is known to not work in a higher version, should I change the theme to one that will work in the new version BEFORE upgrading ? Or AFTER ??    (The reason I ask this is because I recently upgraded one of my galleries from 1.4 to 1.5 and its theme (Winter Blue) would not work even after following the theme edit guide for that upgrade etc, and it caused a login issue so changing themes was very difficult !!! I finally got it changed to curve so it works now at 1.5x, but will this work in 1.6 ? )

Many thanks  for your help with this as I have a few galleries to get upgraded to 1.6 before my web host cuts off Php 5.6 (end of this month !!! )

Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15759
Re: How to know what themes work in 1.6x ?
« Reply #1 on: April 09, 2019, 01:44:21 pm »

Basically all cpg1.5.x themes should work with cpg1.6.x. But this doesn't mean it will also work with PHP7. It will stop to work with PHP7 if it uses mysql_* functions. So just have a look at theme.php (and any other .php files that may be included in the theme), search for
Code: [Select]
mysql_and replace it with
Code: [Select]
cpg_db_
This makes a theme cpg1.6.x PHP7 compatible in most cases (just "most cases", as there may be some rarely used cases that can't be replaced that way, but need to have a closer look).
Logged
Pages: [1]   Go Up
 

Page created in 0.023 seconds with 20 queries.