Advanced search  


cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.

Pages: [1]   Go Down

Author Topic: Issues with upgrade from 1.4.22 to 1.5.48  (Read 3734 times)

0 Members and 1 Guest are viewing this topic.


  • Coppermine newbie
  • Offline Offline
  • Posts: 1
Issues with upgrade from 1.4.22 to 1.5.48
« on: February 09, 2020, 07:10:51 pm »

Hello all! I have used the Coppermine gallery version 1.4.22 for a long time, pretty much since it was available on my hosting account. It's been a few years since I have uploaded any pictures to it, so I haven't accessed it at all. A few a months ago, I tried accessing and all I got was a blank page. No error messages whatsoever. I contacted chat support of my hosting account provider and I was told that there is no issues on the server and that I should update to the newest version of the Coppermine gallery.

Last night I uploaded all the files from the 1.5.48 package to my gallery folder, except for anycontent.php and albums folder, as it is indicated on the upgrade instructions. I ran the update.php and I see this message come up...

Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /home1/firmaone/public_html/galerija/include/ Stack trace: #0 /home1/firmaone/public_html/galerija/include/ cpg_db_connect() #1 /home1/firmaone/public_html/galerija/update.php(27): include_once('/home1/firmaone...') #2 {main} thrown in /home1/firmaone/public_html/galerija/include/ on line 183

The link to my gallery is

Can someone help and explain how to fix this? Thanks in advance.
Pages: [1]   Go Up

Page created in 0.018 seconds with 20 queries.