Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Public Album - Those who upload get huge error  (Read 4466 times)

0 Members and 1 Guest are viewing this topic.

Chuckster

  • Coppermine newbie
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 16
    • Mopars Unlimited of Tacoma
Public Album - Those who upload get huge error
« on: October 25, 2018, 05:19:26 am »

Good evening, everyone!

So, I have my board all set up and migrated to PHP v7 and CG v1.6.04. However, the public album I have set up for folks to upload stuff to, they get the following error:

Fatal error: Uncaught Error: Cannot use assign-op operators with string offsets in /home/cwaters/public_html/gallery/include/makers/canon.php:241 Stack trace: #0 /home/cwaters/public_html/gallery/include/makers/canon.php(423): formatCanonData('USHORT', '0001', 1, 96, Array, '0') #1 /home/cwaters/public_html/gallery/include/exif.php(755): parseCanon('\x1A\x00\x01\x00\x03\x000\x00\x00\x00(\x04\x00\x00\x02...', Array, Resource id #34, 12) #2 /home/cwaters/public_html/gallery/include/exif.php(1015): read_entry(Array, Resource id #33, Resource id #34, 1, 'SubIFD', 12) #3 /home/cwaters/public_html/gallery/include/exif_php.inc.php(51): read_exif_data_raw('albums/userpics...', 0) #4 /home/cwaters/public_html/gallery/displayimage.php(212): exif_parse_file('albums/userpics...', '2471') #5 /home/cwaters/public_html/gallery/displayimage.php(462): html_picinfo() #6 {main} thrown in /home/cwaters/public_html/gallery/include/makers/canon.php on line 241


Hoping someone can help me out?

URL: http://www.moparsunlimited.org/gallery/index.php

I currently have it offline to the rest of my group (via redirects on the homepage header) until I can get all errors figured out. This seems to be the last one!
Logged

Chuckster

  • Coppermine newbie
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 16
    • Mopars Unlimited of Tacoma
Re: Public Album - Those who upload get huge error
« Reply #1 on: October 25, 2018, 05:21:28 am »

Nevermind. PLease delete this post Moderators.

I turned EXIF and ITPC export data off, and it works fine. I'm sorry. I Should have read the error better.
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 2026
Re: Public Album - Those who upload get huge error
« Reply #2 on: October 25, 2018, 02:06:27 pm »

That error condition has been reported and a fix has been applied to the very latest. Only happens with PHP 7.2+ and Canon images.
http://forum.coppermine-gallery.net/index.php/topic,79492.msg385365.html#msg385365

If you want to apply those latest changes, you can use the installer_stub and select the red-highlighted install at the bottom of the list. Then you can turn EXIF/ITPC back on.
Logged

Chuckster

  • Coppermine newbie
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 16
    • Mopars Unlimited of Tacoma
Re: Re: Public Album - Those who upload get huge error
« Reply #3 on: November 02, 2018, 12:03:36 am »

That error condition has been reported and a fix has been applied to the very latest. Only happens with PHP 7.2+ and Canon images.
http://forum.coppermine-gallery.net/index.php/topic,79492.msg385365.html#msg385365

If you want to apply those latest changes, you can use the installer_stub and select the red-highlighted install at the bottom of the list. Then you can turn EXIF/ITPC back on.

Worked like a champ.
Logged
Pages: [1]   Go Up
 

Page created in 0.033 seconds with 20 queries.