Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Not Getting Upload Approval Notifications  (Read 16489 times)

0 Members and 1 Guest are viewing this topic.

Michael Martin

  • Contributor
  • Coppermine newbie
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 6
  • Hi :)
    • Pro Blog Design
Not Getting Upload Approval Notifications
« on: March 24, 2018, 09:47:13 pm »

I'm running the latest code from the 1.6x Github repo. I've configured the email settings and I do get registration/forgot-password etc emails, and when a user uploads a file, it goes into the approval queue before appearing on the site.

The part I can't seem to get working is the notification email to let me know a new file is waiting.

"Notify admin of user upload awaiting approval" is ticked, and I've set the "Gallery administrator email" under Email Settings. It's different to the domain I'm on, but works fine in terms of getting password reset emails etc to it (I've double-checked the spam folder too incase)

I've turned on logging, but not seeing anything there.

Not sure what else I can try?
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 2026
Re: Not Getting Upload Approval Notifications
« Reply #1 on: March 24, 2018, 11:07:15 pm »

Took a quick look and yes there may be an issue with that. I'll try to get it resolved within a few days. Sorry for the trouble.
Logged

Michael Martin

  • Contributor
  • Coppermine newbie
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 6
  • Hi :)
    • Pro Blog Design
Re: Not Getting Upload Approval Notifications
« Reply #2 on: March 24, 2018, 11:20:25 pm »

Thanks for the quick reply. That sounds great, really appreciate you taking a look at it  :D
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 2026
Re: Not Getting Upload Approval Notifications
« Reply #3 on: March 25, 2018, 04:07:37 pm »

I've made coding changes to correct the missing admin email situation.

Best way for you to get the changes is to use the installer stub:
http://forum.coppermine-gallery.net/index.php/topic,79013.msg383037.html#msg383037

Choose the bottom install option (highlighted in red) to get all the most recent changes.

Caches may have to be cleared before it will work correctly.
Logged

Michael Martin

  • Contributor
  • Coppermine newbie
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 6
  • Hi :)
    • Pro Blog Design
Re: Not Getting Upload Approval Notifications
« Reply #4 on: March 26, 2018, 10:33:34 pm »

Awesome, I've upgraded now and it's all working great. Thanks for sorting it, and especially for doing it so quickly!  :D
Logged

AndreyP

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: Not Getting Upload Approval Notifications
« Reply #5 on: April 13, 2023, 09:02:37 pm »

I've made coding changes to correct the missing admin email situation.

Best way for you to get the changes is to use the installer stub:
http://forum.coppermine-gallery.net/index.php/topic,79013.msg383037.html#msg383037

Choose the bottom install option (highlighted in red) to get all the most recent changes.

Caches may have to be cleared before it will work correctly.

I have the same problem. A notification message about uploading new images is not sent.  With registration, emails are sent. I put it directly from the archive 1.6.24 and with the help of the latest plug version 3.5 (I selected the red item at the bottom).
PHP 8.1
What to do?
Logged

AndreyP

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: Not Getting Upload Approval Notifications
« Reply #6 on: April 13, 2023, 09:12:47 pm »

And where in the gallery to clean the cache?
Logged

AndreyP

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: Not Getting Upload Approval Notifications
« Reply #7 on: April 13, 2023, 09:29:50 pm »

I have so far realized that in the multi-file upload mode (HTML5), the email is not sent and there is no notification from above. And when you use the download in single file mode, an email is sent to the administrator, and the user sees a notification "Your file has been successfully added. It will become available after confirmation by the administration."
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 2026
Re: Not Getting Upload Approval Notifications
« Reply #8 on: April 13, 2023, 11:59:57 pm »

I have so far realized that in the multi-file upload mode (HTML5), the email is not sent and there is no notification from above. And when you use the download in single file mode, an email is sent to the administrator, and the user sees a notification "Your file has been successfully added. It will become available after confirmation by the administration."

An update has been made to correct the failure to email admins when approval is needed. You can use that same method (red highlighted update) to update your installation.
There will not be a message that users see in the multi-file upload situation. They will see, when editing their file uploads, that they are pending approval.

Thank you for your feedback.
Logged

AndreyP

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: Not Getting Upload Approval Notifications
« Reply #9 on: April 17, 2023, 04:40:56 pm »

An update has been made to correct the failure to email admins when approval is needed. You can use that same method (red highlighted update) to update your installation.
There will not be a message that users see in the multi-file upload situation. They will see, when editing their file uploads, that they are pending approval.

Thank you for your feedback.
Many thanks to ron4mac  ;), for such a quick solution to the problem. Updated (red line in the stub) and now notifications to the administrator always come when downloading a multi-file upload.
Logged

AndreyP

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: Not Getting Upload Approval Notifications
« Reply #10 on: April 17, 2023, 04:43:34 pm »

Can you tell me how to disable "This is a multi-part message in MIME format." in emails sent to the administrator? And then the letters look somehow not nice (the text of the message with some encoding is duplicated).

In future updates, you can make sure that not only the main administrator, but also moderators from the Moderator Group receive an email notification about new uploaded files?
Logged

AndreyP

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: Not Getting Upload Approval Notifications
« Reply #11 on: April 17, 2023, 05:09:30 pm »

I have email notifications coming for some reason "From: site,login = name on the webhosting". How should I write my sender's name or that it should be on behalf of the gallery?
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 2026
Re: Not Getting Upload Approval Notifications
« Reply #12 on: April 17, 2023, 06:52:20 pm »

Can you tell me how to disable "This is a multi-part message in MIME format." in emails sent to the administrator? And then the letters look somehow not nice (the text of the message with some encoding is duplicated).
If you are seeing those kind of things in the email, it may be that either your server is not configured correctly with regard to sending email or your email client is showing you the raw email instead of interpreting its content.
Logged
Pages: [1]   Go Up
 

Page created in 0.027 seconds with 20 queries.