Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Wrong Encoding  (Read 4823 times)

0 Members and 1 Guest are viewing this topic.

Mike2421

  • Coppermine newbie
  • Offline Offline
  • Posts: 1
Wrong Encoding
« on: March 18, 2019, 08:20:20 pm »

Hi,

I have Coppermine version 1.5.42.

The database, table and fields are set to utf8_general_ci.

I am using Greek language for Categories and Album titles.

However the data in the fields where store in strange characters (i am attaching a screenshot of the db). An example is the below:

ΦΩΤΟΓΡΑΦΙΕΣ ΡΙ

Any idea why's that? Also is there any way or mysql query to fix those bad characters as they are stored in the db now?

Thank you so much in advance!
Logged

Αndr

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: Wrong Encoding
« Reply #1 on: April 09, 2019, 12:46:27 pm »

As a test, please try to add
Code: [Select]
$CONFIG['dbcharset'] = 'utf8'to include/config.inc.php. This will break your current category and album titles, comments or any other meta data which is stored in the database.

Now, try to add a new album / category or comment with greek characters and check if they are stored correctly in the database. If so, we can check how to fix the existing data.
Logged
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 20 queries.