Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: 1 [2]   Go Down

Author Topic: Logins fail after updating to 1.6.03  (Read 20652 times)

0 Members and 1 Guest are viewing this topic.

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1839
Re: Logins fail after updating to 1.6.03
« Reply #20 on: October 20, 2017, 10:44:33 pm »

I see that you tried the installer stub and the problem persists.

I'm really sorry ... I've never seen a failure like this.

I've even tried to simulate your situation. I set up Ubuntu 16.04, installed CPG 1.5.32, used the stub to upgrade it and all works as expected.
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4850
    • Windsurf.me
Re: Logins fail after updating to 1.6.03
« Reply #21 on: October 20, 2017, 10:59:58 pm »

would I be possible for you to PM me with a link to somewhere I can download a backup of your site and database? I will try and replicate your issue on a local setup.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1839
Re: Logins fail after updating to 1.6.03
« Reply #22 on: October 21, 2017, 02:19:33 pm »

I've been able to determine that there is a problem with your database. Is there a way you can send me a dump of your _user table?
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1839
Re: Logins fail after updating to 1.6.03
« Reply #23 on: October 21, 2017, 05:59:36 pm »

This problem has been resolved to an issue with database user permissions. The update could not fully complete because the database user was not allowed to ALTER tables.
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4850
    • Windsurf.me
Re: Logins fail after updating to 1.6.03
« Reply #24 on: October 21, 2017, 08:20:28 pm »

Excellent news. It is never easy with self hosted solutions
Logged
It is a mistake to think you can solve any major problems just with potatoes.

gmc

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 785
    • GMC Design Photo Gallery
Re: Logins fail after updating to 1.6.03
« Reply #25 on: October 22, 2017, 01:55:09 am »

I ran into that issue some time ago with one of my installations... Wasn't obvious at all.
Would be nice if the update script had some awareness of errors - and could flag something like a security error rather than report 'already done'...
Not sure if that is the only error to capture - but it is a challenging issue to find.

Nice work chasing it down.
Logged
Thanks!
Greg
My Coppermine Gallery
Need a web hosting account? See my gallery for an offer for CPG Forum users.
Send me money
Pages: 1 [2]   Go Up
 

Page created in 0.017 seconds with 19 queries.