Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Gallery doesn't work on mobile devices any more  (Read 4098 times)

0 Members and 1 Guest are viewing this topic.

Russ_

  • Coppermine regular visitor
  • **
  • Country: nz
  • Offline Offline
  • Posts: 57
Gallery doesn't work on mobile devices any more
« on: September 20, 2015, 11:27:20 am »

Basically that's it. I'm getting people telling me they can't get to my photos. It works on my desktop PC.

I've since then updated from 1.5.36 to 1.5.38, but that didn't help. Tried changing theme, that didn't work.

I enabled debug mode, got this:

/plugins/theme_switch/codebase.php
  • Warning line 53: Wrong parameter count for strtolower()
  • Warning line 53: Wrong parameter count for strpos()
Sorry i'm not very techie.

Gallery home page: http://www.chainsawphotos.co.nz/gallery/index.php

Any ideas?

Russ_

  • Coppermine regular visitor
  • **
  • Country: nz
  • Offline Offline
  • Posts: 57
Re: Gallery doesn't work on mobile devices any more
« Reply #1 on: September 20, 2015, 11:33:29 am »

May have fixed it - I removed a plug-in:

Theme switch (theme_switch): v1.0
Author:eenemeenemuu
Description:Switches the theme for mobile devices (e.g. smartphones)
and I think the gallery is going again.  :)

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: Gallery doesn't work on mobile devices any more
« Reply #2 on: September 22, 2015, 11:18:00 am »

Have you configured the theme switch plugin after installation?
Logged

Russ_

  • Coppermine regular visitor
  • **
  • Country: nz
  • Offline Offline
  • Posts: 57
Re: Gallery doesn't work on mobile devices any more
« Reply #3 on: September 24, 2015, 01:23:50 pm »

Yes I had.
I already had this installed for a few months, then just had a few people let me know they couldn't get onto the site recently. After I uninstalled it all was good again.
I will try installing it again later in my not-so-busy time and see how we go.

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: Gallery doesn't work on mobile devices any more
« Reply #4 on: September 24, 2015, 01:26:40 pm »

If it again fails, please report which theme you set as mobile theme and please try to provide some information from your users, like operating system (Android / iOS / Windows Phone) and the browser they used.
Logged

PortsmouthKate

  • Coppermine newbie
  • Country: 00
  • Offline Offline
  • Posts: 1
    • Removals Kilburn
Re: Gallery doesn't work on mobile devices any more
« Reply #5 on: September 24, 2015, 03:29:25 pm »

A client of mine told me that he noticed the same problem on his website. I checked for the plugin that Russ said was causing his problem, but there's no such plugin on the website. Could it be some other plugin causing the gallery problem (there are a lot of plugins installed) or do you think it's the theme or something else?
 :-\
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: Gallery doesn't work on mobile devices any more
« Reply #6 on: September 24, 2015, 03:30:56 pm »

A link to the affected gallery might help.
Logged

Russ_

  • Coppermine regular visitor
  • **
  • Country: nz
  • Offline Offline
  • Posts: 57
Re: Gallery doesn't work on mobile devices any more
« Reply #7 on: September 25, 2015, 11:58:28 am »

If it again fails, please report which theme you set as mobile theme and please try to provide some information from your users, like operating system (Android / iOS / Windows Phone) and the browser they used.
Yep - I know it was an Apple phone and an Android one that both failed, but what exact OS's I've no idea.
Pages: [1]   Go Up
 

Page created in 0.027 seconds with 20 queries.