Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: After Upload/Random Thumbnails Broken  (Read 6400 times)

0 Members and 1 Guest are viewing this topic.

fivecolours

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 44
After Upload/Random Thumbnails Broken
« on: June 27, 2015, 05:28:13 pm »

Today while trying to add a new album, I kept getting the spinning wheel. I was trying to add "Name - Temecula, CA - 04/13/15" to no avail. "Name" worked just fine though. I kept it titled "Name" and uploaded the files via fpt > batch upload and they uploaded fine with the green check mark.

When editing the album name to what I wanted, and then viewing thumbnail view, all the thumbnails, and images, in that album were broken links. I then went back to my index page and random thumbnails were broken, as well, not just the new ones I added, but not all.

I might add, I uploaded images BEFORE this broken batch and they were fine. It seems this new batch messed with something...not sure how.

I just upgraded to the latest version of Coppermine thinking it would help, but alas, it did not.

My gallery: http://glorianafans.com/gallery/index.php

Thoughts?
Logged

gmc

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 785
    • GMC Design Photo Gallery
Re: After Upload/Random Thumbnails Broken
« Reply #1 on: June 28, 2015, 06:06:29 am »

I've had limited access tonight, but a quick look it seems the files are missing... Coppermine knows about them, but trying to access a file directly gives 'not found' error.

Did you do any renames of folders/files outside of Coppermine?
Are you near or at your ISP's space or file count limit? (Some not so nice hosts start deleting files...)
Logged
Thanks!
Greg
My Coppermine Gallery
Need a web hosting account? See my gallery for an offer for CPG Forum users.
Send me money

fivecolours

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 44
Re: After Upload/Random Thumbnails Broken
« Reply #2 on: June 28, 2015, 03:31:45 pm »

This all changed when I uploaded new images. I have since deleted that album, folder and files within it.

For all the other broken images... I just checked and the files are all still in their respective folders. I made no changes and I am nowhere near my limit for space/bandwidth/etc for my hosting.
Logged

gmc

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 785
    • GMC Design Photo Gallery
Re: After Upload/Random Thumbnails Broken
« Reply #3 on: June 29, 2015, 01:56:18 am »

For all the other broken images... I just checked and the files are all still in their respective folders. I made no changes and I am nowhere near my limit for space/bandwidth/etc for my hosting.
On your home page (link below) - on any broken image, I right click and select 'View Image' - and I get a 404 not found...
Thumbnail Examples:
14.jpg: http://www.glorianafans.com/gallery/albums/Performances/2015/BakersfieldMusicandArtFestivalBakersfieldCA052315/thumb_14.jpg
Gloriana-31.jpg: http://www.glorianafans.com/gallery/albums/Performances/2015/WorldstoughestRodeoStPaulMN01312015/thumb_Gloriana-31.jpg
Intermediate Images:
14.jpg: http://www.glorianafans.com/gallery/albums/Performances/2015/BakersfieldMusicandArtFestivalBakersfieldCA052315/normal_14.jpg
Gloriana-31.jpg: http://www.glorianafans.com/gallery/albums/Performances/2015/WorldstoughestRodeoStPaulMN01312015/normal_Gloriana-31.jpg
Fullsize:
14.jpg: http://www.glorianafans.com/gallery/albums/Performances/2015/BakersfieldMusicandArtFestivalBakersfieldCA052315/14.jpg
Gloriana-31.jpg: http://www.glorianafans.com/gallery/albums/Performances/2015/WorldstoughestRodeoStPaulMN01312015/Gloriana-31.jpg

These files do not appear to exist in your filesystem... I'm not trying to view them through Coppermine - but directly from your file system...
If they are still there - please attach a screen print from you control panels File Manager or FTP client showing the files and path.

This should only occur if files (or folders) were manually deleted or renamed after being added to Coppermine.
In the cases above - it appears the folders are gone.
Logged
Thanks!
Greg
My Coppermine Gallery
Need a web hosting account? See my gallery for an offer for CPG Forum users.
Send me money

fivecolours

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 44
Re: After Upload/Random Thumbnails Broken
« Reply #4 on: June 30, 2015, 02:43:27 am »

All files are still there, in their respective folders. I only added files the other day, did not delete any. Maybe my host can revert me back to another day, but I would still like to know what on earth happened.
.
Logged

allvip

  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Posts: 1362
Re: After Upload/Random Thumbnails Broken
« Reply #5 on: June 30, 2015, 04:48:20 pm »

Are you using CloudFlare or something like that?
Logged

fivecolours

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 44
Re: After Upload/Random Thumbnails Broken
« Reply #6 on: July 04, 2015, 02:09:34 pm »

I am not using CloudFare, no. All plugins are turned off, too.
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4826
    • Windsurf.me
Re: After Upload/Random Thumbnails Broken
« Reply #7 on: July 04, 2015, 04:58:49 pm »

I assume it is now working as the files above listed by GMC are now appearing but when I checked a couple of days ago they were not.

If that is the case all is good. Trying to find out why they vanished is going to be all but impossible especially without full server logs and even then it could be like looking for a needle in  haystack.

If thumbs go missing in future you can use the admin tools to re-generate them as long as the full size image is still available so it is often not required to ask your host to do a restore.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

fivecolours

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 44
Re: After Upload/Random Thumbnails Broken
« Reply #8 on: July 04, 2015, 05:18:36 pm »

Since I couldn't figure out the issue, I contacted my host who supplied this reason (and fixed it for me):

"It looks like the permissions on your /home/glorscom/public_html/gallery/albums/Performances folder, as well as some of the thumbnail images contained within that folder, were set incorrectly.  The Performances folder was set to not be executable by the web server process, meaning that the web server couldn't open that folder, and the files were writeable by the web server"


Thought I would include this if anyone else has this issue in the future.
Logged

gmc

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 785
    • GMC Design Photo Gallery
Re: After Upload/Random Thumbnails Broken
« Reply #9 on: July 05, 2015, 04:10:36 pm »

Glad you found the issue...
Something you may want to check:
I would have expected a 403 (forbidden) error rather than a 404 (not found) in that case - and would have simplified finding the problem as a permissions issue.
It appears you have a custom error page - it may be 'masking' the true error rather than passing it through.
404 (not found) is the most common error - but others should show as well.

Logged
Thanks!
Greg
My Coppermine Gallery
Need a web hosting account? See my gallery for an offer for CPG Forum users.
Send me money
Pages: [1]   Go Up
 

Page created in 0.026 seconds with 19 queries.