Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Forum Plugin 404 error  (Read 4317 times)

0 Members and 1 Guest are viewing this topic.

Owen34

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Forum Plugin 404 error
« on: March 24, 2015, 07:14:32 pm »

Hello,
I installed the forum plugin, all queries ran, it seemed to fully install.

The link in header goes to /forum.php but this file doesn't exist & I don't see it in the package to copy over? Is some of the files missing or am I missing something.

Thanks
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: Forum Plugin 404 error
« Reply #1 on: March 30, 2015, 10:07:04 am »

That file usually will be created on plugin install. Obviously it hasn't, probably because of permission issues. However, you can manually create that file in the gallery root with the following content:
Code: [Select]
<?php
// define some basic element
define('NBSP''&nbsp;'); // mass use
define('BR''<br />'); // mass use
define('DS'DIRECTORY_SEPARATOR);
define('BASE_DIR'str_replace('\\'DSdirname(__FILE__)).DS);
// load coppermine
define('IN_COPPERMINE'true);
include(
BASE_DIR.'include'.DS.'init.inc.php');
//$fr_time_start = cpgGetMicroTime();
// load class and file
include(BASE_DIR.'plugins'.DS.'forum'.DS.'forum'.DS.'import.php');
// init the forum
include(BASE_DIR.'plugins'.DS.'forum'.DS.'forum'.DS.'initialize.php');
//$fr_time_end = cpgGetMicroTime();
//echo round($fr_time_end - $fr_time_start, 3);
if (!USER_ID && ($CONFIG['fr_guest_browse'] == 0)) {
    
header("Location: login.php?force_login=1&referer=forum.php");
    exit();
}
Logged

Owen34

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Re: Forum Plugin 404 error
« Reply #2 on: April 01, 2015, 08:55:41 pm »

Thanks  ;D
Logged
Pages: [1]   Go Up
 

Page created in 0.024 seconds with 20 queries.