Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Version 1.5.8 - not accepting unicode characters in form submission  (Read 2237 times)

0 Members and 1 Guest are viewing this topic.

dudah84

  • Coppermine newbie
  • Offline Offline
  • Posts: 11

This has been working for years for me, but yesterday I had to upgrade my server, and with it, MAMP and everything that came with it (PHP - MySQL) Current PHP version is
After the upgrade, it seems no form is accepting unicode characters (for icelandic that's characters like ).
For example, if I edit an album and change its name to something WITHOUT unicode characters, like "i am here", everything works. but if it includes the special chars, it'll throw an error that i must provide a title for the album (coppermine is not registering the field at all)
Same goes for editing file info, except it won't throw an error, just replace the previous data with a empty value.
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4843
    • Windsurf.me
Re: Version 1.5.8 - not accepting unicode characters in form submission
« Reply #1 on: February 09, 2015, 12:10:03 pm »

Please upgrade to version 1.5.34 and then provide a link to your gallery.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

dudah84

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Version 1.5.8 - not accepting unicode characters in form submission
« Reply #2 on: February 11, 2015, 07:31:23 pm »

Sorry, I was running 1.5.12

I've now upgraded to 1.5.34 and the problem persists.

In search, it seems to accept the icelandic characters, but not find any results with them - even though there are plenty.
when I try to edit album or file info, the field is interpreted as empty

link is pressphotos.biz
Logged

Αndr

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: Version 1.5.8 - not accepting unicode characters in form submission
« Reply #3 on: February 13, 2015, 08:26:23 pm »

Have you already tested with an unmodified theme like curve or water_drop? Have you installed any plugins or applied any mods? There seems to be some issues with Inspekt, which haven't reported before.

Current PHP version is
Please post your PHP version.
Logged
Pages: [1]   Go Up
 

Page created in 0.022 seconds with 21 queries.