Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Theme incomplete but no errors showing  (Read 2960 times)

0 Members and 1 Guest are viewing this topic.

adnet

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Theme incomplete but no errors showing
« on: January 29, 2015, 02:34:10 am »

Hello,

I recently purchased a semi-customized coppermine template originally based on the waterdrop theme. I have the same theme customized for my wordpress site which works perfectly. After uploading my new coppermine theme it appears that there is either a fault in the template or the theme file (I think maybe theme?!) because my page is incomplete. There are no images, borders, colours etc. I have checked and I believe the theme was designed for coppermine 1.5 and I am upto-date with installs. I have checked that the style.css are all linked correctly and I cannot see where my error is because there actually aren't any visible. I just know that it looks like there is no theme installed.

My website is: http://www.galleries.aleshadixon.net/

What files or code can I share that will allow people to help me fix this problem?

Thanks in advance for the help.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15759
Re: Theme incomplete but no errors showing
« Reply #1 on: January 29, 2015, 07:23:35 pm »

I suggest to update those absolute paths:
Code: [Select]
<link rel="stylesheet" href="http://www.aleshadixon.net/clickandbuilds/Coppermine/MyGalleries/themes/OMM19CPG/style.css" type="text/css" />
<link rel="stylesheet" href="http://www.aleshadixon.net/clickandbuilds/AleshaDixonNet/wp-content/themes/OMM19/style.css" type="text/css" />
to valid (relative) paths. Both links return an error page.
Logged

adnet

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Theme incomplete but no errors showing
« Reply #2 on: January 30, 2015, 01:35:35 am »

Thankyou for your help.

Initially, I did have the relative path and it didn't work so I copied the URL direct from the FTP folder so the files are certainly stored in the place I have linked to. I have no idea why this is happening. Could it be a chmod problem? I'm clutching at straws.

I have changed back to a relative path I believe, with the same result. The page looks unchanged.

Code: [Select]
<link rel="stylesheet" href="/style.css" type="text/css" />
<link rel="stylesheet" ref="/AleshaDixonNet/wp-content/themes/OMM19/style.css" type="text/css" />



Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 1272
Re: Theme incomplete but no errors showing
« Reply #3 on: January 30, 2015, 03:28:49 am »

If you try opening this in a web browser, it says that their site is down for maintenance.

http://www.aleshadixon.net/clickandbuilds/AleshaDixonNet/wp-content/themes/OMM19/style.css

You're getting no CSS from them.
Logged

allvip

  • Global Moderator
  • Coppermine addict
  • *****
  • Country: 00
  • Offline Offline
  • Posts: 1291
Re: Theme incomplete but no errors showing
« Reply #4 on: January 30, 2015, 11:41:45 am »

You have your wordpress website under maintenance http://www.aleshadixon.net/.
Maybe that restricts access to your style.css. Try to put your site on line and the see what happends.

Also I notice that template.html from your coppermine theme loads style.css:

Code: [Select]
<link rel="stylesheet" href="/style.css" type="text/css" />
It was included in the theme?

Because your site in under maintenance http://www.aleshadixon.net/clickandbuilds/AleshaDixonNet/wp-content/themes/OMM19/style.css contains this code:

Code: [Select]
<!DOCTYPE html>

<html>

    <head>

        <title>Maintenance mode</title>

        <meta name="author" content="Designmodo" />

        <meta name="description" content="Alesha Dixon Net - Your Official Alesha Fan Source" />

        <meta name="keywords" content="Maintenance Mode" />

        <meta name="robots" content="index, follow" />

                        <link rel="stylesheet" href="http://www.aleshadixon.net/wp-content/plugins/wp-maintenance-mode/assets/css/style.css">

                    </head>

    <body class="">

        <div class="wrap">

            <h1>Maintenance mode</h1>            <h2><p>Sorry for the inconvenience.<br />Our website is currently undergoing scheduled maintenance.<br />Thank you for your understanding.</p></h2>

           

           

                       

               

        </div>



        <script type='text/javascript'>

            var wpmm_vars = {"ajax_url": "http://www.aleshadixon.net/wp-admin/admin-ajax.php"};

        </script>

                        <script src="http://www.aleshadixon.net/wp-includes/js/jquery/jquery.js"></script>

                                <script src="http://www.aleshadixon.net/wp-content/plugins/wp-maintenance-mode/assets/js/scripts.js"></script>

                    </body>

</html>
Logged

allvip

  • Global Moderator
  • Coppermine addict
  • *****
  • Country: 00
  • Offline Offline
  • Posts: 1291
Re: Theme incomplete but no errors showing
« Reply #5 on: January 30, 2015, 11:52:44 am »

Attachment with the CSS files that load on your gallery page.
Logged
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 21 queries.