Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Installer Doesn't See Database?  (Read 4316 times)

0 Members and 1 Guest are viewing this topic.

pushback

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Installer Doesn't See Database?
« on: October 12, 2014, 01:14:57 am »

Hello,  I'm part-way through an install of 1.5.32 and the installer does not see the database on localhost.  I have tried via the wizard and via the regular installer.  The error message is "MySQL could not locate a database called 'cpgff' please check the value entered for this."  I have already crated the database manually on the server:

[root@flash etc]# mysql

Welcome to the MariaDB monitor.  Commands end with ; or \g.
Your MariaDB connection id is 67
Server version: 5.5.37-MariaDB MariaDB Server

Copyright (c) 2000, 2014, Oracle, Monty Program Ab and others.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

MariaDB [(none)]> show databases;
+--------------------+
| Database           |
+--------------------+
| information_schema |
| cpgff              |
| mysql              |
| performance_schema |
| test               |
+--------------------+
5 rows in set (0.00 sec)

MariaDB [(none)]>


I'm running on CentOS.

Thanks in advance!

 
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1578
Re: Installer Doesn't See Database?
« Reply #1 on: October 12, 2014, 09:20:13 am »

Did you GRANT PRIVILEGES for the username that you are using? Try connecting manually to the 'cpgff' database as that user. Does that work?
Logged

pushback

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Installer Doesn't See Database?
« Reply #2 on: October 12, 2014, 10:23:03 pm »

Yes, I granted all privileges to that username.  I can't even get it to authenticate at the command line:

[root@flash www]# mysql -u fred -p
Enter password:
ERROR 1045 (28000): Access denied for user 'fred'@'localhost' (using password: YES)

The password is good. I've checked it, reset it, checked it again .... it's good.

When I login with no user I can see all the databases I've created:

[root@flash www]# mysql
Welcome to the MariaDB monitor. Commands end with ; or \g.
Your MariaDB connection id is 193
Server version: 5.5.37-MariaDB-log MariaDB Server

Copyright (c) 2000, 2014, Oracle, Monty Program Ab and others.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

MariaDB [(none)]> show databases;
+--------------------+
| Database |
+--------------------+
| information_schema |
| cpgff |
| galleryff |
| mysql |
| performance_schema |
| test |
+--------------------+
7 rows in set (0.00 sec)

But when I remove the password from my fred user and login as fred I cannot see those databases:

[root@flash www]# mysql -u fred
Welcome to the MariaDB monitor. Commands end with ; or \g.
Your MariaDB connection id is 217
Server version: 5.5.37-MariaDB-log MariaDB Server

Copyright (c) 2000, 2014, Oracle, Monty Program Ab and others.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

MariaDB [(none)]> show databases;
+--------------------+
| Database |
+--------------------+
| information_schema |
| test |
+--------------------+
2 rows in set (0.00 sec)

MariaDB [(none)]>


I'd like to be able to login with the username 'fred' and gain access to those databases. Any help is appreciated!
Logged

pushback

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Installer Doesn't See Database?
« Reply #3 on: October 13, 2014, 12:25:28 am »

Is all good now.  Had to read up on granting privs a bit.  Thanks for sending me down the path.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Installer Doesn't See Database?
« Reply #4 on: October 15, 2014, 08:11:27 pm »

Marking as solved.
Logged
Pages: [1]   Go Up
 

Page created in 0.035 seconds with 20 queries.