Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Error: Failed to find block 'contact'  (Read 4055 times)

0 Members and 1 Guest are viewing this topic.

duckie

  • Coppermine newbie
  • Offline Offline
  • Posts: 1
Error: Failed to find block 'contact'
« on: September 12, 2014, 03:56:46 pm »

Hello,

I will change from the standard theme to "ocadia v1.01".
When I do that, I get the next error: Template error, Failed to find block 'contact'.
(See picture)
Also when i'm switching to a "orginal" theme from coppermine self, I get this error also.
(i'm using: Ubuntu14.04 - Coppermine (run-file.))

What is wrong, I want to change from theme before I import pictures, and make any changes on the system.

Thanks...

 
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15757
Re: Error: Failed to find block 'contact'
« Reply #1 on: September 12, 2014, 10:15:05 pm »

I assume the theme isn't compatible with cpg1.5.x. You can reset the theme to the standard "curve" theme by visiting
Code: [Select]
index.php?theme=curvewith your browser.
Logged

brenakie

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 31
Re: Error: Failed to find block 'contact'
« Reply #2 on: January 26, 2015, 09:28:14 pm »

I'm having the same error after upgrading to 1.5.34 I can get to the page via index.php?theme=curve

I'm wondering where can I fix this reference in the code on the .php pages(s)?  I'm not seeing any option in my Admin Panel "options", seems like something is missing....

Any help is greatly appreciated.

Thanks in advance
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15757
Re: Error: Failed to find block 'contact'
« Reply #3 on: January 26, 2015, 09:33:03 pm »

If you have the same issue, I assume that your theme is also not compatible with cpg1.5.x. As you haven't posted any details nor a link to your gallery, we can just guess what's wrong.
Logged

brenakie

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 31
Re: Error: Failed to find block 'contact'
« Reply #4 on: January 26, 2015, 09:38:48 pm »

Andre,

Apologies....

Code: [Select]
Template error
Failed to find block 'contact' (#<!-- BEGIN contact -->(.*?)<!-- END contact -->#s) in :
                <span class="topmenu">

<!-- BEGIN my_gallery -->
                        <a href="{MY_GAL_TGT}" title="{MY_GAL_TITLE}">{MY_GAL_LNK}</a><br /><br />
<!-- END my_gallery -->

<!-- BEGIN allow_memberlist -->
                        <a href="{MEMBERLIST_TGT}" title="{MEMBERLIST_TITLE}">{MEMBERLIST_LNK}</a><br /><br />
<!-- END allow_memberlist -->

<!-- BEGIN my_profile -->
                        <a href="{MY_PROF_TGT}">{MY_PROF_LNK}</a><br /><br />
<!-- END my_profile -->

<!-- BEGIN faq -->
                        <a href="{FAQ_TGT}" title="{FAQ_TITLE}">{FAQ_LNK}</a><br /><br />
<!-- END faq -->

<!-- BEGIN enter_admin_mode -->
                        <a href="{ADM_MODE_TGT}" title="{ADM_MODE_TITLE}">{ADM_MODE_LNK}</a><br /><br />
<!-- END enter_admin_mode -->

<!-- BEGIN leave_admin_mode -->
                        <a href="{USR_MODE_TGT}" title="{USR_MODE_TITLE}">{USR_MODE_LNK}</a><br /><br />
<!-- END leave_admin_mode -->

<!-- BEGIN upload_pic -->
                        <a href="{UPL_PIC_TGT}" title="{UPL_PIC_TITLE}">{UPL_PIC_LNK}</a><br /><br />
<!-- END upload_pic -->

<!-- BEGIN register -->
                        <a href="{REGISTER_TGT}" title="{REGISTER_TITLE}">{REGISTER_LNK}</a><br /><br />
<!-- END register -->

<!-- BEGIN login -->
                        <a href="{LOGIN_TGT}" title="">{LOGIN_LNK}</a>
<!-- END login -->

<!-- BEGIN logout -->
                        <a href="{LOGOUT_TGT}" title="">{LOGOUT_LNK}</a><br />
<!-- END logout -->
</span>
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15757
Re: Error: Failed to find block 'contact'
« Reply #5 on: January 26, 2015, 10:16:48 pm »

Thanks, but that doesn't help at all. Please post a link to your gallery and if you're using a custom theme, attach it as zip file to your next reply.
Logged

brenakie

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 31
Re: Error: Failed to find block 'contact'
« Reply #6 on: January 27, 2015, 12:37:52 am »

Again sorry for the lack of info.

Theme, not 100% sure (can't locate it via the admin panel)  It could be kaki or classic, but I want to go with the default CURVE moving forward

http://bluemountainoutfitters.com/gal/?theme=curve

Let me know if you need anything else.

Thanks,

B
Logged

brenakie

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 31
Re: Error: Failed to find block 'contact'
« Reply #7 on: January 27, 2015, 01:39:24 am »

Andre,

It's now working....  :-\

Thanks,

B
Logged
Pages: [1]   Go Up
 

Page created in 0.019 seconds with 21 queries.