Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: 1.5.30 error on installing  (Read 3282 times)

0 Members and 1 Guest are viewing this topic.

heavensportal

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Posts: 240
    • The Fantasy Attic
1.5.30 error on installing
« on: August 25, 2014, 05:01:03 pm »

I just installed this version, fresh no previous one.

I got this error as soon as the agreement page was agreed on.

Code: [Select]
[25-Aug-2014 09:05:04 America/Mexico_City] PHP Strict Standards:  Non-static method Inspekt::getMatched() should not be called statically, assuming $this from incompatible context in /home/server/location/market/showcase/include/inspekt/cage.php on line 253

[25-Aug-2014 09:05:04 America/Mexico_City] PHP Strict Standards:  Non-static method Inspekt::getInt() should not be called statically, assuming $this from incompatible context in /home/server/location/market/showcase/include/inspekt/cage.php on line 188

[25-Aug-2014 09:05:04 America/Mexico_City] PHP Strict Standards:  Non-static method Inspekt::getAlpha() should not be called statically, assuming $this from incompatible context in /home/server/location/market/showcase/include/inspekt/cage.php on line 124


I also noticed that when using the long version vs classic installer:

gd2 is shown in the choice with ImageMagik click ok appears to be fine
in classic -- however -- it tells you that it did not appear that you chose GD2,

Granted I got these when I switched from extended to classic, but then I deleted the config.inc.php file AND the database tables then did the extended installer first and still got the fist set of errors...the rest went fine.

Again with the delete of items to test out the classic installer and got no error messages, was not given the choice for GD2 but the rest of installation went fine.

Running PHP5+

Just curious about the error and if the GD2 option should be in there or did I miss something.

Nothing is installed so I can delte again and reinstall should there be something I indeed did not get uploaded.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: 1.5.30 error on installing
« Reply #1 on: August 25, 2014, 05:36:47 pm »

Just curious about the error
There are already a lot of threads regarding that issue, please search our board for details. While fixing the strict standards warning messages, it seems that I missed some.


if the GD2 option should be in there or did I miss something.
The classic installer doesn't have that option. However, you can always set that later in the config (admin.php).
Logged

heavensportal

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Posts: 240
    • The Fantasy Attic
Re: 1.5.30 error on installing
« Reply #2 on: August 25, 2014, 05:44:12 pm »

OK, sorry but I did search and came up empty---nothing unusual since searches and me don't always see eye to eye.

I will continue with my configuring the admin area of the new gallery, thanks.
Logged
Pages: [1]   Go Up
 

Page created in 0.016 seconds with 19 queries.