Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Batch Add Files not working!  (Read 6286 times)

0 Members and 1 Guest are viewing this topic.

cjobson

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Batch Add Files not working!
« on: August 20, 2014, 10:02:29 pm »

Hello,

I have recently taken over site LilyAllenFans.net. The gallery was working fine up to about 3 days ago. I uploaded new photos to the FTP server (I use FileZilla) and then went onto the site to use the batch add files service to upload the images from the FTP to the website. I chose all the directories and clicked 'Ok' to add the photos and choose an album to add them too. However instead of taking me to this next step it took me back to the beginning of choosing the directories (this process happens over and over again). I have made sure no directories in the FTP have any punctuation marks as this was the reason for it not working on one of my other sites.
Please if you have any information on how to resolve the problem, please let me know!

I am kind of new to all this, so the easier you can make it the better please!

Best Wishes,
Craig :)
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: Batch Add Files not working!
« Reply #1 on: August 21, 2014, 09:29:16 am »

Unfortunately you haven't posted a link to your gallery. However, I assume you're using an outdated version of cpg1.5.x, as this bug has been fixed in cpg1.5.30. Please upgrade to the latest stable release and it should work as expected.
Logged

cjobson

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Batch Add Files not working!
« Reply #2 on: August 21, 2014, 11:15:25 am »

The web address for the gallery is > lilyallenfans.net/gallery
How do I upgrade to the latest release?

Thank you for your help!
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Logged

cjobson

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Batch Add Files not working!
« Reply #4 on: August 21, 2014, 12:28:18 pm »

I have read through that page.

Can you just confirm that I drag all the files from my computer onto the website server (expect the anycontent.php) and then its done?
If I put overwrite the 'albums' directory won't it get rid of all the files that are already in it because the one I am overwriting it with is empty?

Thank You for your help! :)
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: Batch Add Files not working!
« Reply #5 on: August 21, 2014, 12:36:54 pm »

As said in the docs, you also don't upload the albums directory:
Quote
Except for the "albums" directory, upload all of the new files and directories, making sure not to overwrite your anycontent.php file or the albums directory.
In fact, you could upload the albums folder as well - the one that is contained in the package is empty anyway. The recommendation not to upload this folder is only meant as a pre-caution for some users who have "funny" settings for their FTP apps: some exotic FTP applications delete folders existing on the server and then re-create an empty folder on the server-side. This would of course be a disaster for all existing galleries during the upgrade process, as you would lose all your uploaded files in your gallery. However, the number of FTP apps that is set up in that strange way is small and therefore, it won't hurt for most to upload the albums folder as well. If you're not sure, use one of the FTP clients recommended by the devs.
Logged

cjobson

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Batch Add Files not working!
« Reply #6 on: August 21, 2014, 01:36:26 pm »

Ok,
So I just have to overwrite all the files expect albums directory and anycontent.php file.

Sorry, I am just so nervous of loosing all the photos that are on the gallery.
I really appreciate your help! :)
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: Batch Add Files not working!
« Reply #7 on: August 21, 2014, 02:31:41 pm »

I am just so nervous of loosing all the photos that are on the gallery.
That's why you're creating a backup of all important files and your MySQL database in the first steps ;)
Logged

angey

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: Batch Add Files not working!
« Reply #8 on: September 08, 2014, 06:11:45 pm »

I'm having the same problem and I've never upgraded a gallery before (I had someone do it for me last time) so I literally have no idea how to do it. Could anyone help..?  :(
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: Batch Add Files not working!
« Reply #9 on: September 08, 2014, 08:25:50 pm »

I'm having the same problem
No thread-hijacking
If someone has started a thread, describing his/her issues in detail and asking for support, it's not a bright idea to hijack this thread and reply there, asking for support on your issues.


I've never upgraded a gallery before (I had someone do it for me last time) so I literally have no idea how to do it. Could anyone help..?  :(
http://documentation.coppermine-gallery.net/en/upgrading.htm
Logged
Pages: [1]   Go Up
 

Page created in 0.022 seconds with 19 queries.