Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: JW Player and Adobe Flash ver 14  (Read 23609 times)

0 Members and 1 Guest are viewing this topic.

wetteddy

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
JW Player and Adobe Flash ver 14
« on: June 26, 2014, 09:03:11 pm »

I have the JW Player plugin installed on my site (http://forum.coppermine-gallery.net/index.php/topic,62704.0.html) written by eenemeenemuu to play mp4 videos. It works fine in explorer and firefox on desktops that have adobe flash version 13 installed . However if adobe flash version 14 is installed, I get "Error loading media: File could not be played" Has anyone else experience this issue?
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: JW Player and Adobe Flash ver 14
« Reply #1 on: July 01, 2014, 11:47:14 am »

Just tested successfully with Google Chrome on Linux (it's bundled with Flash player 14.0). Please post a link to your gallery so I can test on your gallery. Unfortunately I cannot test with Firefox and Flash 14, as the latest Flash version for Linux is 11.2 (https://www.adobe.com/software/flash/about/).
Logged

wetteddy

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: JW Player and Adobe Flash ver 14
« Reply #2 on: July 02, 2014, 12:11:37 am »

Thanks for the reply. I downloaded Chrome and get the same error. Here is a link to one of the videos
http://bowlerranch.com/family/displayimage.php?album=149&pid=15113#top_display_media
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: JW Player and Adobe Flash ver 14
« Reply #3 on: July 02, 2014, 10:33:22 am »

Please adjust the URL of your Coppermine gallery folder in the config. It's currently set to
Quote
http://bowlerranch.com/pictures/
but needs to be
Quote
http://bowlerranch.com/family/
Logged

wetteddy

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: JW Player and Adobe Flash ver 14
« Reply #4 on: July 02, 2014, 06:31:25 pm »

Just for clarification, yesterday before I posted the link, I changed the default directory from pictures to family. I reason I did this, was to avoid the spam (that I have received past) after posting to an open forum. Now that both directories are "out there", I have changed the main coppermine directory back to pictures. So the link in the config file should be correct and match http://bowlerranch.com/pictures/

http://bowlerranch.com/pictures/
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: JW Player and Adobe Flash ver 14
« Reply #5 on: July 03, 2014, 12:28:42 pm »

Same result for me on your gallery:
tested successfully with Google Chrome on Linux (it's bundled with Flash player 14.0). [..] Unfortunately I cannot test with Firefox and Flash 14, as the latest Flash version for Linux is 11.2 (https://www.adobe.com/software/flash/about/).

Maybe somebody else with Flash 14 can check if it works for him/her in your gallery: http://bowlerranch.com/pictures/displayimage.php?pid=15113
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1740
Re: JW Player and Adobe Flash ver 14
« Reply #6 on: July 03, 2014, 03:17:13 pm »

@wetteddy
I was able to view video at your site on my main platform, Mac OSX, with all the browsers that I use (Safari, Chrome, Firefox). That version of Chrome is bundled with Flash 14, but the JW Player does not use flash to play your videos in that version of Chrome.

So I have a VirtualBox with Windows 7, where I installed Flash 14. And in IE 11, I do see the error when accessing your site video. From the JW Player site, I located other content delivered by JW Player 6.8.x and it plays as expected. Chrome on Windows 7 plays your video okay .. but probably there too it is not using Flash. So I am going to conclude that, since the JW Player in this plugin is version 6.7.x, it may need to be updated to be compatible with Flash 14.

I'm sure someone will work to update the plugin in the near future.
Logged

wetteddy

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: JW Player and Adobe Flash ver 14
« Reply #7 on: July 03, 2014, 04:47:37 pm »

Thanks for all your help guys. i will be watching for an updated plugin.
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1740
Re: JW Player and Adobe Flash ver 14
« Reply #8 on: July 03, 2014, 05:16:38 pm »

@wetteddy
There seems to be a slight inconsistency with the Flash Media Player plugin at your site. The Flash Media Player plugin (v2.1) is packaged with JW Player 6.1.x, but your site seems to be trying to play video with JW Player 6.7.x. Is this the result of some change that you tried to make to the plugin?

--- edit ---
Investigating further ... I installed the stock version (2.1) of Flash Media Player plugin on my CPG site, uploaded one of your videos to it and had no problems viewing it with Windows 7, IE 11 and Flash 14.  Also, your site seems to be invoking the server-based code for JW Player, as well. Is that from some other plugin?

I suggest that you reinstall the stock Flash Media Player plugin v2.1 and see if you still have issues.

« Last Edit: July 03, 2014, 05:43:58 pm by ron4mac »
Logged

wetteddy

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: JW Player and Adobe Flash ver 14
« Reply #9 on: July 08, 2014, 06:11:23 pm »

Just back from vacation.

I have 4 plugin's installed:
Flash Media Player (flash_media_player): v2.1 by eenemeenemuu
Favorite Button (fav_button): v1.2 by eenemeenemuu
Delete Favorites (del_fav): v1.1 ported by eenemeenemuu
Keyboard Navigation (keyboard_navigation): v2.1 eenemeenemuu

I did not make any adjustments to the plugin's. I will try deleting the plugins, download a clean copy and reinstalling them 1 at a time to see results. I'm not convinced that will make a difference as there were no operating changes made to the site in the last year and I noticed the videos quit working after the installation of flash 14 on my laptop. I will report back with my findings.

Logged

wetteddy

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: JW Player and Adobe Flash ver 14
« Reply #10 on: July 09, 2014, 06:44:44 am »

So today, I upgraded CM to 1.5.3, removed all the plugins, d/l the jw flash player from this thread http://forum.coppermine-gallery.net/index.php/topic,62704.0.html. result below:
Internet explorer:
Videos will play, however after the video plays, it can not be replayed without selecting another video first and then going back to the video or refresh the page. Something also to note is the playback is stuttered. It needs to buffer for smooth playback. Maybe it was a provider issue but it has not been an issue in the past.
Chrome:
Videos will play and can be replayed without refreshing the page. Again buffering is an issue. Maybe it was a provider issue but I checked a couple of video sites running HD content and they played fine.
Firefox:
Videos do not play. I get an error of "Error loading media: File could not be played"
Iphone:
Videos will play and can be replayed without refreshing the page but again buffering is an issue even though i was connected via wifi.

Any other thoughts?
Logged

ron4mac

  • Administrator
  • Coppermine addict
  • *****
  • Country: us
  • Offline Offline
  • Posts: 1740
Re: JW Player and Adobe Flash ver 14
« Reply #11 on: July 09, 2014, 04:41:41 pm »

@wetteddy
I played your videos (cowsorting) in MacOS using Safari, Chrome and Firefox. No stuttering. Firefox was the only browser that acted a little strange, playing the video after blanking the window instead of in-place. They played okay (no stuttering) on my iPhone as well. The only place I had stuttering issues was in Windows (IE, Chrome) ... but that was via virtualization and is probably understandable.

I don't doubt that it would be a good idea for the Flash Media Player plugin to have an update done that includes a newer JW Player version that may be better with modern browsers.
Logged

brianwlsn22

  • Coppermine newbie
  • Offline Offline
  • Posts: 1
Re: JW Player and Adobe Flash ver 14
« Reply #12 on: September 24, 2014, 06:36:09 am »

I have the JW Player plugin installed on my site (http://forum.coppermine-gallery.net/index.php/topic,62704.0.html) written by eenemeenemuu to play mp4 videos. It works fine in explorer and firefox on desktops that have adobe flash version 13 installed . However if adobe flash version 14 is installed, I get "Error loading media: File could not be played" Has anyone else experience this issue?

Have you tried uninstalling firefox and then reinstall?  I have this similar problem both with explorer and firefox. Firefox is now working after reinstall but my explorer is still isn't working.  Not sure how much it will help since I have absolutely no idea why it worked for firefox and not with explorer.  Good luck though. I'm still looking for other solutions online will post back here if I find some.
Logged
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 19 queries.