Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Erreur activation d'enregistrement par mail  (Read 3312 times)

0 Members and 1 Guest are viewing this topic.

ninouee

  • Coppermine novice
  • *
  • Country: fr
  • Offline Offline
  • Gender: Female
  • Posts: 44
Erreur activation d'enregistrement par mail
« on: May 14, 2014, 10:41:50 am »

Bonjour à tous,

Lorsque quelqu'un essaie de s'enregistrer sur la galerie il y a une erreur au moment de la confirmation de l'enregistrement via le mail. La personne reçoit bien le mail mais quand elle clique sur le lien il y a un message d'erreur de ce type:

Le lien de validation ressemble à ça: http://ddstv.fr/register.php?activate=c8b74c9d02adeb6b0f077a58d6888673
Quote
404 Not Found

The requested URL /register.php was not found on this server.

Je me suis dit qu'un de mes fichiers était mal chargé sur le serveur alors j'ai tout re-chargé. Et ça n'a rien changé.

Puis j'ai vu qu'il y avait une mise à jour, je l'ai donc fait en pensant que ça corrigerait l'erreur mais rien n'y a fait.


Je ne sais pas ce qui ne va pas. En attendant j'ai validé manuellement la personne.

Le lien vers ma galerie est le suivant: http://ddstv.fr/galerie/

En tappant ce message j'ai l'impression d'avoir une idée d'où vient le problème : le lien d'activation... Je crois qu'il ne mène pas au bon endroit car il manque le /galerie/ d'où cela peut-il venir?

Merci à vous pour votre aide.
Logged

ninouee

  • Coppermine novice
  • *
  • Country: fr
  • Offline Offline
  • Gender: Female
  • Posts: 44
Re: Erreur activation d'enregistrement par mail
« Reply #1 on: May 14, 2014, 07:56:40 pm »

J'ai cherché et j'ai trouvé!

Voila la solution au cas où cela arriverait à d'autres.

Ma galerie n'est pas à la base du site car j'ai aussi un forum et une encyclopédie.
Cela donne:
Index/galerie
Index/forum
...

Le liens de confirmation d'enregistrement envoyé par mail menait à: Index/register.php le site ne tenais donc pas compte de mon arborescence et menait à une erreur.
j'ai donc modifié le fichier "register.php", à la ligne 615 où on trouve les éléments suivants:

Code: [Select]
// Registrations must be activated/verified by the user clicking a link in an email
    if ($CONFIG['reg_requires_valid_email']) {
        // Mail the user the activation/verification link
        $act_link = rtrim($CONFIG['site_url'], '/') . '/register.php?activate=' . $act_key;

        $template_vars = array(
            '{SITE_NAME}' => $CONFIG['gallery_name'],
            '{USER_NAME}' => $user_name,
            '{ACT_LINK}'  => $act_link,
        );

Il faut ajouter dans la ligne
Code: [Select]
$act_link = rtrim($CONFIG['site_url'], '/') . '/register.php?activate=' . $act_key;Le chermin du dossier dans lequel est votre galerie afin que le lien dans le mail de validation mène au bon endroit.
Pour moi j'ai du ajouter "/galerie" ce qui donne
Code: [Select]
$act_link = rtrim($CONFIG['site_url'], '/') . '/galerie/register.php?activate=' . $act_key;

Voila


J'espère que cela aidera quelqu'un.  :)
Logged

François Keller

  • Moderator
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 9096
  • aka Frantz
    • Ma galerie
Re: Erreur activation d'enregistrement par mail
« Reply #2 on: May 16, 2014, 08:34:41 am »

Est ce qu'il n'aurait pas plutôt fallu changer quelque chose dans la configuration ?
http://documentation.coppermine-gallery.net/fr/configuration.htm#admin_general_coppermine-url
Logged
Avez vous lu la DOC ? la FAQ ? et cherché sur le forum avant de poster ?
Did you read the DOC ? the FAQ ? and search the board before posting ?
Mon Blog
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 21 queries.