Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Fresh install of cpg1.5.x gone awry  (Read 4137 times)

0 Members and 1 Guest are viewing this topic.

xaero

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Fresh install of cpg1.5.x gone awry
« on: May 03, 2014, 04:58:21 pm »

I'm in the process of setting up Coppermine for myself and I ran into a hitch of sorts, I get as far as the admin creation step (#9) and I create my admin user, then it stops, the user is created successfully, but it doesn't advance to the next step, it just prompts for more newuser data. What gives?
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Fresh install of cpg1.5.x gone awry
« Reply #1 on: May 04, 2014, 10:28:47 am »

I haven't tested this myself, but what happens if you use another user name / password / email address? Please also have a look at the Coppermine database if the user has been added to the users table (e.g. with a tool like phpMyAdmin).
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4726
    • Windsurf.me
Re: Fresh install of cpg1.5.x gone awry
« Reply #2 on: May 04, 2014, 12:20:50 pm »

Another option would be to switch to the classic installer and see if that does the trick.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

xaero

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Re: Fresh install of cpg1.5.x gone awry
« Reply #3 on: May 05, 2014, 03:43:59 am »

I haven't tested this myself, but what happens if you use another user name / password / email address? Please also have a look at the Coppermine database if the user has been added to the users table (e.g. with a tool like phpMyAdmin).

Another option would be to switch to the classic installer and see if that does the trick.

It creates a new user if I supply a new user/pass combo to the installer, and I have checked the database, that's what tipped me off to this. I'll try the classic installer and let you know what happens.
Logged

xaero

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Fresh install of cpg1.5.x gone awry
« Reply #4 on: May 05, 2014, 05:58:47 am »

Doing the classic install works (it's also *MUCH* quicker.)
Logged

xaero

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Fresh install of cpg1.5.x gone awry
« Reply #5 on: May 05, 2014, 06:29:07 am »

I got it working, successfully created an album, but every upload fails. The error message says it can't create thumbnails or reduced sized images. Can't quite figure out why though. No actual error messages are printed in the server logs.
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4726
    • Windsurf.me
Re: Fresh install of cpg1.5.x gone awry
« Reply #6 on: May 05, 2014, 09:26:49 am »

Best start a new thread for that. Having said that it is almost certainly a file permissions problem. Coppermine needs to create files and folders in the albums directory so please check that. If that fails please start a new thread providing all the details requested in the upload troubleshooting section of the docs.
Logged
It is a mistake to think you can solve any major problems just with potatoes.
Pages: [1]   Go Up
 

Page created in 0.024 seconds with 19 queries.