Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Fatal error: Maximum execution time of 30 seconds exceeded  (Read 3197 times)

0 Members and 1 Guest are viewing this topic.

fran86

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 61
Fatal error: Maximum execution time of 30 seconds exceeded
« on: November 23, 2013, 12:33:22 pm »

I just updated my coppermine to the latest version and installed the imsharpen plugin. I have an error when updating all my "resized/intermediate" pictures...

Fatal error: Maximum execution time of 30 seconds exceeded in /home/**/public_html/photos/include/picmgmt.inc.php on line 625

- I have decreased the timeout to 10 seconds and it worked for a while then came the fatal error again. What do I do? If I make it even less I'll be here for hours! I have around 4,000 intermediates to update.

Thankyou for any help :)
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4886
    • Windsurf.me
Re: Fatal error: Maximum execution time of 30 seconds exceeded
« Reply #1 on: November 23, 2013, 12:59:38 pm »

Many hosts allow you to increase the max execution time. It is a setting in PHP, cot Coppermine but unless you have root access you may need to ask your host how to increase it. It is there to stop scripts running forever and crashing the server. Some hosts allow a local php.ini file and others you can simply add a line to the .htaccess file but they will be the best people to advise. Some even allow it through their cpanel. On my system I have it set at 60 seconds.

Logged
It is a mistake to think you can solve any major problems just with potatoes.

fran86

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 61
Re: Fatal error: Maximum execution time of 30 seconds exceeded
« Reply #2 on: November 23, 2013, 01:10:07 pm »

Ah alright. I think I could do it myself? I have cpanel and ftp and if you mean root as in access to the directory "public_html" and the one above then yes I do. Should I be asking my host anyway before I go ahead?
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: Fatal error: Maximum execution time of 30 seconds exceeded
« Reply #3 on: November 23, 2013, 03:24:30 pm »

I suggest to update fewer files simultaneously (or try with just "1" at a time).
Logged

fran86

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 61
Re: Fatal error: Maximum execution time of 30 seconds exceeded
« Reply #4 on: November 23, 2013, 03:31:14 pm »

Yeah, I went ahead and just did 5 at a time. It went for a while longer but ended up with a connection time out. Could of been my internet or unfortunate timing for a downtime for my site. Either way I think it went well till that happened. The longer it takes the higher change it will happen to me again :( I'll have to leave my laptop on all night in hopes it will all go through.
Logged
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 19 queries.