Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Critical error There was an error while processing a database query  (Read 4714 times)

0 Members and 1 Guest are viewing this topic.

laurenmarie14

  • Coppermine newbie
  • Offline Offline
  • Posts: 1

Hi all,

I just went to upload something onto my website's gallery, and received this error message:

Critical error
There was an error while processing a database query

I haven't updated anything recently and everything was working fine until just now. I get the same error message whether I am logged in or not.

Can someone please help? Thanks!!
Logged

Jeff Bailey

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1322
  • Fishing relaxes me.
    • Bailey Family Co.
Re: Critical error There was an error while processing a database query
« Reply #1 on: November 11, 2013, 09:14:00 pm »

Usually this has something to do with 'includes/config.inc.php' (Didn't notice this was on the uploads board) but we'll need the full error to help.
A link would also be useful. http://forum.coppermine-gallery.net/index.php/topic,55415.msg270616.html#msg270616

Contact your host or look in your error logs for the full error.
« Last Edit: November 14, 2013, 08:41:46 pm by Jeff Bailey »
Logged
Thinking is the hardest work there is, which is probably the reason why so few engage in it. - Henry Ford

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15760
Re: Critical error There was an error while processing a database query
« Reply #2 on: November 14, 2013, 02:00:59 pm »

Maybe we can find out what's wrong without contacting your host if you enable debug mode in the config. If so, you'll get an extended error message. Please post it here.

Additionally: http://documentation.coppermine-gallery.net/en/upload_troubleshooting.htm
Logged

sjj1805

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 30
Re: Critical error There was an error while processing a database query
« Reply #3 on: April 05, 2014, 02:28:37 pm »

Having had this same error appear on 4 of my 5 computers I spent a couple of weeks trying to resolve this. The Odd thing at the time was that the gallery worked perfectly on the 5th computer but all 5 computers were "Carbon copies" of each other (as far as the coppermine gallery was concerned.

Having now resolved this issue I thought I would share what eventually cured my issue in the hope others may benefit:

[size=150]Symptoms:[/size]
Kept getting this error every time I tried to open an Album. Thumbnails displayed OK but clicking the thumbnail to enter the album brought up this error.
If I deleted the full size image from the hard drive the album would open up. The coppermine gallery was an exact carbon copy of a gallery on another computer but the other computer did not have this fault.

Steps taken to try and resolve the issue (All failed)
Replaced the entire coppermine installation with the one from the working computer.
Replaced the PHP.INI file with the one from the working computer
Usual troubleshooting of a computer such as chkdsk, clear out temporary files, webcache etc.
Searched the Coppermine User Forum for possible answers.

What eventually resolved the error was the MySQL settings.
It would seem that the MySQL server must have been timing out when attempting to load the larger images.
Action taken to achieve this:
Go to the MSQL installation directory and then open the "BIN" folder. In here you have a file named
MySQLInstanceConfig.exe
Run this and choose to reconfigure your installation. When you get to the 3 choices:
Developer Machine
Server Machine
Dedicated MySQL Server Machine

Make sure you DO NOT select the Developer machine - select one of the other two.
Job Done
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4826
    • Windsurf.me

What you are suggesting is only possible on those with root access (and even then only on certain builds) which a large percentage of users do not have. Those with root access would usually be able to look at the server error logs to see exactly what the problem is. Rather than changing mode better to edit the parameters that are causing the issue in the my.ini file.
Logged
It is a mistake to think you can solve any major problems just with potatoes.
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 20 queries.