Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: stuck on connection with db (newb)  (Read 3497 times)

0 Members and 1 Guest are viewing this topic.

brynn

  • Coppermine frequent poster
  • ***
  • Country: us
  • Offline Offline
  • Gender: Female
  • Posts: 198
    • Inkscape Commmunity
stuck on connection with db (newb)
« on: September 12, 2013, 12:15:42 am »

Hi Friends,
Yesterday, I successfully installed CPG to a subdomain I have that I use only for testing stuff.  I'm new to webmastering/admin-ing, and this is only the 2nd time I've tried to install something (manually).  So I wanted to try it on the test subdomain, in case anything goes wrong.  Anyway, it installed successfully, but I couldn't bridge it to my forum (according to my understanding of the manual) from there.  So today, I'm trying to install it to my main domain.

As such a newbie, I didn't see any reason why I couldn't use the same db that I had created for the test gallery.  But when I got to the step (I think 8.) where it populates the db, I got an error.  The only part of the error that I could understand, said "MySQL error: Table 'cpg15x_albums' already exists on query".

I thought that probably means that the wizard can't proceed because it found the db already poplulated.  So I thought I would just create a new db.  So I do have the new db created and the new user and both connected together.  But when I go back to step 6, to make the connection to the new db, I keep getting an error which I don't understand.  Here's the error msg:

"MySQL could not locate a database called 'brynn_cpg' please check the value entered for this"

The reason I don't understand it, is because the 1st db I tried (which was the db for the gallery on the testing subdomain) is called brynn_cpg.  But now, I'm entering the new db, which is brynn_cpgic into step 6.  I don't understand why it's trying to connect to a different db than the one I'm entering into the MySQL username field.

Since I'm so new at this, I'm not sure what kind of info you might need from me.  My computer uses Windows 7, 64-bit, browser Firefox, both currently updated.  My server is cPanel, which uses Linux.  Whatever other info you might need, just ask, and I'll provide it  :)

And just for clarity, my question is how to make it recognize the new db.  Or, if there's another way to just start over from the beginning....I tried going back to the beginning, by browsing to the install page in a new browser tab, but it just goes automatically back to the same error page on step 6.  Or whatever I need to do, to continue with the installation  :)

Thank you very much  :)
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15764
Re: stuck on connection with db (newb)
« Reply #1 on: September 12, 2013, 10:26:31 am »

Delete the file include/config.tmp.php if you want to run the installer from the beginning.
Logged

brynn

  • Coppermine frequent poster
  • ***
  • Country: us
  • Offline Offline
  • Gender: Female
  • Posts: 198
    • Inkscape Commmunity
Re: stuck on connection with db (newb)
« Reply #2 on: September 13, 2013, 12:41:56 am »

Oh, thank you so much!

It's all installed successfully now  ;D
Logged
Pages: [1]   Go Up
 

Page created in 0.014 seconds with 19 queries.